summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-01-08 18:36:58 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-01-08 18:36:58 +0100
commit54f0d45709b5d5372c14c4adba63ead0159f87f2 (patch)
treeeb53564b64c55bca6421fde5fdbb79473c1fd6e3
parentsys-apps/sensei-raw-ctl: add snapshot ebuild (diff)
downloadeva-54f0d45709b5d5372c14c4adba63ead0159f87f2.tar.gz
eva-54f0d45709b5d5372c14c4adba63ead0159f87f2.tar.bz2
eva-54f0d45709b5d5372c14c4adba63ead0159f87f2.zip
sys-kernel/raspberrypi-sources: bump available releases
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Manifest-Sign-Key: C6085806
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.2.9999.ebuild (renamed from sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild)2
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.3.9999.ebuild31
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.5.9999.ebuild31
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.6.9999.ebuild31
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.7.9999.ebuild31
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.8.9999.ebuild31
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild31
7 files changed, 187 insertions, 1 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.2.9999.ebuild
index 365d847..3a132e6 100644
--- a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.19.9999.ebuild
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.2.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.3.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.3.9999.ebuild
new file mode 100644
index 0000000..3a132e6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.3.9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2
+
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${S}"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.5.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.5.9999.ebuild
new file mode 100644
index 0000000..3a132e6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.5.9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2
+
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${S}"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.6.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.6.9999.ebuild
new file mode 100644
index 0000000..3a132e6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.6.9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2
+
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${S}"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.7.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.7.9999.ebuild
new file mode 100644
index 0000000..3a132e6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.7.9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2
+
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${S}"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.8.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.8.9999.ebuild
new file mode 100644
index 0000000..3a132e6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.8.9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2
+
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${S}"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
new file mode 100644
index 0000000..3a132e6
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.9.9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+inherit kernel-2
+
+detect_version
+detect_arch
+
+inherit git-r3 versionator
+
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+EGIT_CHECKOUT_DIR="${S}"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}