summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2024-01-21 15:18:56 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2024-01-21 15:18:56 +0100
commit5d4c007fd68aadeb5e58e6d7730551ae009d406e (patch)
tree966c68f3f5d322ac333db115f67dd206e79e795c
parentdev-python/httpagentparser: treeclean (diff)
downloadeva-5d4c007fd68aadeb5e58e6d7730551ae009d406e.tar.gz
eva-5d4c007fd68aadeb5e58e6d7730551ae009d406e.tar.bz2
eva-5d4c007fd68aadeb5e58e6d7730551ae009d406e.zip
dev-util/deskzilla: treeclean
Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--dev-util/deskzilla/Manifest11
-rw-r--r--dev-util/deskzilla/deskzilla-3.1.ebuild104
-rw-r--r--dev-util/deskzilla/files/deskzilla_gentoo.licensebin1584 -> 0 bytes
-rw-r--r--dev-util/deskzilla/metadata.xml8
4 files changed, 0 insertions, 123 deletions
diff --git a/dev-util/deskzilla/Manifest b/dev-util/deskzilla/Manifest
deleted file mode 100644
index fced7c6..0000000
--- a/dev-util/deskzilla/Manifest
+++ /dev/null
@@ -1,11 +0,0 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA512
-
-DIST deskzilla-3_1_without_jre.tar.gz 14040899 SHA256 075a5949bcc42c501d91a89d58364f0c28c8b5817a5c8e260777c2c4088d4846 SHA512 564838b6b89781220bb76df0f8bcde7923221039635ce033f37f6ac4297ac862dc58cd312c11e8a82c6bea1a4d16be42023cef5fd71dfdbaf50cf881009c8271 WHIRLPOOL 21a29b45e00d44b6619fdc6b3a022634794fc123671f88517aeb5d9517baea281d0cb65da11b679f7fed71d7b32ce9b43492c63b273f3f5501d1fbc06587285b
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.19 (GNU/Linux)
-
-iEYEAREKAAYFAlC2liUACgkQ1fmVwcYIWAbyhgCglhwivv+vEcz6+zxfLO52CEbT
-P18AoLVsQhQhr+x8Wv/6v6XTmkd8SOg/
-=hVj2
------END PGP SIGNATURE-----
diff --git a/dev-util/deskzilla/deskzilla-3.1.ebuild b/dev-util/deskzilla/deskzilla-3.1.ebuild
deleted file mode 100644
index ca5ee22..0000000
--- a/dev-util/deskzilla/deskzilla-3.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=1
-
-inherit eutils java-pkg-2 versionator
-
-DESCRIPTION="A desktop client for Mozilla's Bugzilla bug tracking system."
-HOMEPAGE="http://almworks.com/deskzilla"
-
-MY_PV=$(replace_all_version_separators '_') #${PV/beta/b})
-MY_P="${PN}-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
-SRC_URI="http://d1.almworks.com/.files/${MY_P}_without_jre.tar.gz"
-LICENSE="ALMWorks-1.2"
-# license does not allow redistributing, and they seem to silently update
-# distfiles...
-RESTRICT="mirror"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=virtual/jre-1.5
- dev-java/picocontainer:1
- dev-java/javolution:4
- >=dev-java/commons-codec-1.3
- >=dev-java/jgoodies-forms-1.0.7
- >=dev-java/commons-logging-1.0.4
- >=dev-java/xmlrpc-2.0.1
- dev-java/xerces:2
- dev-java/itext:0
- dev-java/jazzy:0
- >=dev-java/jna-3.2.7
- >=dev-java/sun-javamail-1.3.3
- dev-db/sqlite:3"
-
-src_unpack() {
- unpack ${A}
- # Remove external unaltered bundled jars
- local lib="${S}/lib"
- local liborig="${S}/lib.orig"
- mv ${lib} ${liborig} || die
- mkdir ${lib} || die
- # They've patched commons-httpclient (was version 3.0)
- mv ${liborig}/commons-httpclient.jar ${lib} || die
- # They've patched nekohtml (was version 0.9.5)
- mv ${liborig}/nekohtml.jar ${lib} || die
- # Also jdom (was 1.0), soon they will patch everything and we will just unpack, yay
- mv ${liborig}/pjdom.jar ${lib} || die
- # Almworks proprietary lib
- mv ${liborig}/almworks-tracker-api.jar ${lib} || die
- # IntelliJ IDEA proprietary lib
- mv ${liborig}/forms_rt.jar ${lib} || die
- # God knows what's this. Anyway, proprietary.
- mv ${liborig}/twocents.jar ${lib} || die
- # Integers ???
- mv ${liborig}/integers.jar ${lib} || die
-
- # FIXME: opensource package exists
- mv ${liborig}/sqlite4java.jar ${lib} || die
- if use amd64; then
- mv ${liborig}/libsqlite4java-linux-amd64.so ${lib} || die
- elif use i386; then
- mv ${liborig}/libsqlite4java-linux-i386.so ${lib} || die
- fi
-
- rm -rf ${liborig} || die
-}
-
-src_install () {
- local dir="/opt/${PN}"
-
- insinto "${dir}"
- doins -r components etc license lib log deskzilla.url
- insinto "${dir}/license"
- doins "${FILESDIR}"/${PN}_gentoo.license
-
- java-pkg_jarinto "${dir}"
- java-pkg_dojar ${PN}.jar
- local dep="xerces-2,picocontainer-1,commons-logging,commons-codec"
- dep+=",jgoodies-forms,javolution-4,xmlrpc,itext,jazzy"
- java-pkg_register-dependency ${dep}
- java-pkg_dolauncher ${PN} --main "com.almworks.launcher.Launcher" --java_args "-Xmx256M"
-
- newdoc README.txt README || die
- newdoc RELEASE.txt RELEASE || die
-
- doicon deskzilla.png
- make_desktop_entry deskzilla "Deskzilla" deskzilla "Development"
-}
-
-pkg_postinst() {
- elog "The default, evaluation license allows usage for one month."
- elog "You may switch (per-user) to the license we obtained for Gentoo,"
- elog "located in /opt/${PN}/license/${PN}_gentoo.license"
- elog "It is locked to Gentoo, ALM Works and Mozilla bugzilla only."
- elog "Note that you need to use 1.5 VM to run deskzilla when setting"
- elog "license or it won't get set due to bug in 1.6+ VMs."
- elog
- elog "If you are going to use Deskzilla for an open source project,"
- elog "you can similarly request your own free license:"
- elog "http://almworks.com/opensource.html?product=deskzilla"
-}
diff --git a/dev-util/deskzilla/files/deskzilla_gentoo.license b/dev-util/deskzilla/files/deskzilla_gentoo.license
deleted file mode 100644
index 4c8825b..0000000
--- a/dev-util/deskzilla/files/deskzilla_gentoo.license
+++ /dev/null
Binary files differ
diff --git a/dev-util/deskzilla/metadata.xml b/dev-util/deskzilla/metadata.xml
deleted file mode 100644
index 2444066..0000000
--- a/dev-util/deskzilla/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-</pkgmetadata>