summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wyd/wyd-0.2.ebuild')
-rw-r--r--net-analyzer/wyd/wyd-0.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/wyd/wyd-0.2.ebuild b/net-analyzer/wyd/wyd-0.2.ebuild
new file mode 100644
index 0000000..9d791fd
--- /dev/null
+++ b/net-analyzer/wyd/wyd-0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit perl-module
+
+DESCRIPTION="A password profiler"
+HOMEPAGE="http://www.remote-exploit.org/codes_wyd.html"
+SRC_URI="http://www.remote-exploit.org/codes/wyd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="catdoc jhead mp3info xpdf"
+#IUSE="catdoc jhead mp3info pdf oodoc"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ catdoc? ( app-text/catdoc )
+ jhead? ( media-gfx/jhead )
+ mp3info? ( media-sound/mp3info )
+ xpdf? ( app-text/xpdf )"
+
+src_install() {
+ exeinto /usr/bin
+ doexe wyd.pl
+ dodoc BUGS TODO README CHANGES || die
+ docinto docs
+ dodoc docs/* || die
+ insinto "/usr/share/doc/${P}/testfiles"
+ doins testfiles/* || die
+
+ perlinfo
+
+ insinto "${VENDOR_LIB}/wlgmod"
+ doins wlgmod/*.pm
+
+ elog "Be aware that wyd will try to call wlgmod::odt, which needs"
+ elog "OpenOffice::OODoc (http://www.cpan.org/modules/index.html)."
+ elog "wyd.pl will bails, that's normal."
+ elog "You can help in integrating all the features of wyd by porting"
+ elog "OpenOffice::OODoc to Gentoo."
+
+}
+