summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2020-08-05 07:01:00 +0200
committerHans de Graaff <hans@degraaff.org>2020-08-05 07:01:00 +0200
commit5e0490311c08f70dda68ae940efeb26a4933d845 (patch)
tree8f7b09ed32f247a344ef47b1a32501008dc0623c /dev-ruby/rotp/rotp-5.0.0.ebuild
parentapp-forensics/brakeman: cleanup (diff)
downloadgraaff-5e0490311c08f70dda68ae940efeb26a4933d845.tar.gz
graaff-5e0490311c08f70dda68ae940efeb26a4933d845.tar.bz2
graaff-5e0490311c08f70dda68ae940efeb26a4933d845.zip
Revert "dev-ruby/rotp: cleanup"
This reverts commit 9ea2b0ce0f91bfbf61a9b11c45a0dde42916500f. Still needed for active_model_otp Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/rotp/rotp-5.0.0.ebuild')
-rw-r--r--dev-ruby/rotp/rotp-5.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rotp/rotp-5.0.0.ebuild b/dev-ruby/rotp/rotp-5.0.0.ebuild
new file mode 100644
index 00000000..8c39f997
--- /dev/null
+++ b/dev-ruby/rotp/rotp-5.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Works for both HOTP and TOTP, and includes QR Code provisioning"
+HOMEPAGE="https://github.com/mdp/rotp"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.5:0
+"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/timecop )
+"
+
+all_ruby_prepare() {
+ # Remove pregenerated documentation so we can update it.
+ rm -rf doc || die
+
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}