summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2023-02-24 08:49:54 +0100
committerHans de Graaff <hans@degraaff.org>2023-02-24 08:49:54 +0100
commitc29b4ed721cf4f5630d4177a8ea93a69ca6cf8d3 (patch)
tree2bf2711aa8eb8725aeb282f71d7aa423b649bd3e /dev-ruby/rubocop-capybara
parentdev-ruby/rubocop: add 1.46.0 (diff)
downloadgraaff-c29b4ed721cf4f5630d4177a8ea93a69ca6cf8d3.tar.gz
graaff-c29b4ed721cf4f5630d4177a8ea93a69ca6cf8d3.tar.bz2
graaff-c29b4ed721cf4f5630d4177a8ea93a69ca6cf8d3.zip
dev-ruby/rubocop-capybara: new package, add 2.17.1
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/rubocop-capybara')
-rw-r--r--dev-ruby/rubocop-capybara/Manifest1
-rw-r--r--dev-ruby/rubocop-capybara/metadata.xml9
-rw-r--r--dev-ruby/rubocop-capybara/rubocop-capybara-2.17.1.ebuild30
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-capybara/Manifest b/dev-ruby/rubocop-capybara/Manifest
new file mode 100644
index 00000000..c09c460f
--- /dev/null
+++ b/dev-ruby/rubocop-capybara/Manifest
@@ -0,0 +1 @@
+DIST rubocop-capybara-2.17.1.tar.gz 29094 BLAKE2B 28ec120edf9dd6732bc642d30ce4aa3e3309dcdb7392bf9033e30f790329ae6f23bf0d49fcf180ec9f676edc44f61dd4d98a395cf5ecd790f13e8f5968404eac SHA512 b75c7ee783d78dd81fd3d0a41c0967604b11638c1e68a5ed065710131001e564d398ac4d22713d3877f8eedd0e80fc7c0e2b680e86f12ec9505b78387aefbf33
diff --git a/dev-ruby/rubocop-capybara/metadata.xml b/dev-ruby/rubocop-capybara/metadata.xml
new file mode 100644
index 00000000..3974c401
--- /dev/null
+++ b/dev-ruby/rubocop-capybara/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person"><email>graaff@gentoo.org</email></maintainer>
+ <upstream>
+ <remote-id type="github">rubocop/rubocop-capybara</remote-id>
+ <remote-id type="rubygems">rubocop-capybara</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rubocop-capybara/rubocop-capybara-2.17.1.ebuild b/dev-ruby/rubocop-capybara/rubocop-capybara-2.17.1.ebuild
new file mode 100644
index 00000000..a753146b
--- /dev/null
+++ b/dev-ruby/rubocop-capybara/rubocop-capybara-2.17.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-capybara.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code style checking for RSpec files"
+HOMEPAGE="https://github.com/rubocop/rubocop-capybara"
+SRC_URI="https://github.com/rubocop/rubocop-capybara/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rubocop-1* >=dev-ruby/rubocop-1.41
+"