summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dry-core/dry-core-0.8.1.ebuild')
-rw-r--r--dev-ruby/dry-core/dry-core-0.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/dry-core/dry-core-0.8.1.ebuild b/dev-ruby/dry-core/dry-core-0.8.1.ebuild
new file mode 100644
index 00000000..b6cf8852
--- /dev/null
+++ b/dev-ruby/dry-core/dry-core-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="dry-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolset of small support modules used throughout the dry-rb ecosystem"
+
+HOMEPAGE="https://dry-rb.org/gems/dry-core"
+SRC_URI="https://github.com/dry-rb/dry-core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+# Skip tests for now to avoid circular dependencies.
+RESTRICT=test
+
+ruby_add_rdepend "
+ dev-ruby/concurrent-ruby:1
+"
+
+#ruby_add_bdepend "test? (
+# dev-ruby/dry-types
+#)"