summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-10-12 11:00:26 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-10-12 11:00:26 +0000
commit47a6e5d26253b14a6c57dce87553551282059374 (patch)
tree5509d8e9092b1aedb6588845e00bab52cbe22e07 /app-i18n/uim-svn/uim-svn-1.5.ebuild
parentreplace DEFAULT_BROWSER_CMD to firefox. (diff)
downloadhattya-47a6e5d26253b14a6c57dce87553551282059374.tar.gz
hattya-47a6e5d26253b14a6c57dce87553551282059374.tar.bz2
hattya-47a6e5d26253b14a6c57dce87553551282059374.zip
sync with CVS.
svn path=/; revision=12
Diffstat (limited to 'app-i18n/uim-svn/uim-svn-1.5.ebuild')
-rw-r--r--app-i18n/uim-svn/uim-svn-1.5.ebuild83
1 files changed, 43 insertions, 40 deletions
diff --git a/app-i18n/uim-svn/uim-svn-1.5.ebuild b/app-i18n/uim-svn/uim-svn-1.5.ebuild
index dc6f068..0092407 100644
--- a/app-i18n/uim-svn/uim-svn-1.5.ebuild
+++ b/app-i18n/uim-svn/uim-svn-1.5.ebuild
@@ -7,10 +7,10 @@ inherit elisp-common flag-o-matic kde-functions multilib subversion
IUSE="X anthy canna dict eb emacs fep gtk immqt libedit m17n-lib nls qt3"
DESCRIPTION="a multilingual input method library"
-HOMEPAGE="http://uim.freedesktop.org/"
+HOMEPAGE="http://code.google.com/p/uim/"
SRC_URI=""
-LICENSE="|| (BSD GPL-2 LGPL-2.1)"
+LICENSE="|| ( BSD GPL-2 LGPL-2.1 )"
KEYWORDS="~x86"
SLOT="0"
@@ -22,23 +22,17 @@ DEPEND="${RDEPEND}
dev-lang/perl
dev-lang/ruby
app-text/asciidoc
- X? ( || ( (
- x11-proto/xextproto
- x11-proto/xproto
- )
- virtual/x11 ) )
+ X? ( x11-proto/xextproto
+ x11-proto/xproto )
nls? ( virtual/libintl )"
RDEPEND="!app-i18n/uim
- X? ( || ( (
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXext
- x11-libs/libXrender
- )
- virtual/x11 ) )
+ X? ( x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXrender )
anthy? ( || ( app-i18n/anthy app-i18n/anthy-ss ) )
canna? ( app-i18n/canna )
eb? ( dev-libs/eb )
@@ -51,7 +45,16 @@ RDEPEND="!app-i18n/uim
src_unpack() {
- local repo_uri="http://anonsvn.freedesktop.org/svn/uim"
+ local repo_uri="http://uim.googlecode.com/svn"
+
+ subversion_wc_info ${repo_uri}/trunk
+
+ if [[ $? -eq 0 ]] && [ "${ESVN_WC_URL}" != "${repo_uri}/trunk" ]; then
+ eerror "uim's repository is moved to Google Code."
+ eerror "please remove ${ESVN_STORE_DIR}/${ESVN_PROJECT}."
+
+ die
+ fi
subversion_fetch ${repo_uri}/trunk
subversion_fetch ${repo_uri}/sigscheme-trunk sigscheme
@@ -90,6 +93,7 @@ src_compile() {
econf \
$(use_enable emacs) \
+ $(use_with emacs lispdir "${SITELISP}") \
$(use_enable fep) \
$(use_enable nls) \
$(use_with X x) \
@@ -129,29 +133,18 @@ src_install() {
done
if use emacs; then
- local im
-
- if has_version app-i18n/anthy || has_version app-i18n/anthy-ss; then
- im="anthy"
-
- elif has_version app-i18n/prime; then
- im="prime"
-
- else
- im="skk"
-
- fi
-
- elisp-site-file-install "${FILESDIR}"/50uim-gentoo.el
- dosed "s:@IM@:${im}:" ${SITELISP}/50uim-gentoo.el
+ cd "${D}/${SITELISP}"/uim-el
+ elisp-comp *.el || die
+ cd -
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el uim-el
fi
- # move sigscheme documents into ${P}
- mv ${D}/usr/share/doc/{sigscheme,${P}/}
+ # remove empty directories
+ rm -rf "${D}"/usr/include/sigscheme
+ rm -rf "${D}"/usr/include/libgcroots
- # remove sigscheme headers and a pkgconfig file
- rm -rf ${D}/usr/include/sigscheme
- rm -f ${D}/usr/lib/pkgconfig/sigscheme.pc
+ # remove unnecessary header
+ rm -f "${D}"/usr/include/gcroots.h
}
@@ -161,7 +154,17 @@ pkg_postinst() {
has_multilib_profile && chost=${CHOST}
use gtk && gtk-query-immodules-2.0 > "${ROOT}"/etc/gtk-2.0/${chost}/gtk.immodules
- use emacs && elisp-site-regen
+
+ if use emacs; then
+ elisp-site-regen
+
+ echo
+ elog "uim is autoloaded with Emacs with a minimal set of"
+ elog "features: There is no keybinding defined to call it directly,"
+ elog "so please create one yourself and choose an input method."
+ elog "Integration with LEIM is not done with this ebuild, please have a look"
+ elog "at the documentation how to achieve this."
+ fi
}
@@ -171,7 +174,7 @@ pkg_postrm() {
has_multilib_profile && chost=${CHOST}
use gtk && gtk-query-immodules-2.0 > "${ROOT}"/etc/gtk-2.0/${chost}/gtk.immodules
- has_version virtual/emacs && elisp-site-regen
+ use emacs && elisp-site-regen
}