summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-06-02 18:52:13 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-06-02 18:52:13 +0900
commitdd56d20d780ebe8f5fcc007d4f54cd5f1c1095bf (patch)
tree446d3942c3e10efc13117c4a176eeba5830a204a
parentsys-apps/portage: use gentoo main repo. (diff)
downloadheroxbd-dd56d20d780ebe8f5fcc007d4f54cd5f1c1095bf.tar.gz
heroxbd-dd56d20d780ebe8f5fcc007d4f54cd5f1c1095bf.tar.bz2
heroxbd-dd56d20d780ebe8f5fcc007d4f54cd5f1c1095bf.zip
dev-lang/perl: sync with main repo, drop perl-5.18.
-rw-r--r--dev-lang/perl/files/eblits/common-v50160001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/common-v50240001.eblit71
-rw-r--r--dev-lang/perl/files/eblits/pkg_postinst-v50160001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/pkg_postinst-v50240001.eblit36
-rw-r--r--dev-lang/perl/files/eblits/pkg_postrm-v50160001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/pkg_postrm-v50240001.eblit7
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit66
-rw-r--r--dev-lang/perl/files/eblits/src_configure-v50180002.eblit55
-rw-r--r--dev-lang/perl/files/eblits/src_configure-v50240001.eblit188
-rw-r--r--dev-lang/perl/files/eblits/src_install-v50160001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/src_install-v50200001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/src_install-v50240001.eblit51
-rw-r--r--dev-lang/perl/files/eblits/src_prepare-v50160001.eblit2
-rw-r--r--dev-lang/perl/files/eblits/src_prepare-v50240001.eblit72
-rw-r--r--dev-lang/perl/files/eblits/src_test-v50160001.eblit2
-rw-r--r--dev-lang/perl/perl-5.24.0.ebuild (renamed from dev-lang/perl/perl-5.20.2-r1.ebuild)66
17 files changed, 577 insertions, 51 deletions
diff --git a/dev-lang/perl/files/eblits/common-v50160001.eblit b/dev-lang/perl/files/eblits/common-v50160001.eblit
index e108d2a..2a8d815 100644
--- a/dev-lang/perl/files/eblits/common-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/common-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/common-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Id$
src_remove_dual_file() {
local i pkg ver
diff --git a/dev-lang/perl/files/eblits/common-v50240001.eblit b/dev-lang/perl/files/eblits/common-v50240001.eblit
new file mode 100644
index 0000000..2a8d815
--- /dev/null
+++ b/dev-lang/perl/files/eblits/common-v50240001.eblit
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+src_remove_dual_file() {
+ local i pkg ver
+ pkg="$1"
+ ver="$2"
+ shift 2
+ case "${EBUILD_PHASE:-none}" in
+ postinst|postrm)
+ for i in "$@" ; do
+ alternatives_auto_makesym "${i}" "${i}-[0-9]*"
+ done
+ ;;
+ setup)
+ for i in "$@" ; do
+ if [[ -f ${EROOT}${i} && ! -h ${EROOT}${i} ]] ; then
+ has_version ${pkg} && ewarn "You must reinstall ${pkg} !"
+ break
+ fi
+ done
+ ;;
+ install)
+ for i in "$@" ; do
+ if ! [[ -f "${ED}"${i} ]] ; then
+ ewarn "${i} does not exist!"
+ continue
+ fi
+ mv "${ED}"${i}{,-${ver}-${P}} || die
+ done
+ ;;
+ esac
+}
+
+src_remove_dual_man() {
+ local i pkg ver ff
+ pkg="$1"
+ ver="$2"
+ shift 2
+ case "${EBUILD_PHASE:-none}" in
+ postinst|postrm)
+ for i in "$@" ; do
+ ff=`echo "${EROOT}${i%.[0-9]}-${ver}-${P}${i#${i%.[0-9]}}"*`
+ ff=${ff##*${i#${i%.[0-9]}}}
+ alternatives_auto_makesym "${i}${ff}" "${i%.[0-9]}-[0-9]*"
+ done
+ ;;
+ install)
+ for i in "$@" ; do
+ if ! [[ -f "${ED}"${i} ]] ; then
+ ewarn "${i} does not exist!"
+ continue
+ fi
+ mv "${ED}"${i} "${ED}"${i%.[0-9]}-${ver}-${P}${i#${i%.[0-9]}} || die
+ done
+ ;;
+ esac
+}
+
+src_remove_dual() {
+ local i pkg ver
+ pkg="$1"
+ ver="$2"
+ shift 2
+ for i in "$@" ; do
+ src_remove_dual_file "${pkg}" "${ver}" "/usr/bin/${i}"
+ src_remove_dual_man "${pkg}" "${ver}" "/usr/share/man/man1/${i}.1"
+ done
+}
+
diff --git a/dev-lang/perl/files/eblits/pkg_postinst-v50160001.eblit b/dev-lang/perl/files/eblits/pkg_postinst-v50160001.eblit
index ad743bc..cc864d0 100644
--- a/dev-lang/perl/files/eblits/pkg_postinst-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_postinst-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/pkg_postinst-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Id$
eblit-perl-pkg_postinst() {
dual_scripts
diff --git a/dev-lang/perl/files/eblits/pkg_postinst-v50240001.eblit b/dev-lang/perl/files/eblits/pkg_postinst-v50240001.eblit
new file mode 100644
index 0000000..2603ef4
--- /dev/null
+++ b/dev-lang/perl/files/eblits/pkg_postinst-v50240001.eblit
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-pkg_postinst() {
+ dual_scripts
+
+ if [[ "${ROOT}" = "/" ]] ; then
+ local INC DIR file
+ INC=$(perl -e 'for $line (@INC) { next if $line eq "."; next if $line =~ m/'${SHORT_PV}'|etc|local|perl$/; print "$line\n" }')
+ einfo "Removing old .ph files"
+ for DIR in ${INC} ; do
+ if [[ -d "${DIR}" ]] ; then
+ for file in $(find "${DIR}" -name "*.ph" -type f ) ; do
+ rm -f "${file}"
+ einfo "<< ${file}"
+ done
+ fi
+ done
+ # Silently remove the now empty dirs
+ for DIR in ${INC} ; do
+ if [[ -d "${DIR}" ]] ; then
+ find "${DIR}" -depth -type d -print0 | xargs -0 -r rmdir &> /dev/null
+ fi
+ done
+
+# einfo "Converting C header files to the corresponding Perl format (ignore any error)"
+# # Prefix note: unprefixed as this is all kernel/libc stuff that we never provide
+# pushd /usr/include >/dev/null
+# h2ph -Q -a -d "${EPREFIX}"${ARCH_LIB} \
+# asm/termios.h syscall.h syslimits.h syslog.h sys/ioctl.h \
+# sys/socket.h sys/time.h wait.h sysexits.h
+# popd >/dev/null
+
+ fi
+}
diff --git a/dev-lang/perl/files/eblits/pkg_postrm-v50160001.eblit b/dev-lang/perl/files/eblits/pkg_postrm-v50160001.eblit
index a4d5ad6..02b5944 100644
--- a/dev-lang/perl/files/eblits/pkg_postrm-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_postrm-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/pkg_postrm-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Id$
eblit-perl-pkg_postrm(){
dual_scripts
diff --git a/dev-lang/perl/files/eblits/pkg_postrm-v50240001.eblit b/dev-lang/perl/files/eblits/pkg_postrm-v50240001.eblit
new file mode 100644
index 0000000..ed98a86
--- /dev/null
+++ b/dev-lang/perl/files/eblits/pkg_postrm-v50240001.eblit
@@ -0,0 +1,7 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-pkg_postrm(){
+ dual_scripts
+}
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
index f8d01f8..a7b734f 100644
--- a/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit,v 1.2 2013/11/22 08:56:13 haubi Exp $
+# $Id$
eblit-perl-pkg_setup() {
case ${CHOST} in
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit
new file mode 100644
index 0000000..9ce8e99
--- /dev/null
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-pkg_setup() {
+ case ${CHOST} in
+ *-freebsd*) osname="freebsd" ;;
+ *-dragonfly*) osname="dragonfly" ;;
+ *-netbsd*) osname="netbsd" ;;
+ *-openbsd*) osname="openbsd" ;;
+ *-darwin*) osname="darwin" ;;
+ *-interix*) osname="interix" ;;
+ *-aix*) osname="aix" ;;
+ *) osname="linux" ;;
+ esac
+
+ myarch="${CHOST%%-*}-${osname}"
+ if use debug ; then
+ myarch+="-debug"
+ fi
+ if use ithreads ; then
+ mythreading="-multi"
+ myarch+="-thread"
+ fi
+
+ LIBPERL="libperl$(get_libname ${MY_PV} )"
+ PRIV_LIB="/usr/$(get_libdir)/perl5/${MY_PV}"
+ ARCH_LIB="/usr/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}"
+ SITE_LIB="/usr/local/$(get_libdir)/perl5/${MY_PV}"
+ SITE_ARCH="/usr/local/$(get_libdir)/perl5/${MY_PV}/${myarch}${mythreading}"
+ VENDOR_LIB="/usr/$(get_libdir)/perl5/vendor_perl/${MY_PV}"
+ VENDOR_ARCH="/usr/$(get_libdir)/perl5/vendor_perl/${MY_PV}/${myarch}${mythreading}"
+
+ if use ithreads ; then
+ echo ""
+ ewarn "THREADS WARNING"
+ ewarn "PLEASE NOTE: You are compiling ${MY_P} with interpreter-level threading enabled."
+ ewarn "Threading is not supported by all applications that compile against perl. You"
+ ewarn "use threading at your own discretion."
+ fi
+ check_rebuild
+ dual_scripts
+}
+
+check_rebuild() {
+ if has_version "<dev-lang/perl-${SHORT_PV}" ; then
+ echo ""
+ ewarn "UPDATE THE PERL MODULES:"
+ ewarn "After updating dev-lang/perl the installed Perl modules will"
+ ewarn "have to be re-installed. In most cases, this is done automatically"
+ ewarn "by the package manager, but you should still call perl-cleaner to"
+ ewarn "make sure your system is consistent."
+ ewarn "Use: perl-cleaner --all"
+ elif has_version dev-lang/perl ; then
+ if ( use ithreads && ! has_version dev-lang/perl[ithreads] ) || \
+ ( ! use ithreads && has_version dev-lang/perl[ithreads] ) || \
+ ( use debug && ! has_version dev-lang/perl[debug] ) || \
+ ( ! use debug && has_version dev-lang/perl[debug] ) ; then
+ echo ""
+ ewarn "TOGGLED USE-FLAGS WARNING:"
+ ewarn "You changed one of the use-flags ithreads or debug."
+ ewarn "You must rebuild all perl-modules installed."
+ ewarn "Use: perl-cleaner --modules ; perl-cleaner --force --libperl"
+ fi
+ fi
+}
diff --git a/dev-lang/perl/files/eblits/src_configure-v50180002.eblit b/dev-lang/perl/files/eblits/src_configure-v50180002.eblit
index 7a2460c..05fa86b 100644
--- a/dev-lang/perl/files/eblits/src_configure-v50180002.eblit
+++ b/dev-lang/perl/files/eblits/src_configure-v50180002.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_configure-v50180002.eblit,v 1.3 2014/09/26 11:00:50 grobian Exp $
+# $Id$
myconf() {
# the myconf array is declared in src_configure
@@ -74,8 +74,10 @@ eblit-perl-src_configure() {
[[ ${ELIBC} == "FreeBSD" ]] && myconf "-Dlibc=/usr/$(get_libdir)/libc.a"
- # Make sure we can do the final link #523730
- [[ ${CHOST} == *-darwin* ]] && myconf "-Dld=$(tc-getCC)"
+ # Make sure we can do the final link #523730, need to set deployment
+ # target to override hardcoded 10.3 which breaks on modern OSX
+ [[ ${CHOST} == *-darwin* ]] && \
+ myconf "-Dld=env MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET} $(tc-getCC)"
# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
# Prefix itself we don't do multilib either, so make sure perl can find
@@ -90,10 +92,6 @@ eblit-perl-src_configure() {
# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.
local paths="/lib/*-linux-gnu /usr/lib/*-linux-gnu /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 /lib /usr/lib"
myconf "-Dlibpth=${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir) ${paths}"
-
- # Configure checks for /system/lib/libandroid.so to override linux into linux-android,
- # which is not intended for Gentoo
- sed -i "/libandroid.so/d" Configure || die "sed failed"
elif [[ $(get_libdir) != "lib" ]] ; then
# We need to use " and not ', as the written config.sh use ' ...
myconf "-Dlibpth=/usr/local/$(get_libdir) /$(get_libdir) /usr/$(get_libdir)"
@@ -109,6 +107,46 @@ eblit-perl-src_configure() {
myconf -Dnoextensions="${disabled_extensions}"
+ echo Configuring Perl as follows:
+ echo sh Configure \
+ -des \
+ -Duseshrplib \
+ -Darchname="${myarch}" \
+ -Dcc="$(tc-getCC)" \
+ -Doptimize="${CFLAGS}" \
+ -Dldflags="${LDFLAGS}" \
+ -Dprefix="${EPREFIX}"'/usr' \
+ -Dinstallprefix="${EPREFIX}"'/usr' \
+ -Dsiteprefix="${EPREFIX}"'/usr/local' \
+ -Dvendorprefix="${EPREFIX}"'/usr' \
+ -Dscriptdir="${EPREFIX}"'/usr/bin' \
+ -Dprivlib="${EPREFIX}${PRIV_LIB}" \
+ -Darchlib="${EPREFIX}${ARCH_LIB}" \
+ -Dsitelib="${EPREFIX}${SITE_LIB}" \
+ -Dsitearch="${EPREFIX}${SITE_ARCH}" \
+ -Dvendorlib="${EPREFIX}${VENDOR_LIB}" \
+ -Dvendorarch="${EPREFIX}${VENDOR_ARCH}" \
+ -Dman1dir="${EPREFIX}"/usr/share/man/man1 \
+ -Dman3dir="${EPREFIX}"/usr/share/man/man3 \
+ -Dsiteman1dir="${EPREFIX}"/usr/local/man/man1 \
+ -Dsiteman3dir="${EPREFIX}"/usr/local/man/man3 \
+ -Dvendorman1dir="${EPREFIX}"/usr/share/man/man1 \
+ -Dvendorman3dir="${EPREFIX}"/usr/share/man/man3 \
+ -Dman1ext='1' \
+ -Dman3ext='3pm' \
+ -Dlibperl="${LIBPERL}" \
+ -Dlocincpth="${EPREFIX}"'/usr/include ' \
+ -Dglibpth="${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir)"' ' \
+ -Duselargefiles \
+ -Dd_semctl_semun \
+ -Dcf_by='Gentoo' \
+ -Dmyhostname='localhost' \
+ -Dperladmin='root@localhost' \
+ -Dinstallusrbinperl='n' \
+ -Ud_csh \
+ -Uusenm \
+ "${myconf[@]}"
+
sh Configure \
-des \
-Duseshrplib \
@@ -146,8 +184,5 @@ eblit-perl-src_configure() {
-Dinstallusrbinperl='n' \
-Ud_csh \
-Uusenm \
- -Dsh="${EPREFIX}"/bin/sh \
- -Dtargetsh="${EPREFIX}"/bin/sh \
- -Dsysroot="${EROOT}" \
"${myconf[@]}" || die "Unable to configure"
}
diff --git a/dev-lang/perl/files/eblits/src_configure-v50240001.eblit b/dev-lang/perl/files/eblits/src_configure-v50240001.eblit
new file mode 100644
index 0000000..05fa86b
--- /dev/null
+++ b/dev-lang/perl/files/eblits/src_configure-v50240001.eblit
@@ -0,0 +1,188 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+myconf() {
+ # the myconf array is declared in src_configure
+ myconf=( "${myconf[@]}" "$@" )
+}
+
+eblit-perl-src_configure() {
+ declare -a myconf
+
+ export LC_ALL="C"
+ [[ ${COLUMNS:-1} -ge 1 ]] || unset COLUMNS # bug #394091
+
+ # some arches and -O do not mix :)
+ use ppc && replace-flags -O? -O1
+ # Perl has problems compiling with -Os in your flags with glibc
+ use elibc_uclibc || replace-flags "-Os" "-O2"
+ # This flag makes compiling crash in interesting ways
+ filter-flags "-malign-double"
+ # Fixes bug #97645
+ use ppc && filter-flags "-mpowerpc-gpopt"
+ # Fixes bug #143895 on gcc-4.1.1
+ filter-flags "-fsched2-use-superblocks"
+
+ use sparc && myconf -Ud_longdbl
+
+ export BUILD_BZIP2=0
+ export BZIP2_INCLUDE=${EPREFIX}/usr/include
+ export BZIP2_LIB=${EPREFIX}/usr/$(get_libdir)
+
+ export BUILD_ZLIB=False
+ export ZLIB_INCLUDE=${EPREFIX}/usr/include
+ export ZLIB_LIB=${EPREFIX}/usr/$(get_libdir)
+
+ # allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
+
+ myndbm='U'
+ mygdbm='U'
+ mydb='U'
+
+ if use gdbm ; then
+ mygdbm='D'
+ myndbm='D'
+ fi
+ if use berkdb ; then
+ mydb='D'
+ has_version '=sys-libs/db-1*' && myndbm='D'
+ fi
+
+ myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
+
+ if use alpha && [[ "$(tc-getCC)" = "ccc" ]] ; then
+ ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
+ myconf -Ui_db -Ui_ndbm
+ fi
+
+ use ithreads && myconf -Dusethreads
+
+ if use debug ; then
+ append-cflags "-g"
+ myconf -DDEBUGGING
+ elif [[ ${CFLAGS} == *-g* ]] ; then
+ myconf -DDEBUGGING=-g
+ else
+ myconf -DDEBUGGING=none
+ fi
+
+ if [[ -n ${PERL_OLDVERSEN} ]] ; then
+ local inclist=$(for v in ${PERL_OLDVERSEN}; do echo -n "${v}/${myarch}${mythreading} ${v} "; done )
+ myconf -Dinc_version_list="${inclist}"
+ fi
+
+ [[ ${ELIBC} == "FreeBSD" ]] && myconf "-Dlibc=/usr/$(get_libdir)/libc.a"
+
+ # Make sure we can do the final link #523730, need to set deployment
+ # target to override hardcoded 10.3 which breaks on modern OSX
+ [[ ${CHOST} == *-darwin* ]] && \
+ myconf "-Dld=env MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET} $(tc-getCC)"
+
+ # Prefix: the host system needs not to follow Gentoo multilib stuff, and in
+ # Prefix itself we don't do multilib either, so make sure perl can find
+ # something compatible.
+ if use prefix ; then
+ # Set a hook to check for each detected library whether it actually works.
+ export libscheck="
+ ( echo 'main(){}' > '${T}'/conftest.c &&
+ $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+ ) || xxx=/dev/null"
+
+ # Use all host paths that might contain useful stuff, the hook above will filter out bad choices.
+ local paths="/lib/*-linux-gnu /usr/lib/*-linux-gnu /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 /lib /usr/lib"
+ myconf "-Dlibpth=${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir) ${paths}"
+ elif [[ $(get_libdir) != "lib" ]] ; then
+ # We need to use " and not ', as the written config.sh use ' ...
+ myconf "-Dlibpth=/usr/local/$(get_libdir) /$(get_libdir) /usr/$(get_libdir)"
+ fi
+
+ # don't try building ODBM, bug #354453
+ disabled_extensions="ODBM_File"
+
+ if ! use gdbm ; then
+ # workaround for bug #157774: don't try building GDBM related stuff with USE="-gdbm"
+ disabled_extensions="${disabled_extensions} GDBM_File NDBM_File"
+ fi
+
+ myconf -Dnoextensions="${disabled_extensions}"
+
+ echo Configuring Perl as follows:
+ echo sh Configure \
+ -des \
+ -Duseshrplib \
+ -Darchname="${myarch}" \
+ -Dcc="$(tc-getCC)" \
+ -Doptimize="${CFLAGS}" \
+ -Dldflags="${LDFLAGS}" \
+ -Dprefix="${EPREFIX}"'/usr' \
+ -Dinstallprefix="${EPREFIX}"'/usr' \
+ -Dsiteprefix="${EPREFIX}"'/usr/local' \
+ -Dvendorprefix="${EPREFIX}"'/usr' \
+ -Dscriptdir="${EPREFIX}"'/usr/bin' \
+ -Dprivlib="${EPREFIX}${PRIV_LIB}" \
+ -Darchlib="${EPREFIX}${ARCH_LIB}" \
+ -Dsitelib="${EPREFIX}${SITE_LIB}" \
+ -Dsitearch="${EPREFIX}${SITE_ARCH}" \
+ -Dvendorlib="${EPREFIX}${VENDOR_LIB}" \
+ -Dvendorarch="${EPREFIX}${VENDOR_ARCH}" \
+ -Dman1dir="${EPREFIX}"/usr/share/man/man1 \
+ -Dman3dir="${EPREFIX}"/usr/share/man/man3 \
+ -Dsiteman1dir="${EPREFIX}"/usr/local/man/man1 \
+ -Dsiteman3dir="${EPREFIX}"/usr/local/man/man3 \
+ -Dvendorman1dir="${EPREFIX}"/usr/share/man/man1 \
+ -Dvendorman3dir="${EPREFIX}"/usr/share/man/man3 \
+ -Dman1ext='1' \
+ -Dman3ext='3pm' \
+ -Dlibperl="${LIBPERL}" \
+ -Dlocincpth="${EPREFIX}"'/usr/include ' \
+ -Dglibpth="${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir)"' ' \
+ -Duselargefiles \
+ -Dd_semctl_semun \
+ -Dcf_by='Gentoo' \
+ -Dmyhostname='localhost' \
+ -Dperladmin='root@localhost' \
+ -Dinstallusrbinperl='n' \
+ -Ud_csh \
+ -Uusenm \
+ "${myconf[@]}"
+
+ sh Configure \
+ -des \
+ -Duseshrplib \
+ -Darchname="${myarch}" \
+ -Dcc="$(tc-getCC)" \
+ -Doptimize="${CFLAGS}" \
+ -Dldflags="${LDFLAGS}" \
+ -Dprefix="${EPREFIX}"'/usr' \
+ -Dinstallprefix="${EPREFIX}"'/usr' \
+ -Dsiteprefix="${EPREFIX}"'/usr/local' \
+ -Dvendorprefix="${EPREFIX}"'/usr' \
+ -Dscriptdir="${EPREFIX}"'/usr/bin' \
+ -Dprivlib="${EPREFIX}${PRIV_LIB}" \
+ -Darchlib="${EPREFIX}${ARCH_LIB}" \
+ -Dsitelib="${EPREFIX}${SITE_LIB}" \
+ -Dsitearch="${EPREFIX}${SITE_ARCH}" \
+ -Dvendorlib="${EPREFIX}${VENDOR_LIB}" \
+ -Dvendorarch="${EPREFIX}${VENDOR_ARCH}" \
+ -Dman1dir="${EPREFIX}"/usr/share/man/man1 \
+ -Dman3dir="${EPREFIX}"/usr/share/man/man3 \
+ -Dsiteman1dir="${EPREFIX}"/usr/local/man/man1 \
+ -Dsiteman3dir="${EPREFIX}"/usr/local/man/man3 \
+ -Dvendorman1dir="${EPREFIX}"/usr/share/man/man1 \
+ -Dvendorman3dir="${EPREFIX}"/usr/share/man/man3 \
+ -Dman1ext='1' \
+ -Dman3ext='3pm' \
+ -Dlibperl="${LIBPERL}" \
+ -Dlocincpth="${EPREFIX}"'/usr/include ' \
+ -Dglibpth="${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir)"' ' \
+ -Duselargefiles \
+ -Dd_semctl_semun \
+ -Dcf_by='Gentoo' \
+ -Dmyhostname='localhost' \
+ -Dperladmin='root@localhost' \
+ -Dinstallusrbinperl='n' \
+ -Ud_csh \
+ -Uusenm \
+ "${myconf[@]}" || die "Unable to configure"
+}
diff --git a/dev-lang/perl/files/eblits/src_install-v50160001.eblit b/dev-lang/perl/files/eblits/src_install-v50160001.eblit
index d31e90e..aa90fae 100644
--- a/dev-lang/perl/files/eblits/src_install-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/src_install-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_install-v50160001.eblit,v 1.3 2013/03/14 12:46:31 tove Exp $
+# $Id$
eblit-perl-src_install() {
local i
diff --git a/dev-lang/perl/files/eblits/src_install-v50200001.eblit b/dev-lang/perl/files/eblits/src_install-v50200001.eblit
index 1df4296..fafff82 100644
--- a/dev-lang/perl/files/eblits/src_install-v50200001.eblit
+++ b/dev-lang/perl/files/eblits/src_install-v50200001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_install-v50200001.eblit,v 1.1 2014/12/19 18:52:46 dilfridge Exp $
+# $Id$
eblit-perl-src_install() {
local i
diff --git a/dev-lang/perl/files/eblits/src_install-v50240001.eblit b/dev-lang/perl/files/eblits/src_install-v50240001.eblit
new file mode 100644
index 0000000..fafff82
--- /dev/null
+++ b/dev-lang/perl/files/eblits/src_install-v50240001.eblit
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+eblit-perl-src_install() {
+ local i
+ local coredir="${ARCH_LIB}/CORE"
+
+ emake DESTDIR="${D}" install
+
+ rm -f "${ED}/usr/bin/perl${MY_PV}"
+ ln -s perl "${ED}"/usr/bin/perl${MY_PV} || die
+
+ if ! tc-is-static-only ; then
+ dolib.so "${ED}"${coredir}/${LIBPERL}
+ rm -f "${ED}"${coredir}/${LIBPERL}
+ ln -sf ${LIBPERL} "${ED}"/usr/$(get_libdir)/libperl$(get_libname ${SHORT_PV}) || die
+ ln -sf ${LIBPERL} "${ED}"/usr/$(get_libdir)/libperl$(get_libname) || die
+ ln -sf ../../../../../$(get_libdir)/${LIBPERL} "${ED}"${coredir}/${LIBPERL} || die
+ ln -sf ../../../../../$(get_libdir)/${LIBPERL} "${ED}"${coredir}/libperl$(get_libname ${SHORT_PV}) || die
+ ln -sf ../../../../../$(get_libdir)/${LIBPERL} "${ED}"${coredir}/libperl$(get_libname) || die
+ fi
+
+ rm -rf "${ED}"/usr/share/man/man3 || die "Unable to remove module man pages"
+
+ # This removes ${D} from Config.pm
+ for i in $(find "${D}" -iname "Config.pm" ) ; do
+ einfo "Removing ${D} from ${i}..."
+ sed -i -e "s:${D}::" "${i}" || die "Sed failed"
+ done
+
+ find "${ED}" -type f -name .packlist -delete || die
+
+ dodoc Changes* README AUTHORS
+
+ if use doc ; then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ LD_LIBRARY_PATH=. ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${ED}/usr/share/doc/${PF}/html"
+ fi
+
+ [[ -d ${ED}/usr/local ]] && rm -r "${ED}"/usr/local
+
+ dual_scripts
+}
diff --git a/dev-lang/perl/files/eblits/src_prepare-v50160001.eblit b/dev-lang/perl/files/eblits/src_prepare-v50160001.eblit
index 075e576..a12b773 100644
--- a/dev-lang/perl/files/eblits/src_prepare-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/src_prepare-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_prepare-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Id$
src_prepare_update_patchlevel_h() {
# Copied and modified from debian:
diff --git a/dev-lang/perl/files/eblits/src_prepare-v50240001.eblit b/dev-lang/perl/files/eblits/src_prepare-v50240001.eblit
new file mode 100644
index 0000000..5387d4b
--- /dev/null
+++ b/dev-lang/perl/files/eblits/src_prepare-v50240001.eblit
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+src_prepare_update_patchlevel_h() {
+ # Copied and modified from debian:
+ # Copyright 2011 Niko Tyni
+ # This program is free software; you can redistribute it and/or modify
+ # it under the same terms as Perl itself.
+ local patchdir="${WORKDIR}/patches"
+ local prefix
+
+ [[ -f ${patchdir}/series ]] || return 0
+
+while read patch
+do
+ patchname=$(echo $patch | sed 's/\.diff$//')
+ < $patchdir/$patch sed -e '/^Subject:/ { N; s/\n / / }' | sed -n -e '
+
+ # massage the patch headers
+ s|^Bug: .*https\?://rt\.perl\.org/.*id=\(.*\).*|[perl #\1]|; tprepend;
+ s|^Bug: .*https\?://rt\.cpan\.org/.*id=\(.*\).*|[rt.cpan.org #\1]|; tprepend;
+ s|^Bug-Gentoo: ||; tprepend;
+ s/^\(Subject\|Description\): //; tappend;
+ s|^Origin: .*http://perl5\.git\.perl\.org/perl\.git/commit\(diff\)\?/\(.......\).*|[\2]|; tprepend;
+
+ # post-process at the end of input
+ $ { x;
+ # include the version number in the patchlevel.h description (if available)
+ s/List packaged patches/&'" for ${PF}(#${PATCH_VER})"'/;
+
+ # escape any backslashes and double quotes
+ s|\\|\\\\|g; s|"|\\"|g;
+
+ # add a prefix
+ s|^|\t,"'"$prefix$patchname"' - |;
+ # newlines away
+ s/\n/ /g; s/ */ /g;
+ # add a suffix
+ s/ *$/"/; p
+ };
+ # stop all processing
+ d;
+ # label: append to the hold space
+ :append H; d;
+ # label: prepend to the hold space
+ :prepend x; H; d;
+ '
+done < "${WORKDIR}"/patches/series > "${S}"/patchlevel-gentoo.h
+}
+
+eblit-perl-src_prepare() {
+ local patch
+ EPATCH_OPTS+=" -p1"
+ einfo "Applying patches from ${MY_P}-${PATCH_VER} ..."
+ while read patch ; do
+ EPATCH_SINGLE_MSG=" ${patch} ..."
+ epatch "${WORKDIR}"/patches/${patch}
+ done < "${WORKDIR}"/patches/series
+
+ src_prepare_update_patchlevel_h
+
+ # pod/perltoc.pod fails
+ # lib/ExtUtils/t/Embed.t fails
+ if ! tc-is-static-only ; then
+ ln -s ${LIBPERL} libperl$(get_libname ${SHORT_PV}) || die
+ ln -s ${LIBPERL} libperl$(get_libname ) || die
+ fi
+
+ default
+}
+
diff --git a/dev-lang/perl/files/eblits/src_test-v50160001.eblit b/dev-lang/perl/files/eblits/src_test-v50160001.eblit
index 86acdc4..9e241ec 100644
--- a/dev-lang/perl/files/eblits/src_test-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/src_test-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_test-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Id$
eblit-perl-src_test() {
if [[ ${EUID} == 0 ]] ; then
diff --git a/dev-lang/perl/perl-5.20.2-r1.ebuild b/dev-lang/perl/perl-5.24.0.ebuild
index 43247b6..53bf104 100644
--- a/dev-lang/perl/perl-5.20.2-r1.ebuild
+++ b/dev-lang/perl/perl-5.24.0.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing prefix
+inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing
-PATCH_VER=2
+PATCH_VER=1
-PERL_OLDVERSEN="5.20.0 5.20.1"
-MODULE_AUTHOR=SHAY
+PERL_OLDVERSEN=""
+MODULE_AUTHOR=RJBS
SHORT_PV="${PV%.*}"
MY_P="perl-${PV/_rc/-RC}"
@@ -21,13 +21,13 @@ SRC_URI="
mirror://cpan/src/5.0/${MY_P}.tar.bz2
mirror://cpan/authors/id/${MODULE_AUTHOR:0:1}/${MODULE_AUTHOR:0:2}/${MODULE_AUTHOR}/${MY_P}.tar.bz2
mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.xz
- http://dev.gentoo.org/~dilfridge/distfiles/${MY_P}-patches-${PATCH_VER}.tar.xz
+ https://dev.gentoo.org/~dilfridge/distfiles/${MY_P}-patches-${PATCH_VER}.tar.xz
"
HOMEPAGE="http://www.perl.org/"
LICENSE="|| ( Artistic GPL-1+ )"
SLOT="0/${SHORT_PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~amd64-linux ~arm ~arm64 ~hppa ~hppa-hpux ~ia64 ~ia64-hpux ~ia64-linux ~m68k ~m68k-mint ~mips ~ppc ~ppc64 ~ppc-aix ~ppc-macos ~s390 ~sh ~sparc ~sparc64-solaris ~sparc-solaris ~x64-freebsd ~x64-macos ~x64-solaris ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~x86-linux ~x86-macos ~x86-solaris"
IUSE="berkdb debug doc gdbm ithreads"
RDEPEND="
@@ -43,27 +43,28 @@ PDEPEND="
>=app-admin/perl-cleaner-2.5
>=virtual/perl-File-Temp-0.230.400-r2
>=virtual/perl-Data-Dumper-2.154.0
+ virtual/perl-Test-Harness
"
# bug 390719, bug 523624
+# virtual/perl-Test-Harness is here for the bundled ExtUtils::MakeMaker
S="${WORKDIR}/${MY_P}"
dual_scripts() {
- src_remove_dual perl-core/Archive-Tar 1.960.0 ptar ptardiff ptargrep
- src_remove_dual perl-core/Digest-SHA 5.880.0 shasum
- src_remove_dual perl-core/CPAN 2.50.0 cpan
- src_remove_dual perl-core/Encode 2.600.0 enc2xs piconv
- src_remove_dual perl-core/ExtUtils-MakeMaker 6.980.0 instmodsh
- src_remove_dual perl-core/ExtUtils-ParseXS 3.240.0 xsubpp
- src_remove_dual perl-core/IO-Compress 2.64.0 zipdetails
- src_remove_dual perl-core/JSON-PP 2.272.30 json_pp
- src_remove_dual perl-core/Module-Build 0.420.500 config_data
- src_remove_dual perl-core/Module-CoreList 5.201.502.140 corelist
- src_remove_dual perl-core/Pod-Parser 1.620.0 pod2usage podchecker podselect
- src_remove_dual perl-core/Pod-Perldoc 3.230.0 perldoc
- src_remove_dual perl-core/Test-Harness 3.330.0 prove
- src_remove_dual perl-core/podlators 2.5.3 pod2man pod2text
- src_remove_dual_man perl-core/podlators 2.5.3 /usr/share/man/man1/perlpodstyle.1
+ src_remove_dual perl-core/Archive-Tar 2.40.0 ptar ptardiff ptargrep
+ src_remove_dual perl-core/Digest-SHA 5.950.0 shasum
+ src_remove_dual perl-core/CPAN 2.110.0 cpan
+ src_remove_dual perl-core/Encode 2.800.0 enc2xs piconv
+ src_remove_dual perl-core/ExtUtils-MakeMaker 7.100.100_rc instmodsh
+ src_remove_dual perl-core/ExtUtils-ParseXS 3.310.0 xsubpp
+ src_remove_dual perl-core/IO-Compress 2.69.0 zipdetails
+ src_remove_dual perl-core/JSON-PP 2.273.0 json_pp
+ src_remove_dual perl-core/Module-CoreList 5.201.605.60 corelist
+ src_remove_dual perl-core/Pod-Parser 1.630.0 pod2usage podchecker podselect
+ src_remove_dual perl-core/Pod-Perldoc 3.250.200_rc perldoc
+ src_remove_dual perl-core/Test-Harness 3.360.0 prove
+ src_remove_dual perl-core/podlators 4.70.0 pod2man pod2text
+ src_remove_dual_man perl-core/podlators 4.70.0 /usr/share/man/man1/perlpodstyle.1
}
# eblit-include [--skip] <function> [version]
@@ -101,26 +102,25 @@ eblit-run() {
eblit-run-maybe eblit-$1-post
}
-#src_unpack() { eblit-run src_unpack v50160001 ; }
-src_prepare() {
- eblit-run src_prepare v50160001
- epatch "${FILESDIR}"/${PN}-cwd-prefix.patch
- eprefixify dist/PathTools/Cwd.pm
-}
-src_configure() { eblit-run src_configure v50180002 ; }
+src_prepare() { eblit-run src_prepare v50240001 ; }
+
+src_configure() { eblit-run src_configure v50240001 ; }
+
#src_compile() { eblit-run src_compile v50160001 ; }
+
src_test() {
export NO_GENTOO_NETWORK_TESTS=1;
eblit-run src_test v50160001 ;
}
-src_install() { eblit-run src_install v50200001 ; }
+
+src_install() { eblit-run src_install v50240001 ; }
# FILESDIR might not be available during binpkg install
# FIXME: version passing
for x in setup {pre,post}{inst,rm} ; do
- e="${FILESDIR}/eblits/pkg_${x}-v50160001.eblit"
+ e="${FILESDIR}/eblits/pkg_${x}-v50240001.eblit"
if [[ -e ${e} ]] ; then
. "${e}"
- eval "pkg_${x}() { eblit-run pkg_${x} v50160001 ; }"
+ eval "pkg_${x}() { eblit-run pkg_${x} v50240001 ; }"
fi
done