summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-12-13 19:17:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-12-13 19:17:49 +0000
commitfc65e7966189ce496510ee4aff3d0b4e61c8a3a2 (patch)
tree128a04caaf6f82d1f3846a372924f603a9aa9cc2
parentkde-misc/kover: in gx86 by kde team (diff)
downloadhwoarang-fc65e7966189ce496510ee4aff3d0b4e61c8a3a2.tar.gz
hwoarang-fc65e7966189ce496510ee4aff3d0b4e61c8a3a2.tar.bz2
hwoarang-fc65e7966189ce496510ee4aff3d0b4e61c8a3a2.zip
dev-python/mechanize: Remove because it's broken and unmaintainedHEADmaster
-rw-r--r--dev-python/mechanize/mechanize-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/mechanize/mechanize-9999.ebuild b/dev-python/mechanize/mechanize-9999.ebuild
deleted file mode 100644
index 3d71b3e..0000000
--- a/dev-python/mechanize/mechanize-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.1.11.ebuild,v 1.7 2010/01/03 02:26:42 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils git
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
-EGIT_REPO_URI="git://github.com/jjlee/mechanize.git"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND=">=dev-python/clientform-0.2.7"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="0.1-changes.txt"
-
-src_prepare() {
- # Use distutils instead of setuptools.
- # (This can't be removed in the same ${PV} due to file->directory replacement.)
- sed -e 's/not hasattr(sys, "version_info")/True/' -i setup.py || die "sed in setup.py failed"
-
- # We don't run coverage tests or functional_tests
- # which access the network, just doctests and unit tests
- sed -e '/import coverage/d' -i test.py || die "sed in test.py failed"
-
- epatch "${FILESDIR}/${P}-python-2.7.patch"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- # Remove some files to prevent distutils_src_install from installing them.
- dohtml *.html
- rm -f README.html*
-
- distutils_src_install
-}