summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-12-10 14:36:43 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-12-10 14:36:43 +0000
commit9a17e5f99da547b4f30d9992af08d9beb205f2ac (patch)
tree5b354b093b7c7fbf97c28b91b028d8f947041629 /app-laptop/pommed
parentadd patch (diff)
downloadje_fro-9a17e5f99da547b4f30d9992af08d9beb205f2ac.tar.gz
je_fro-9a17e5f99da547b4f30d9992af08d9beb205f2ac.tar.bz2
je_fro-9a17e5f99da547b4f30d9992af08d9beb205f2ac.zip
really add patch this time
svn path=/; revision=144
Diffstat (limited to 'app-laptop/pommed')
-rw-r--r--app-laptop/pommed/files/pommed-1.13.patch21
-rwxr-xr-xapp-laptop/pommed/files/pommed.rc19
2 files changed, 40 insertions, 0 deletions
diff --git a/app-laptop/pommed/files/pommed-1.13.patch b/app-laptop/pommed/files/pommed-1.13.patch
new file mode 100644
index 0000000..0dcb368
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.13.patch
@@ -0,0 +1,21 @@
+diff -ru pommed-1.11~/pommed/Makefile pommed-1.11/pommed/Makefile
+--- pommed-1.11~/pommed/Makefile 2007-11-18 22:41:53.000000000 +0100
++++ pommed-1.11/pommed/Makefile 2007-11-18 22:44:05.000000000 +0100
+@@ -16,7 +16,7 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS)
+
+ ifeq ($(ARCH), ppc)
+ OFLIB ?=
+@@ -41,7 +41,7 @@
+
+ else
+
+-LDFLAGS = -lz -lsmbios $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
++LDFLAGS = -lz -lsmbios -lstdc++ $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+ SOURCES = pommed.c cd_eject.c evdev.c conffile.c audio.c dbus.c power.c beep.c \
+ mactel/x1600_backlight.c mactel/gma950_backlight.c \
diff --git a/app-laptop/pommed/files/pommed.rc b/app-laptop/pommed/files/pommed.rc
new file mode 100755
index 0000000..062d1a9
--- /dev/null
+++ b/app-laptop/pommed/files/pommed.rc
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need dbus alsasound
+}
+
+start() {
+ ebegin "Running pommed daemon"
+ start-stop-daemon --start --quiet --exec /usr/bin/pommed
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pommed daemon"
+ start-stop-daemon --stop --pidfile /var/run/pommed.pid
+ eend $?
+}