summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-08-09 08:20:15 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-08-09 08:20:15 +0000
commit0c666a027797cf517c4325e48735074eb24c287a (patch)
tree6be0d962013935e51d69a2bfef6419e9103ae627 /sci-biology/cluster/cluster-1.36.ebuild
parentAdd metadata.xml (diff)
downloadje_fro-0c666a027797cf517c4325e48735074eb24c287a.tar.gz
je_fro-0c666a027797cf517c4325e48735074eb24c287a.tar.bz2
je_fro-0c666a027797cf517c4325e48735074eb24c287a.zip
Fix to work with USE=X
svn path=/; revision=22
Diffstat (limited to 'sci-biology/cluster/cluster-1.36.ebuild')
-rw-r--r--sci-biology/cluster/cluster-1.36.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/sci-biology/cluster/cluster-1.36.ebuild b/sci-biology/cluster/cluster-1.36.ebuild
index e381dcb..1c4376c 100644
--- a/sci-biology/cluster/cluster-1.36.ebuild
+++ b/sci-biology/cluster/cluster-1.36.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-
+inherit autotools
SRC_URI="${P}.tar.gz"
DESCRIPTION="Clustering software for microarrays analisys"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X"
-DEPEND="X? ( x11-libs/openmotif )"
+DEPEND="X? ( virtual/motif )"
RESTRICT="fetch"
@@ -19,11 +19,25 @@ pkg_nofetch() {
einfo "Please obtain ${P}.tar.gz from ${HOMEPAGE} and place it in ${DISTDIR}"
}
-# S="${WORKDIR}/cluster-1.35"
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ sed -i \
+ -e 's:^docdir = $(prefix)/cluster/doc:docdir = @docdir@:' \
+ -e 's:^htmldir = $(prefix)/cluster/html:htmldir = @htmldir@:' \
+ -e 's:^imagedir = $(prefix)/cluster/html/images:imagedir = @htmldir@/images:' \
+ -e 's:^fileformatdir = $(prefix)/cluster:fileformatdir = @docdir@:' \
+ X11/Makefile.in || die "sed failed"
+
+# X11/gui.c \
+}
src_compile() {
- econf $(use_with X x) || die "econf failed"
+ econf $(use_with X x) \
+ --docdir="/usr/share/doc/${P}" \
+ --htmldir="/usr/share/doc/${P}/html" \
+ || die "econf failed"
emake || die "emake failed"
}
@@ -32,10 +46,7 @@ src_install() {
cd ${S}
emake DESTDIR="${D}" install || die "Install failed"
- dohtml html/*
dodoc README COPYING AUTHORS ChangeLog NEWS TODO
- insinto /usr/share/doc/${P}/pdf
- doins doc/*.pdf
insinto /usr/share/doc/${P}/examples
- doins X11/format.xpm example/example.c example/README
+ doins example/example.c example/README
}