summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-04-27 04:55:03 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-04-27 04:55:03 +0000
commit080ccb5b82f541b16ce656390bc4ca4e18cbff87 (patch)
tree318a5e00eae486128aee5535828a87c52fbf75f7 /sci-chemistry/namd
parentin tree (diff)
downloadje_fro-080ccb5b82f541b16ce656390bc4ca4e18cbff87.tar.gz
je_fro-080ccb5b82f541b16ce656390bc4ca4e18cbff87.tar.bz2
je_fro-080ccb5b82f541b16ce656390bc4ca4e18cbff87.zip
Towards getting the latest version going
svn path=/; revision=276
Diffstat (limited to 'sci-chemistry/namd')
-rw-r--r--sci-chemistry/namd/Manifest11
-rw-r--r--sci-chemistry/namd/namd-2.7.ebuild99
2 files changed, 101 insertions, 9 deletions
diff --git a/sci-chemistry/namd/Manifest b/sci-chemistry/namd/Manifest
index d331835..4c8db39 100644
--- a/sci-chemistry/namd/Manifest
+++ b/sci-chemistry/namd/Manifest
@@ -1,12 +1,5 @@
AUX namd-2.6-gentoo-amd64.patch 3603 RMD160 c73b9a273716c430004d87d36551a5474e6d3288 SHA1 a815851f7ebc8bb2533f38bb24b529765f2e6c54 SHA256 17f60d6add2b777726507c5badaf4dc5e0eb947d2c49c2562eda242aa8384435
-MD5 98dd6d870f303cbe8ba139e0bb2f35b4 files/namd-2.6-gentoo-amd64.patch 3603
-RMD160 c73b9a273716c430004d87d36551a5474e6d3288 files/namd-2.6-gentoo-amd64.patch 3603
-SHA256 17f60d6add2b777726507c5badaf4dc5e0eb947d2c49c2562eda242aa8384435 files/namd-2.6-gentoo-amd64.patch 3603
DIST NAMD_2.6_Source.tar.gz 8963319 RMD160 186f79322226a20398031618011104a666237298 SHA1 3b3d83fdc54a520cb6c59b34cde03c9f74d2f443 SHA256 bf353ff13eae18b5a8dc33d79d295e9fe73fb87482858309b7695ce3e24f0d0b
+DIST NAMD_2.7b1_Source.tar.gz 26302404 RMD160 ccb73606d3f0724c55ce022aa130656444825f5e SHA1 955e096a6c70e1e7786d10334bec3cae1eb4fff6 SHA256 cf48b659667fe9e03af27c8d434567525e924ebd08c801321c71361a8f166b2e
EBUILD namd-2.6.ebuild 2191 RMD160 6455f4414fe0dbabfaa9c311aa4b4f396a7a5cb4 SHA1 3578db2de833ca07566a4ab30ed0655ec3d8afdf SHA256 b35ff3d0fabeaba543f59d8e42acfb50dd6729981680365628c0f663b117da53
-MD5 a95e8518c38f1fbab38f0a9b26910461 namd-2.6.ebuild 2191
-RMD160 6455f4414fe0dbabfaa9c311aa4b4f396a7a5cb4 namd-2.6.ebuild 2191
-SHA256 b35ff3d0fabeaba543f59d8e42acfb50dd6729981680365628c0f663b117da53 namd-2.6.ebuild 2191
-MD5 f125c37a6c730dd4213cc69fb280de0f files/digest-namd-2.6 250
-RMD160 b71b7ad56f3f23d002ecca0ec623636690c7c895 files/digest-namd-2.6 250
-SHA256 2a4f6569fcce7447d6c81a24a115b4b410ccc4247fb4c4e5a11c63c6708aa4a1 files/digest-namd-2.6 250
+EBUILD namd-2.7.ebuild 2255 RMD160 79c471631c5c4305bdb4d8b63f79d048c38ea599 SHA1 bb9d8f57121c9b7d1a99403793951412ba72a496 SHA256 562d81583afbde1155f2d79d4f12052e56fc56c4bf991288cc3dd310273302bf
diff --git a/sci-chemistry/namd/namd-2.7.ebuild b/sci-chemistry/namd/namd-2.7.ebuild
new file mode 100644
index 0000000..bac3055
--- /dev/null
+++ b/sci-chemistry/namd/namd-2.7.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# This is broken and needs work.
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A powerful and highly parallelized molecular dynamics code"
+LICENSE="namd"
+HOMEPAGE="http://www.ks.uiuc.edu/Research/namd/"
+
+MY_PN="NAMD"
+MY_PV="2.7b1"
+
+SRC_URI="${MY_PN}_${MY_PV}_Source.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="fetch"
+
+DEPEND="|| ( app-shells/csh
+ app-shells/tcsh )
+ virtual/libc
+ sys-cluster/charm
+ =sci-libs/fftw-2*
+ =dev-lang/tcl-8.4*"
+
+CHARM="charm-9999"
+# NAMD_ARCH="Linux-amd64-g++"
+NAMD_ARCH="Linux-x86_64"
+
+NAMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_Source"
+
+pkg_nofetch() {
+ echo
+ einfo "Please download ${MY_PN}_${MY_PV}_Source.tar.gz from"
+ einfo "${NAMD_DOWNLOAD}"
+ einfo "after agreeing to the license and then move it to"
+ einfo "${DISTDIR}"
+ einfo "Be sure to select the ${MY_PV} version!"
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # apply a few small fixes to make NAMD compile and
+ # link to the proper libraries
+# epatch "${FILESDIR}"/namd-2.6-gentoo-amd64.patch
+
+ cd "${S}"
+
+ # proper compiler and cflags
+ sed -e "s/g++/$(tc-getCXX)/" \
+ -e "s/CXXOPTS = -O3 -march=pentiumpro -ffast-math -static/CXXOPTS = ${CXXFLAGS}/" \
+ -e "s/gcc/$(tc-getCC)/" \
+ -e "s/COPTS = -O3 -march=pentiumpro -ffast-math -static/COPTS = ${CFLAGS}/" \
+ -i arch/${NAMD_ARCH}.arch || \
+ die "Failed to setup ${NAMD_ARCH}.arch"
+
+ # configure
+ ./config tcl fftw ${NAMD_ARCH}
+}
+
+src_compile() {
+ # build namd
+ cd "${S}/${NAMD_ARCH}"
+ emake || die "Failed to build namd"
+}
+
+src_install() {
+ cd "${S}/${NAMD_ARCH}"
+
+ # the binaries
+ dobin ${PN}2 psfgen flipbinpdb flipdcd || \
+ die "Failed to install binaries"
+
+ cd "${S}"
+
+ # some docs
+ dodoc announce.txt license.txt notes.txt || \
+ die "Failed to install docs"
+}
+
+pkg_postinst() {
+ echo
+ einfo "For detailed instructions on how to run and configure"
+ einfo "NAMD please consults the extensive documentation at"
+ einfo "http://www.ks.uiuc.edu/Research/namd/"
+ einfo "and the NAMD tutorials available at"
+ einfo "http://www.ks.uiuc.edu/Training/Tutorials/"
+ einfo "Have fun :)"
+ echo
+}