summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-05-24 23:52:34 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-05-24 23:52:34 +0000
commitb82d3afe9719e4bbc79c23a34dd4eeab7fa818f4 (patch)
treef550abd8f1f1038fc171ce1a4599cda59e6f5686 /sci-chemistry
parentLatest version for testing with new radeonhd. (diff)
downloadje_fro-b82d3afe9719e4bbc79c23a34dd4eeab7fa818f4.tar.gz
je_fro-b82d3afe9719e4bbc79c23a34dd4eeab7fa818f4.tar.bz2
je_fro-b82d3afe9719e4bbc79c23a34dd4eeab7fa818f4.zip
manifest
svn path=/; revision=280
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/namd/Manifest2
-rw-r--r--sci-chemistry/namd/namd-2.6.ebuild96
2 files changed, 1 insertions, 97 deletions
diff --git a/sci-chemistry/namd/Manifest b/sci-chemistry/namd/Manifest
index 889edd9..440f6f0 100644
--- a/sci-chemistry/namd/Manifest
+++ b/sci-chemistry/namd/Manifest
@@ -1,3 +1,3 @@
AUX namd-2.6-gentoo-amd64.patch 3603 RMD160 c73b9a273716c430004d87d36551a5474e6d3288 SHA1 a815851f7ebc8bb2533f38bb24b529765f2e6c54 SHA256 17f60d6add2b777726507c5badaf4dc5e0eb947d2c49c2562eda242aa8384435
DIST NAMD_2.7b1_Source.tar.gz 26302404 RMD160 ccb73606d3f0724c55ce022aa130656444825f5e SHA1 955e096a6c70e1e7786d10334bec3cae1eb4fff6 SHA256 cf48b659667fe9e03af27c8d434567525e924ebd08c801321c71361a8f166b2e
-EBUILD namd-2.7.ebuild 2265 RMD160 eb54d7f8c81886d59b1a7a66ad58639db2dff476 SHA1 a2ab70155b25297bbe55f45343865c3125869367 SHA256 b618fcc84492d2f6828309a2ae79ee6d6f8a5033a5f85d4ec5ea846e6a917be8
+EBUILD namd-2.7.ebuild 2244 RMD160 f02c25aae72ea2165d923f58d4e7c1da13e01a48 SHA1 782d153320df1a6634a3962a6868b5ea9c5305e8 SHA256 747a19d3373be9efcbdf47f8a287c1c629415eccf00ff923555e4d187adaefc0
diff --git a/sci-chemistry/namd/namd-2.6.ebuild b/sci-chemistry/namd/namd-2.6.ebuild
deleted file mode 100644
index ece7471..0000000
--- a/sci-chemistry/namd/namd-2.6.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A powerful and highly parallelized molecular dynamics code"
-LICENSE="namd"
-HOMEPAGE="http://www.ks.uiuc.edu/Research/namd/"
-
-MY_PN="NAMD"
-MY_PV="2.6"
-
-SRC_URI="${MY_PN}_${MY_PV}_Source.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="fetch"
-
-DEPEND="|| ( app-shells/csh
- app-shells/tcsh )
- virtual/libc
- sys-cluster/charm
- =sci-libs/fftw-2*
- =dev-lang/tcl-8.4*"
-
-CHARM="charm-9999"
-NAMD_ARCH="Linux-amd64-g++"
-
-NAMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD"
-
-S="${WORKDIR}/${MY_PN}_${MY_PV}_Source"
-
-pkg_nofetch() {
- echo
- einfo "Please download ${MY_PN}_${MY_PV}_Source.tar.gz from"
- einfo "${NAMD_DOWNLOAD}"
- einfo "after agreeing to the license and then move it to"
- einfo "${DISTDIR}"
- einfo "Be sure to select the ${MY_PV} version!"
- echo
-}
-
-src_unpack() {
- unpack ${A}
-
- # apply a few small fixes to make NAMD compile and
- # link to the proper libraries
- epatch "${FILESDIR}"/namd-2.6-gentoo-amd64.patch
-
- cd "${S}"
-
- # proper compiler and cflags
- sed -e "s/g++/$(tc-getCXX)/" \
- -e "s/CXXOPTS = -O3 -march=pentiumpro -ffast-math -static/CXXOPTS = ${CXXFLAGS}/" \
- -e "s/gcc/$(tc-getCC)/" \
- -e "s/COPTS = -O3 -march=pentiumpro -ffast-math -static/COPTS = ${CFLAGS}/" \
- -i arch/${NAMD_ARCH}.arch || \
- die "Failed to setup ${NAMD_ARCH}.arch"
-
- # configure
- ./config tcl fftw ${NAMD_ARCH}
-}
-
-src_compile() {
- # build namd
- cd "${S}/${NAMD_ARCH}"
- emake || die "Failed to build namd"
-}
-
-src_install() {
- cd "${S}/${NAMD_ARCH}"
-
- # the binaries
- dobin ${PN}2 psfgen flipbinpdb flipdcd || \
- die "Failed to install binaries"
-
- cd "${S}"
-
- # some docs
- dodoc announce.txt license.txt notes.txt || \
- die "Failed to install docs"
-}
-
-pkg_postinst() {
- echo
- einfo "For detailed instructions on how to run and configure"
- einfo "NAMD please consults the extensive documentation at"
- einfo "http://www.ks.uiuc.edu/Research/namd/"
- einfo "and the NAMD tutorials available at"
- einfo "http://www.ks.uiuc.edu/Training/Tutorials/"
- einfo "Have fun :)"
- echo
-}