summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-08-22 22:35:55 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-08-22 22:35:55 +0000
commitdfb1ed300d17e2e70cae4d817d6912a24345e954 (patch)
tree4f5c6a22eafa00730b359be980760b9f874efd99 /sys-cluster/charm/files
parentTesting namd on amd64. (diff)
downloadje_fro-dfb1ed300d17e2e70cae4d817d6912a24345e954.tar.gz
je_fro-dfb1ed300d17e2e70cae4d817d6912a24345e954.tar.bz2
je_fro-dfb1ed300d17e2e70cae4d817d6912a24345e954.zip
Needed by namd. Testing on amd64.
svn path=/; revision=55
Diffstat (limited to 'sys-cluster/charm/files')
-rwxr-xr-xsys-cluster/charm/files/charm-5.9-gcc4.patch41
-rw-r--r--sys-cluster/charm/files/charm-charmc-gentoo.patch29
-rw-r--r--sys-cluster/charm/files/charm-doc-makefile-gentoo.patch35
-rw-r--r--sys-cluster/charm/files/charm-examples-gentoo.patch105
-rw-r--r--sys-cluster/charm/files/charm-fpic-gentoo.patch32
-rw-r--r--sys-cluster/charm/files/charm-python-configure-gentoo.patch29
-rw-r--r--sys-cluster/charm/files/digest-charm-5.93
7 files changed, 274 insertions, 0 deletions
diff --git a/sys-cluster/charm/files/charm-5.9-gcc4.patch b/sys-cluster/charm/files/charm-5.9-gcc4.patch
new file mode 100755
index 0000000..9a1cb9f
--- /dev/null
+++ b/sys-cluster/charm/files/charm-5.9-gcc4.patch
@@ -0,0 +1,41 @@
+diff -Naur charm-5.9/src/ck-com/MsgPacker.h charm-5.9-new/src/ck-com/MsgPacker.h
+--- charm-5.9/src/ck-com/MsgPacker.h 2005-03-20 23:21:51.000000000 -0600
++++ charm-5.9-new/src/ck-com/MsgPacker.h 2006-04-19 17:16:05.000000000 -0500
+@@ -83,7 +83,7 @@
+
+ //Takes a queue of envelopes as char* ptrs and not charm message holders
+ //Used by mesh streaming strategy
+- MsgPacker::MsgPacker(CkQ<char *> &msgq, int n_msgs);
++ MsgPacker(CkQ<char *> &msgq, int n_msgs);
+
+ void getMessage(CombinedMessage *&msg, int &size);
+ static void deliver(CombinedMessage *cmb_msg);
+diff -Naur charm-5.9/src/ck-core/charisma.h charm-5.9-new/src/ck-core/charisma.h
+--- charm-5.9/src/ck-core/charisma.h 2003-03-20 18:30:50.000000000 -0600
++++ charm-5.9-new/src/ck-core/charisma.h 2006-04-19 17:19:34.000000000 -0500
+@@ -295,6 +295,7 @@
+ class CharismaInPort
+ {
+ public:
++ virtual ~CharismaInPort() {}
+ virtual void send(void *msg, int len) = 0;
+ void _create(const char *name)
+ {
+@@ -307,6 +308,7 @@
+ protected:
+ CharismaInPort *inport;
+ public:
++ virtual ~CharismaOutPort() {}
+ virtual void emitData(void *data, int len)
+ {
+ inport->send(data, len);
+diff -Naur charm-5.9/src/ck-core/cklocation.h charm-5.9-new/src/ck-core/cklocation.h
+--- charm-5.9/src/ck-core/cklocation.h 2004-10-30 11:35:25.000000000 -0500
++++ charm-5.9-new/src/ck-core/cklocation.h 2006-04-19 17:21:24.000000000 -0500
+@@ -431,6 +431,7 @@
+ /// Abstract superclass of all array manager objects
+ class CkArrMgr {
+ public:
++ virtual ~CkArrMgr() {}
+ /// Insert this initial element on this processor
+ virtual void insertInitial(const CkArrayIndex &idx,void *ctorMsg, int local=1)=0;
diff --git a/sys-cluster/charm/files/charm-charmc-gentoo.patch b/sys-cluster/charm/files/charm-charmc-gentoo.patch
new file mode 100644
index 0000000..e5be49a
--- /dev/null
+++ b/sys-cluster/charm/files/charm-charmc-gentoo.patch
@@ -0,0 +1,29 @@
+# adjust paths in charmc wrapper to point to the proper include
+# and libary directories
+
+--- charm-5.9/src/scripts/charmc 2005-01-25 23:13:30.000000000 +0000
++++ charm-5.9-patched/src/scripts/charmc 2005-09-26 00:52:57.000000000 +0000
+@@ -656,20 +656,9 @@
+ PROG_EXT=".exe"
+ fi
+
+-CHARMLIB="$CHARMBIN/../lib"
+-CHARMINC="$CHARMBIN/../include"
+-CHARMLIBSO=
+-if test -d "$CHARMBIN/../lib_so"
+-then
+- CHARMLIBSO=`cd $CHARMBIN/../lib_so 2>/dev/null && pwd`
+- #getting absolute path is harder than thought because of symbolic links and ..
+- #ksh needs cd -P to resolve werid symbolic links, however -P is not portable
+- #csh is ok too if it exists
+- test -z "$CHARMLIBSO" && CHARMLIBSO=`cd -P $CHARMBIN/../lib_so 2>/dev/null && pwd`
+- test -z "$CHARMLIBSO" && CHARMLIBSO=`csh -c "cd $CHARMBIN/../lib_so >& /dev/null && pwd"`
+- test -z "$CHARMLIBSO" && echo "$CHARMBIN/../lib_so: not found" && exit 1
+-fi
+-
++CHARMLIB="/usr/lib"
++CHARMINC="/usr/include/gentoo-include"
++CHARMLIBSO="/usr/lib"
+
+
+ ##############################################################################
diff --git a/sys-cluster/charm/files/charm-doc-makefile-gentoo.patch b/sys-cluster/charm/files/charm-doc-makefile-gentoo.patch
new file mode 100644
index 0000000..f18497a
--- /dev/null
+++ b/sys-cluster/charm/files/charm-doc-makefile-gentoo.patch
@@ -0,0 +1,35 @@
+# patch to properly build the docs as pdf and html
+
+--- charm-5.9/doc/Makefile 2004-10-14 06:12:10.000000000 +0000
++++ charm-5.9-patched/doc/Makefile 2005-09-24 22:55:53.000000000 +0000
+@@ -1,4 +1,4 @@
+-IDIR=../../doc
++IDIR=./doc
+ LNCMD=test ! -f pplmanual.sty && ln -f -s ../pplmanual.sty .
+ RMCMD=rm -f ./pplmanual.sty
+ DIRS=install converse convext charm++ libraries f90charm pose \
+--- charm-5.9/doc/Makefile.common 2005-04-19 17:21:52.000000000 +0000
++++ charm-5.9-patched/doc/Makefile.common 2005-09-24 22:56:30.000000000 +0000
+@@ -10,7 +10,7 @@
+ # (optional) PROJECT_LINK: HTML to include at bottom of page
+
+ # Destination directory for local copy of files (e.g., on user machine)
+-DOCDIR=..
++DOCDIR=../doc
+
+ # Destination directory for web-accessible copy of files (e.g., on PPL machines)
+ WEBDIR=/www/ppl_manuals
+@@ -71,12 +71,10 @@
+ -rm -fr index.tex $(FIG_CLEAN)
+
+ # Build local copy of documentation:
+-doc: all
++doc: pdf html
+ if [ ! -d $(DOCDIR) ] ; then mkdir $(DOCDIR) ; fi
+- if [ ! -d $(DOCDIR)/ps ] ; then mkdir $(DOCDIR)/ps ; fi
+ if [ ! -d $(DOCDIR)/pdf ] ; then mkdir $(DOCDIR)/pdf ; fi
+ if [ ! -d $(DOCDIR)/html ] ; then mkdir $(DOCDIR)/html ; fi
+- /bin/cp $(FILE).ps $(DOCDIR)/ps/$(DEST).ps
+ /bin/cp $(FILE).pdf $(DOCDIR)/pdf/$(DEST).pdf
+ /bin/rm -rf $(DOCDIR)/html/$(DEST)
+ /bin/cp -R $(FILE) $(DOCDIR)/html/$(DEST)
diff --git a/sys-cluster/charm/files/charm-examples-gentoo.patch b/sys-cluster/charm/files/charm-examples-gentoo.patch
new file mode 100644
index 0000000..ef8089f
--- /dev/null
+++ b/sys-cluster/charm/files/charm-examples-gentoo.patch
@@ -0,0 +1,105 @@
+diff -Naur charm-5.9/examples/pose/ASIM/Makefile charm-5.9-backup/examples/pose/ASIM/Makefile
+--- charm-5.9/examples/pose/ASIM/Makefile 2004-10-22 04:38:26.000000000 +0000
++++ charm-5.9-backup/examples/pose/ASIM/Makefile 2005-09-27 03:27:08.000000000 +0000
+@@ -12,8 +12,8 @@
+ OPTS=-O#-DCMK_OPTIMIZE=1 -DCMK_MEMCHECKS_OFF=1
+
+ CHARMBASE=../../..
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin
++CHARMINC=/usr/include/charm-5.9
+
+ CHARMC=$(CHARMBIN)/charmc -I$(CHARMINC)/pose $(OPTS)
+
+diff -Naur charm-5.9/examples/pose/BigNetSim/Makefile charm-5.9-backup/examples/pose/BigNetSim/Makefile
+--- charm-5.9/examples/pose/BigNetSim/Makefile 2004-10-17 22:48:10.000000000 +0000
++++ charm-5.9-backup/examples/pose/BigNetSim/Makefile 2005-09-27 03:27:08.000000000 +0000
+@@ -16,8 +16,8 @@
+
+ CHARMBASE=../../../
+ #CHARMBASE=/expand8/home/gzheng/old/charm-6-8/net-linux/
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin
++CHARMINC=/usr/include/charm-5.9
+
+ ifeq ($(SEQUENTIAL),1)
+ CHARMC=$(CHARMBIN)/charmc -I$(CHARMINC)/pose $(OPTS) -DSEQUENTIAL_POSE=1
+diff -Naur charm-5.9/examples/pose/ChunkSim/Makefile charm-5.9-backup/examples/pose/ChunkSim/Makefile
+--- charm-5.9/examples/pose/ChunkSim/Makefile 2004-10-12 17:12:26.000000000 +0000
++++ charm-5.9-backup/examples/pose/ChunkSim/Makefile 2005-09-27 03:27:08.000000000 +0000
+@@ -12,8 +12,8 @@
+ OPTS=-O#-DCMK_OPTIMIZE=1 -DCMK_MEMCHECKS_OFF=1
+
+ CHARMBASE=../../../
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin
++CHARMINC=/usr/include/charm-5.9
+
+ CHARMC=$(CHARMBIN)/charmc -I$(CHARMINC)/pose $(OPTS)
+
+@@ -109,4 +109,4 @@
+ $(CHARMBIN)/etrans.pl Worker
+
+ test:
+- ./pgm 1000 10 1 RANDOM SPARSE 50 -gf 344
+\ No newline at end of file
++ ./pgm 1000 10 1 RANDOM SPARSE 50 -gf 344
+diff -Naur charm-5.9/examples/pose/HiSim/Makefile.common charm-5.9-backup/examples/pose/HiSim/Makefile.common
+--- charm-5.9/examples/pose/HiSim/Makefile.common 2004-11-02 07:29:40.000000000 +0000
++++ charm-5.9-backup/examples/pose/HiSim/Makefile.common 2005-09-27 03:27:08.000000000 +0000
+@@ -1,8 +1,8 @@
+
+ CHARMBASE=../../../../
+ #CHARMBASE=/expand8/home/gzheng/tmp/pose/charm/net-linux
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin
++CHARMINC=/usr/include/charm-5.9
+ ETRANS=$(CHARMBIN)/etrans.pl
+ OPTS=-g
+
+diff -Naur charm-5.9/examples/pose/LBSim/Makefile charm-5.9-backup/examples/pose/LBSim/Makefile
+--- charm-5.9/examples/pose/LBSim/Makefile 2004-11-04 04:30:45.000000000 +0000
++++ charm-5.9-backup/examples/pose/LBSim/Makefile 2005-09-27 03:27:08.000000000 +0000
+@@ -12,8 +12,8 @@
+ OPTS=-O#-DCMK_OPTIMIZE=1 -DCMK_MEMCHECKS_OFF=1
+
+ CHARMBASE=../../../
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin
++CHARMINC=/usr/include/charm-5.9
+
+ CHARMC=$(CHARMBIN)/charmc -I$(CHARMINC)/pose $(OPTS)
+
+diff -Naur charm-5.9/examples/pose/Ring/Makefile charm-5.9-backup/examples/pose/Ring/Makefile
+--- charm-5.9/examples/pose/Ring/Makefile 2005-02-08 18:58:05.000000000 +0000
++++ charm-5.9-backup/examples/pose/Ring/Makefile 2005-09-27 03:27:08.000000000 +0000
+@@ -12,8 +12,8 @@
+ OPTS=-O#-DCMK_OPTIMIZE=1 -DCMK_MEMCHECKS_OFF=1
+
+ CHARMBASE=../../..
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin/
++CHARMINC=/usr/include/charm-5.9
+
+ CHARMC=$(CHARMBIN)/charmc -I$(CHARMINC)/pose $(OPTS)
+
+diff -Naur charm-5.9/examples/pose/SimBenchmark/Makefile charm-5.9-backup/examples/pose/SimBenchmark/Makefile
+--- charm-5.9/examples/pose/SimBenchmark/Makefile 2005-03-17 22:31:41.000000000 +0000
++++ charm-5.9-backup/examples/pose/SimBenchmark/Makefile 2005-09-27 03:27:08.000000000 +0000
+@@ -12,8 +12,8 @@
+ OPTS=-O#-DCMK_OPTIMIZE=1 -DCMK_MEMCHECKS_OFF=1
+
+ CHARMBASE=../../..
+-CHARMBIN=$(CHARMBASE)/bin
+-CHARMINC=$(CHARMBASE)/include
++CHARMBIN=/usr/bin
++CHARMINC=/usr/include/charm-5.9
+
+ CHARMC=$(CHARMBIN)/charmc -I$(CHARMINC)/pose $(OPTS)
+
diff --git a/sys-cluster/charm/files/charm-fpic-gentoo.patch b/sys-cluster/charm/files/charm-fpic-gentoo.patch
new file mode 100644
index 0000000..e70874d
--- /dev/null
+++ b/sys-cluster/charm/files/charm-fpic-gentoo.patch
@@ -0,0 +1,32 @@
+# compile with -fPIC to avoid TEXTRELs
+
+--- charm-5.9/src/arch/net-linux/conv-mach.sh 2005-04-22 01:14:55.000000000 +0000
++++ charm-5.9-backup/src/arch/net-linux/conv-mach.sh 2005-09-27 18:07:10.000000000 +0000
+@@ -1,8 +1,8 @@
+ CMK_CPP_CHARM="/lib/cpp -P"
+ CMK_CPP_C="gcc -E"
+-CMK_CC="gcc "
+-CMK_CXX="g++ "
+-CMK_CXXPP="$CMK_CXX -x c++ -E "
++CMK_CC="gcc -fPIC"
++CMK_CXX="g++ -fPIC -Wno-deprecated"
++CMK_CXXPP="$CMK_CXX -E "
+ CMK_CF77="g77 "
+ CMK_CF90="f90 "
+ CMK_CF90_FIXED="$CMK_CF90 -W132 "
+@@ -10,12 +10,12 @@
+ CMK_LIBS="-lckqt"
+ #CMK_LD="$CMK_CC -Wl,--allow-multiple-definition "
+ #CMK_LDXX="$CMK_CXX -Wl,--allow-multiple-definition "
+-CMK_LD="$CMK_CC "
+-CMK_LDXX="$CMK_CXX "
++CMK_LD="gcc "
++CMK_LDXX="g++ "
+ CMK_LD_SHARED="-shared"
+ CMK_LD_LIBRARY_PATH="-Wl,-rpath,$CHARMLIBSO/"
+ CMK_XIOPTS=""
+-CMK_F90LIBS="-L/usr/absoft/lib -L/opt/absoft/lib -lf90math -lfio -lU77 -lf77math "
++CMK_F90LIBS=""
+ CMK_F77LIBS="-lg2c "
+ CMK_MOD_NAME_ALLCAPS=1
+ CMK_MOD_EXT="mod"
diff --git a/sys-cluster/charm/files/charm-python-configure-gentoo.patch b/sys-cluster/charm/files/charm-python-configure-gentoo.patch
new file mode 100644
index 0000000..6e98642
--- /dev/null
+++ b/sys-cluster/charm/files/charm-python-configure-gentoo.patch
@@ -0,0 +1,29 @@
+# include proper python headers
+
+--- charm-5.9/src/scripts/configure 2005-06-01 03:46:06.000000000 +0000
++++ charm-5.9-backup/src/scripts/configure 2005-09-27 14:28:48.000000000 +0000
+@@ -1970,11 +1970,12 @@
+ fi
+
+ #### test if Python headers are installed ####
++PYTHON_VERSION=`python -V 2>&1 | awk {'print $2'} | awk -F. {'print $1"."$2'}`
+ cat > $t <<EOT
+-#include "python/Python.h"
+-#include "python/compile.h"
+-#include "python/eval.h"
+-#include "python/node.h"
++#include "python${PYTHON_VERSION}/Python.h"
++#include "python${PYTHON_VERSION}/compile.h"
++#include "python${PYTHON_VERSION}/eval.h"
++#include "python${PYTHON_VERSION}/node.h"
+
+ int main() {
+ Py_Initialize();
+@@ -1983,7 +1984,6 @@
+ PyCodeObject *program = PyNode_Compile(programNode, "");
+ }
+ EOT
+-PYTHON_VERSION=`python -V 2>&1 | awk {'print $2'} | awk -F. {'print $1"."$2'}`
+ test_link "whether Python is installed" "yes" "no" "-lpython$PYTHON_VERSION -lpthread -lutil -ldl"
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/sys-cluster/charm/files/digest-charm-5.9 b/sys-cluster/charm/files/digest-charm-5.9
new file mode 100644
index 0000000..2c50cfb
--- /dev/null
+++ b/sys-cluster/charm/files/digest-charm-5.9
@@ -0,0 +1,3 @@
+MD5 e0632ea7993a9b9f197fe5c20712a6be charm-5.9.tar.gz 7580639
+RMD160 ebc3a8515fd918c6e0fc0fd9963a22b3ae5d057d charm-5.9.tar.gz 7580639
+SHA256 b5f8d53f0b447dbd720a0f2607a0e7902c227c7377326bf279e448ed570dcc89 charm-5.9.tar.gz 7580639