summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-08-21 07:11:54 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-08-21 07:11:54 +0000
commitfcf017b6c91216c4852cd797648de43805097704 (patch)
tree16a38e51a9b1269816a10d1682e33cfa36fb12ff /x11-apps/ccsm/ccsm-0.5.2.ebuild
parentInitial import of compiz-fusion from xeffects overlay. (diff)
downloadje_fro-fcf017b6c91216c4852cd797648de43805097704.tar.gz
je_fro-fcf017b6c91216c4852cd797648de43805097704.tar.bz2
je_fro-fcf017b6c91216c4852cd797648de43805097704.zip
Adding x11-apps.
svn path=/; revision=48
Diffstat (limited to 'x11-apps/ccsm/ccsm-0.5.2.ebuild')
-rw-r--r--x11-apps/ccsm/ccsm-0.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-apps/ccsm/ccsm-0.5.2.ebuild b/x11-apps/ccsm/ccsm-0.5.2.ebuild
new file mode 100644
index 0000000..add6488
--- /dev/null
+++ b/x11-apps/ccsm/ccsm-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Compizconfig Settings Manager"
+HOMEPAGE="http://opencompositing.org"
+SRC_URI="http://releases.compiz-fusion.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND="~dev-python/compizconfig-python-${PV}
+ >=dev-python/pygtk-2.10"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ cd ${S}
+ ./setup.py build --prefix=/usr
+}
+
+src_install() {
+ ./setup.py install --root=${D} --prefix=/usr
+}
+
+pkg_postinst() {
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ einfo "Please report all bugs at http://forums.gentoo-xeffects.org/"
+ einfo "Thank you on behalf of the Gentoo Xeffects team"
+}