summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-10-24 03:56:17 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-10-24 03:56:17 +0000
commit9f8954fc4de58fb4245ee74aa2527ed15a14a7a3 (patch)
tree9ebed767cc973e4491053a9198cc8b0a1118ee81 /x11-drivers/ati-drivers
parentlatest version in the tree (diff)
downloadje_fro-9f8954fc4de58fb4245ee74aa2527ed15a14a7a3.tar.gz
je_fro-9f8954fc4de58fb4245ee74aa2527ed15a14a7a3.tar.bz2
je_fro-9f8954fc4de58fb4245ee74aa2527ed15a14a7a3.zip
adding stuff from bugzilla
svn path=/; revision=106
Diffstat (limited to 'x11-drivers/ati-drivers')
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild2
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild_fromBugzilla430
-rw-r--r--x11-drivers/ati-drivers/files/8.42.3/ati-drivers-2.6.23.patch127
3 files changed, 527 insertions, 32 deletions
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild
index 9092660..4c839da 100644
--- a/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild
@@ -285,7 +285,7 @@ src_install() {
# etc.
insinto /etc/ati
# Everything except for the authatieventsd.sh script.
- doins common/etc/ati/{fglrxprofiles.csv,fglrxrc,logo*,control,atiogl.xml,signature}
+ doins common/etc/ati/{logo*,control,atiogl.xml,signature}
if use acpi; then
doins common/etc/ati/authatieventsd.sh
fi
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild_fromBugzilla b/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild_fromBugzilla
new file mode 100644
index 0000000..3dcde9b
--- /dev/null
+++ b/x11-drivers/ati-drivers/ati-drivers-8.42.3.ebuild_fromBugzilla
@@ -0,0 +1,430 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.40.4.ebuild,v 1.3 2007/10/09 08:11:29 dberkholz Exp $
+
+IUSE="acpi multilib"
+
+inherit eutils multilib linux-mod toolchain-funcs versionator
+
+DESCRIPTION="Ati precompiled drivers for recent chipsets"
+HOMEPAGE="http://www.ati.com"
+ATI_URL="https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/"
+SRC_URI="${ATI_URL}/ati-driver-installer-${PV}-x86.x86_64.run"
+
+LICENSE="AMD GPL-2 QPL-1.0 as-is"
+KEYWORDS="~amd64 ~x86"
+
+# The portage dep is for COLON_SEPARATED support in env-update.
+# The eselect dep (>=1.0.9) is for COLON_SEPARATED in eselect env update.
+RDEPEND="x11-base/xorg-server
+ !x11-apps/ati-drivers-extra
+ >=app-admin/eselect-1.0.9
+ app-admin/eselect-opengl
+ =virtual/libstdc++-3.3*
+ amd64? ( multilib? ( app-emulation/emul-linux-x86-compat ) )
+ acpi? (
+ x11-apps/xauth
+ sys-power/acpid
+ )
+ >=sys-apps/portage-2.1.1-r1"
+
+DEPEND="${RDEPEND}
+ x11-proto/xf86miscproto
+ x11-proto/xf86vidmodeproto"
+
+EMULTILIB_PKG="true"
+
+QA_EXECSTACK_x86="usr/lib/dri/fglrx_dri.so
+ usr/lib/opengl/ati/lib/libGL.so.1.2
+ opt/bin/amdcccle"
+QA_EXECSTACK_amd64="usr/lib64/dri/fglrx_dri.so
+ usr/lib32/dri/fglrx_dri.so
+ usr/lib64/opengl/ati/lib/libGL.so.1.2
+ usr/lib32/opengl/ati/lib/libGL.so.1.2
+ opt/bin/amdcccle"
+QA_TEXTRELS_x86="usr/lib/dri/fglrx_dri.so
+ usr/lib/xorg/modules/drivers/fglrx_drv.so
+ usr/lib/opengl/ati/lib/libGL.so.1.2"
+QA_TEXTRELS_amd64="
+ usr/lib64/opengl/ati/lib/libGL.so.1.2
+ usr/lib32/opengl/ati/lib/libGL.so.1.2
+ usr/lib64/dri/fglrx_dri.so
+ usr/lib32/dri/fglrx_dri.so"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ #check kernel and sets up KV_OBJ
+ MODULE_NAMES="fglrx(video:${S}/common/lib/modules/fglrx/build_mod/2.6.x)"
+ BUILD_TARGETS="kmod_build"
+ linux-mod_pkg_setup
+ BUILD_PARAMS="GCC_VER_MAJ=$(gcc-major-version) KVER=${KV_FULL} KDIR=${KV_DIR}"
+
+ if ! kernel_is 2 6; then
+ eerror "Need a 2.6 kernel to compile against!"
+ die "Need a 2.6 kernel to compile against!"
+ fi
+
+ if ! linux_chkconfig_present MTRR; then
+ ewarn "You don't have MTRR support enabled, the direct rendering will not work."
+ fi
+
+ if linux_chkconfig_builtin DRM; then
+ ewarn "You have DRM support enabled builtin, the direct rendering will not work."
+ fi
+
+ if ! linux_chkconfig_present AGP && \
+ ! linux_chkconfig_present PCIEPORTBUS; then
+ ewarn "You need AGP and/or PCI Express support for direct rendering to work."
+ fi
+
+ if linux_chkconfig_present PARAVIRT; then
+ eerror "The current ati-drivers don't compile when having"
+ eerror "paravirtualization active due to GPL symbol export"
+ eerror "restrictions."
+ eerror "Please disable it:"
+ eerror " CONFIG_PARAVIRT=n"
+ eerror "in /usr/src/linux/.config or"
+ eerror " Processor type and features -->"
+ eerror " [ ] Paravirtualization support (EXPERIMENTAL)"
+ eerror "in 'menuconfig'"
+ die "CONFIG_PARAVIRT enabled"
+ fi
+
+ # xorg-server 1.1 and its prereleases correspond to xorg 7.1.
+ if has_version ">=x11-base/xorg-server-1.0.99"; then
+ BASE_DIR="${S}/x710"
+ else
+ BASE_DIR="${S}/x690"
+ fi
+
+ if use amd64 ; then
+ BASE_DIR="${BASE_DIR}_64a"
+ # This is used like $(get_libdir) for paths in ati's package.
+ PKG_LIBDIR=lib64
+ ARCH_DIR="${S}/arch/x86_64"
+ else
+ PKG_LIBDIR=lib
+ ARCH_DIR="${S}/arch/x86"
+ fi
+}
+
+src_unpack() {
+ local src="${DISTDIR}/${A}"
+ # This is apparently a nonstandard makeself archive, so extract
+ # the offset by hand.
+ local offset=$(grep -am1 SKIP "${src}" | sed -e 's/SKIP="\([0-9]\+\)"/\1/')
+
+ #Switching to a standard way to extract the files since otherwise no signature file
+ #would be created
+ sh "${src}" --extract "${S}" 2&>1 /dev/null
+
+ # These are the userspace utilities that we also have source for.
+ # We rebuild these later.
+ rm \
+ "${ARCH_DIR}"/usr/X11R6/bin/{fgl_glxgears,fglrx_xgamma} \
+ "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR}/libfglrx_gamma* \
+ || die "bin rm failed"
+
+ if use acpi; then
+ sed -i \
+ -e "s:/var/lib/xdm/authdir/:/etc/X11/xdm/authdir/:" \
+ -e "s:/var/lib/gdm/:/var/gdm/:" \
+ -e "s/#ffff#/#ffff##:.*MIT-MAGIC-COOKIE/" \
+ "${S}/common/etc/ati/authatieventsd.sh" \
+ || die "sed failed."
+
+ # Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/
+ epatch "${FILESDIR}"/ati-powermode-opt-path.patch
+ fi
+
+ pushd common/lib/modules/fglrx/build_mod >/dev/null
+ ln -s "${ARCH_DIR}"/lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC$(gcc-major-version) \
+ || die "symlinking precompiled core failed"
+
+ convert_to_m 2.6.x/Makefile || die "convert_to_m failed"
+
+ # When built with ati's make.sh it defines a bunch of macros if
+ # certain .config values are set, falling back to less reliable
+ # detection methods if linux/autoconf.h is not available. We
+ # simply use the linux/autoconf.h settings directly, bypassing the
+ # detection script.
+ sed -i -e 's/__SMP__/CONFIG_SMP/' *.c *h || die "SMP sed failed"
+ sed -i -e 's/ifdef MODVERSIONS/ifdef CONFIG_MODVERSIONS/' *.c *.h \
+ || die "MODVERSIONS sed failed"
+ popd >/dev/null
+
+ mkdir extra || die "mkdir failed"
+ cd extra
+ unpack ./../common/usr/src/ati/fglrx_sample_source.tgz
+ sed -i -e 's:include/extensions/extutil.h:X11/extensions/extutil.h:' \
+ lib/fglrx_gamma/fglrx_gamma.c || die "include fixup failed"
+ # Add a category.
+ mv programs/fglrx_gamma/fglrx_xgamma.{man,1} || die "man mv failed"
+ cd ..
+
+ # Misc. patches.
+ epatch "${FILESDIR}"/${PV}/${P}-warnings.patch
+
+ if kernel_is ge 2 6 23; then
+ epatch "${FILESDIR}"/${PV}/${PN}-2.6.23.patch
+ fi
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ einfo "Building fgl_glxgears"
+ cd "${S}"/extra/fgl_glxgears
+ # These extra libs/utils either have an Imakefile that does not
+ # work very well without tweaking or a Makefile ignoring CFLAGS
+ # and the like. We bypass those.
+
+ # The -DUSE_GLU is needed to compile using nvidia headers
+ # according to a comment in ati-drivers-extra-8.33.6.ebuild.
+ "$(tc-getCC)" -o fgl_fglxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU \
+ -I"${S}"/common/usr/include fgl_glxgears.c \
+ -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed"
+
+ einfo "Building fglrx_gamma lib"
+ cd "${S}"/extra/lib/fglrx_gamma
+ "$(tc-getCC)" -shared -fpic -o libfglrx_gamma.so.1.0 ${CFLAGS} ${LDFLAGS} \
+ -DXF86MISC -Wl,-soname,libfglrx_gamma.so.1.0 fglrx_gamma.c \
+ -lXext || die "fglrx_gamma lib build failed"
+ ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so || die "ln failed"
+ ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1 || die "ln failed"
+
+ einfo "Building fglrx_gamma util"
+ cd "${S}"/extra/programs/fglrx_gamma
+ "$(tc-getCC)" -o fglrx_xgamma ${CFLAGS} ${LDFLAGS} \
+ -I../../../common/usr/X11R6/include -L../../lib/fglrx_gamma \
+ fglrx_xgamma.c -lm -lfglrx_gamma -lX11 \
+ || die "fglrx_gamma util build failed"
+
+}
+
+src_install() {
+ linux-mod_src_install
+
+ # We can do two things here, and neither of them is very nice.
+
+ # For direct rendering libGL has to be able to load one or more
+ # dri modules (files ending in _dri.so, like fglrx_dri.so).
+ # Gentoo's mesa looks for these files in the location specified by
+ # LIBGL_DRIVERS_PATH or LIBGL_DRIVERS_DIR, then in the hardcoded
+ # location /usr/$(get_libdir)/dri. Ati's libGL does the same
+ # thing, but the hardcoded location is /usr/X11R6/lib/modules/dri
+ # on x86 and amd64 32bit, /usr/X11R6/lib64/modules/dri on amd64
+ # 64bit. So we can either put the .so files in that (unusual,
+ # compared to "normal" mesa libGL) location or set
+ # LIBGL_DRIVERS_PATH. We currently do the latter. See also bug
+ # 101539.
+
+ # The problem with this approach is that LIBGL_DRIVERS_PATH
+ # *overrides* the default hardcoded location, it does not extend
+ # it. So if ati-drivers is merged but a non-ati libGL is selected
+ # and its hardcoded path does not match our LIBGL_DRIVERS_PATH
+ # (because it changed in a newer mesa or because it was compiled
+ # for a different set of multilib abis than we are) stuff breaks.
+
+ # We create one file per ABI to work with "native" multilib, see
+ # below.
+
+ echo "COLON_SEPARATED=LIBGL_DRIVERS_PATH" > "${T}/03ati-colon-sep"
+ doenvd "${T}/03ati-colon-sep"
+
+ # All libraries that we have a 32 bit and 64 bit version of on
+ # amd64 are installed in src_install-libs. Everything else
+ # (including libraries only available in native 64bit on amd64)
+ # goes in here.
+
+ # There used to be some code here that tried to detect running
+ # under a "native multilib" portage ((precursor of)
+ # http://dev.gentoo.org/~kanaka/auto-multilib/). I removed that, it
+ # should just work (only doing some duplicate work). --marienz
+ if has_multilib_profile; then
+ local OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ src_install-libs
+ done
+ ABI=${OABI}
+ unset OABI
+ else
+ src_install-libs
+ fi
+
+ # This is sorted by the order the files occur in the source tree.
+
+ # X modules.
+ exeinto /usr/$(get_libdir)/xorg/modules/drivers
+ doexe "${BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/drivers/fglrx_drv.so
+ exeinto /usr/$(get_libdir)/xorg/modules/linux
+ doexe "${BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/linux/libfglrxdrm.so
+ exeinto /usr/$(get_libdir)/xorg/modules
+ doexe "${BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/{esut.a,glesx.so}
+
+ # Arch-specific files.
+ # (s)bin.
+ into /opt
+ if use acpi; then
+ dosbin "${ARCH_DIR}"/usr/sbin/atieventsd
+ fi
+ # We cleaned out the compilable stuff in src_unpack
+ dobin "${ARCH_DIR}"/usr/X11R6/bin/*
+
+ # lib.
+ exeinto /usr/$(get_libdir)
+ # Everything except for the libGL.so installed in src_install-libs.
+ doexe $(find "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR} \
+ -maxdepth 1 -type f -name '*.so*' -not -name 'libGL.so*')
+ insinto /usr/$(get_libdir)
+ doins $(find "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR} \
+ -maxdepth 1 -type f -not -name '*.so*')
+
+ # Common files.
+ # etc.
+ insinto /etc/ati
+ # Everything except for the authatieventsd.sh script.
+ doins common/etc/ati/{logo*,control,atiogl.xml,signature}
+ if use acpi; then
+ doins common/etc/ati/authatieventsd.sh
+ fi
+
+ # include.
+ insinto /usr
+ doins -r common/usr/include
+ insinto /usr/include/X11/extensions
+ doins common/usr/X11R6/include/X11/extensions/fglrx_gamma.h
+
+ # Just the atigetsysteminfo.sh script.
+ into /usr
+ dosbin common/usr/sbin/*
+
+ # data files for the control panel.
+ insinto /usr/share
+ doins -r common/usr/share/ati
+ insinto /usr/share/pixmaps
+ doins common/usr/share/icons/ccc_{large,small}.xpm
+ make_desktop_entry amdcccle 'ATI Catalyst Control Center' \
+ ccc_large.xpm System
+
+ # doc.
+ dohtml -r common/usr/share/doc/fglrx
+
+ if use acpi; then
+ doman common/usr/share/man/man8/atieventsd.8
+
+ pushd common/usr/share/doc/fglrx/examples/etc/acpi >/dev/null
+
+ exeinto /etc/acpi
+ doexe ati-powermode.sh
+ insinto /etc/acpi/events
+ doins events/*
+
+ popd >/dev/null
+ fi
+
+ # Done with the "source" tree. Install tools we rebuilt:
+ dobin extra/fgl_glxgears/fgl_fglxgears
+ newdoc extra/fgl_glxgears/README README.fgl_glxgears
+
+ dolib extra/lib/fglrx_gamma/*so*
+ newdoc extra/lib/fglrx_gamma/README README.libfglrx_gamma
+
+ dobin extra/programs/fglrx_gamma/fglrx_xgamma
+ doman extra/programs/fglrx_gamma/fglrx_xgamma.1
+ newdoc extra/programs/fglrx_gamma/README README.fglrx_gamma
+
+ # Gentoo-specific stuff:
+
+ if use acpi; then
+ newinitd "${FILESDIR}"/atieventsd.init atieventsd \
+ || die "Failed to install atieventsd.init.d"
+ echo 'ATIEVENTSDOPTS=""' > "${T}"/atieventsd.conf
+ newconfd "${T}"/atieventsd.conf atieventsd
+ fi
+}
+
+src_install-libs() {
+ if [[ "${ABI}" == "amd64" ]]; then
+ local pkglibdir=lib64
+ else
+ local pkglibdir=lib
+ fi
+ einfo "ati tree '${pkglibdir}' -> '$(get_libdir)' on system"
+
+ local ATI_ROOT=/usr/$(get_libdir)/opengl/ati
+ # To make sure we do not miss a spot when these change.
+ local libmajor=1 libminor=2
+ local libver=${libmajor}.${libminor}
+
+ # The GLX libraries
+ # (yes, this really is "lib" even on amd64/multilib --marienz)
+ exeinto ${ATI_ROOT}/lib
+ if [[ "${ABI}" == "amd64" ]]; then
+ doexe "${ARCH_DIR}"/usr/X11R6/${pkglibdir}/libGL.so.${libver}
+ else
+ doexe "${WORKDIR}"/arch/x86/usr/X11R6/${pkglibdir}/libGL.so.${libver}
+ fi
+ dosym libGL.so.${libver} ${ATI_ROOT}/lib/libGL.so.${libmajor}
+ dosym libGL.so.${libver} ${ATI_ROOT}/lib/libGL.so
+
+ # Same as the xorg implementation (eselect opengl does not fall
+ # back to xorg-x11 if we omit this symlink, meaning no glx).
+ dosym ../xorg-x11/extensions ${ATI_ROOT}/extensions
+
+ # DRI modules, installed into the path used by recent versions of mesa.
+ exeinto /usr/$(get_libdir)/dri
+ if [[ "${ABI}" == "amd64" ]]; then
+ doexe "${ARCH_DIR}"/usr/X11R6/${pkglibdir}/modules/dri/fglrx_dri.so
+ else
+ doexe "${WORKDIR}"/arch/x86/usr/X11R6/${pkglibdir}/modules/dri/fglrx_dri.so
+ fi
+
+ # Make up a libGL.la. Ati does not provide one, but mesa does. If
+ # a (libtool-based) libfoo is built with libGL.la present a
+ # reference to it is put into libfoo.la, and compiling
+ # (libtool-based) things that link too libfoo.la will complain if
+ # libGL.la disappears. So if we do not make up a libGL.la
+ # switching between mesa and ati becomes painful.
+ #
+ # According to the libtool manual the "revision" should be updated
+ # whenever the code changes. We construct this from the version
+ # (8.37.6 becomes 83706).
+ local revision=$(printf '%d%02d%02d' $(get_version_components))
+ sed -e "s:\${libmajor}:${libmajor}:g" \
+ -e "s:\${libminor}:${libminor}:g" \
+ -e "s:\${libdir}:$(get_libdir):g" \
+ -e "s:\${revision}:${revision}:g" \
+ "${FILESDIR}"/libGL.la.in > "${D}"/${ATI_ROOT}/lib/libGL.la \
+ || die "sed failed to make libGL.la"
+
+ local envname="${T}"/04ati-dri-path
+ if [[ -n ${ABI} ]]; then
+ envname="${envname}-${ABI}"
+ fi
+ echo "LIBGL_DRIVERS_PATH=/usr/$(get_libdir)/dri" > "${envname}"
+ doenvd "${envname}"
+}
+
+pkg_postinst() {
+ /usr/bin/eselect opengl set --use-old ati
+
+ elog "To switch to ATI OpenGL, run \"eselect opengl set ati\""
+ elog "To change your xorg.conf you can use the bundled \"aticonfig\""
+ elog
+ elog "If you experience unexplained segmentation faults and kernel crashes"
+ elog "with this driver and multi-threaded applications such as wine,"
+ elog "set UseFastTLS in xorg.conf to either 0 or 1, but not 2."
+ elog
+ # (to get the LIBGL_DRIVERS_PATH)
+ elog "You will have to source /etc/profile (or logout and back in) for dri"
+ elog "to work, unless you previously had ati-drivers installed."
+ # DRM module
+ linux-mod_pkg_postinst
+}
+
+pkg_postrm() {
+ linux-mod_pkg_postrm
+ /usr/bin/eselect opengl set --use-old xorg-x11
+}
diff --git a/x11-drivers/ati-drivers/files/8.42.3/ati-drivers-2.6.23.patch b/x11-drivers/ati-drivers/files/8.42.3/ati-drivers-2.6.23.patch
index 9713208..fab41b3 100644
--- a/x11-drivers/ati-drivers/files/8.42.3/ati-drivers-2.6.23.patch
+++ b/x11-drivers/ati-drivers/files/8.42.3/ati-drivers-2.6.23.patch
@@ -1,41 +1,106 @@
-diff -Naur common/lib/modules/fglrx/build_mod/firegl_public.c common/lib/modules/fglrx/build_mod/firegl_public.c
---- common/lib/modules/fglrx/build_mod/firegl_public.c 2007-07-29 13:36:37.000000000 +0200
-+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2007-07-29 14:24:11.000000000 +0200
-@@ -2409,7 +2409,11 @@
- #ifdef pte_offset_map
- pte_p = pte_offset_map(pmd_p, virtual_addr);
- if (pte_present(*pte_p))
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)
- ret = (ptep_clear_flush_dirty(vma, virtual_addr, pte_p) ? 1 : 0);
+8.43.3 for 2.6.23 compatibility
+
+--- firegl_public.c.orig 2007-10-23 19:31:26.000000000 +0200
++++ firegl_public.c 2007-10-23 19:32:07.000000000 +0200
+@@ -217,6 +217,56 @@
+ #define preempt_enable()
+ #endif
+
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,22)
++#if defined(__i386__)
++#define ptep_test_and_clear_dirty(vma, addr, ptep) ({ \
++ int __ret = 0; \
++ if (pte_dirty(*(ptep))) \
++ __ret = test_and_clear_bit(_PAGE_BIT_DIRTY, \
++ &(ptep)->pte_low); \
++ if (__ret) \
++ pte_update((vma)->vm_mm, addr, ptep); \
++ __ret; \
++})
++
++static inline int pte_read(pte_t pte) { return (pte).pte_low & _PAGE_USER; }
++static inline int pte_user(pte_t pte) { return (pte).pte_low & _PAGE_USER; }
++#ifdef CONFIG_X86_PAE
++/*
++ * Is the pte executable?
++ */
++static inline int pte_x(pte_t pte)
++{
++ return !(pte_val(pte) & _PAGE_NX);
++}
++
++/*
++ * All present user-pages with !NX bit are user-executable:
++ */
++static inline int pte_exec(pte_t pte)
++{
++ return pte_user(pte) && pte_x(pte);
++}
+#else
-+ return 0;
++static inline int pte_exec(pte_t pte)
++{
++ return pte_user(pte);
++}
++#endif /* PAE */
++
++#elif defined(__x86_64__)
++static inline int ptep_test_and_clear_dirty(struct vm_area_struct *vma,
++ unsigned long addr, pte_t *ptep)
++{
++ if (!pte_dirty(*ptep))
++ return 0;
++ return test_and_clear_bit(_PAGE_BIT_DIRTY, &ptep->pte);
++}
++static inline int pte_read(pte_t pte) { return pte_val(pte) & _PAGE_USER; }
++static inline int pte_exec(pte_t pte) { return !(pte_val(pte) & _PAGE_NX); }
+#endif
- else
- __KE_DEBUG("page not exists!\n");
- pte_unmap(pte_p);
-@@ -3399,9 +3403,11 @@
- sprintf(buf, "0x%Lx %c%c%c%c%c%c\n",
- *phys_address,
- pte_present (pte) ? 'p' : '-',
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
- pte_read (pte) ? 'r' : '-',
-- pte_write (pte) ? 'w' : '-',
- pte_exec (pte) ? 'x' : '-',
+#endif
-+ pte_write (pte) ? 'w' : '-',
- pte_dirty (pte) ? 'd' : '-',
- pte_young (pte) ? 'a' : '-');
- }
-@@ -5348,7 +5354,11 @@
++
+ // ============================================================
+ /* globals */
+
+@@ -2489,7 +2539,7 @@ void ATI_API_CALL __ke_put_vm_page_table
+ #ifndef ptep_clear_flush_dirty
+ #define ptep_clear_flush_dirty(__vma, __address, __ptep) \
+ ({ \
+- int __dirty = ptep_test_and_clear_dirty(__ptep); \
++ int __dirty = ptep_test_and_clear_dirty(__vma, __address, __ptep); \
+ if (__dirty) \
+ flush_tlb_page(__vma, __address); \
+ __dirty; \
+@@ -2936,7 +2986,7 @@ int ATI_API_CALL __ke_request_irq(unsign
+ {
+ return request_irq(irq,
+ (void(*)(int, void *, struct pt_regs *))handler,
+- SA_SHIRQ, dev_name, dev_id);
++ IRQF_SHARED, dev_name, dev_id);
+ }
+
+ void ATI_API_CALL __ke_free_irq(unsigned int irq, void *dev_id)
+@@ -2959,7 +3009,7 @@ int ATI_API_CALL __ke_request_irq(unsign
+ irq_handler_func = handler;
+ return request_irq(irq,
+ ke_irq_handler_wrap,
+- SA_SHIRQ, dev_name, dev_id);
++ IRQF_SHARED, dev_name, dev_id);
+ }
+
+ void ATI_API_CALL __ke_free_irq(unsigned int irq, void *dev_id)
+@@ -5436,7 +5486,7 @@ unsigned int ATI_API_CALL KAS_Spinlock_R
+ /** \brief Type definition of the structure describing Slab Cache object */
+ typedef struct tag_kasSlabCache_t
+ {
+- kmem_cache_t* cache; /* OS slab cache object */
++ struct kmem_cache *cache; /* OS slab cache object */
+ spinlock_t lock; /* OS spinlock object protecting the cache */
+ unsigned int routine_type; /* Type of routine the cache might be accessed from */
+ char name[14]; /* Cache object name (kernel 2.4 restricts its length to 19 chars) */
+@@ -5482,7 +5532,7 @@ unsigned int ATI_API_CALL KAS_SlabCache_
DBG_TRACE("creating slab object '%s'", slabcache_obj->name);
if ((slabcache_obj->cache =
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
- kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL, NULL)))
-+#else
+- kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL, NULL)))
+ kmem_cache_create(slabcache_obj->name, iEntrySize, 0, 0, NULL)))
-+#endif
{
ret = 1;
}
-