summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-tv/ivtv/Manifest8
-rw-r--r--media-tv/ivtv/files/digest-ivtv-1.0.13
-rw-r--r--media-tv/ivtv/ivtv-1.0.1.ebuild133
3 files changed, 144 insertions, 0 deletions
diff --git a/media-tv/ivtv/Manifest b/media-tv/ivtv/Manifest
new file mode 100644
index 0000000..fcbfa54
--- /dev/null
+++ b/media-tv/ivtv/Manifest
@@ -0,0 +1,8 @@
+DIST ivtv-1.0.1.tar.gz 302883 RMD160 c7259d94513bab12ffc99cb369e9e37e085e9806 SHA1 212c2bb217fda7e3adaf6ff8d2bceabecaa88fbd SHA256 93c15a46b283f1d4c2ff2514752cfc21de089a6e76479b556f521222642a8896
+EBUILD ivtv-1.0.1.ebuild 4316 RMD160 6390d7b79abbf173739b6503abb4f57a3fd7def5 SHA1 fdb167a9b01d178417fc10395ee6af839c61bbff SHA256 c758cbf1d10540a8ec4176cf51a8addeb6d859835c1f19e0ae845356a8025b78
+MD5 3016fd61d06a32c953c28906fea78a7d ivtv-1.0.1.ebuild 4316
+RMD160 6390d7b79abbf173739b6503abb4f57a3fd7def5 ivtv-1.0.1.ebuild 4316
+SHA256 c758cbf1d10540a8ec4176cf51a8addeb6d859835c1f19e0ae845356a8025b78 ivtv-1.0.1.ebuild 4316
+MD5 ca720e155ecbe204bdc6662435f7a494 files/digest-ivtv-1.0.1 232
+RMD160 6d8fde8b8abe1c7c2228c811acbac8574884e15b files/digest-ivtv-1.0.1 232
+SHA256 f9c1f984f9eeb2df84cb8844f0dcbbdfb92b57e33f74d366c06710997129559a files/digest-ivtv-1.0.1 232
diff --git a/media-tv/ivtv/files/digest-ivtv-1.0.1 b/media-tv/ivtv/files/digest-ivtv-1.0.1
new file mode 100644
index 0000000..b6facf3
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-1.0.1
@@ -0,0 +1,3 @@
+MD5 41810e3d704b0abc5aa8e09da4b4f99c ivtv-1.0.1.tar.gz 302883
+RMD160 c7259d94513bab12ffc99cb369e9e37e085e9806 ivtv-1.0.1.tar.gz 302883
+SHA256 93c15a46b283f1d4c2ff2514752cfc21de089a6e76479b556f521222642a8896 ivtv-1.0.1.tar.gz 302883
diff --git a/media-tv/ivtv/ivtv-1.0.1.ebuild b/media-tv/ivtv/ivtv-1.0.1.ebuild
new file mode 100644
index 0000000..71ab81c
--- /dev/null
+++ b/media-tv/ivtv/ivtv-1.0.1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.0.x/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="fbcon"
+RDEPEND="|| ( >=sys-fs/udev-103 sys-apps/hotplug )"
+DEPEND="app-arch/unzip"
+PDEPEND="=media-tv/pvr-firmware-20070217"
+
+pkg_setup() {
+
+ MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
+ BUILD_TARGETS="all"
+ CONFIG_CHECK="EXPERIMENTAL KMOD VIDEO_DEV I2C VIDEO_V4L1_COMPAT VIDEO_V4L2
+ !VIDEO_HELPER_CHIPS_AUTO
+ FW_LOADER VIDEO_WM8775 VIDEO_MSP3400 VIDEO_CX25840 VIDEO_TUNER
+ VIDEO_SAA711X VIDEO_CX2341X VIDEO_SAA7127 VIDEO_TVEEPROM VIDEO_IVTV"
+
+ if use fbcon; then
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+ CONFIG_CHECK="${CONFIG_CHECK} FB FB_TRIDENT FRAMEBUFFER_CONSOLE FONTS"
+ fi
+
+ if ! ( kernel_is 2 6 22 ); then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different ivtv driver"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ die "This only works on 2.6.22 kernels"
+ fi
+
+ if use fbcon; then
+ ewarn ""
+ ewarn "From the README regarding framebuffer support:"
+ ewarn ""
+ ewarn "ivtv-fb now requires that you enable the following kernel config"
+ ewarn "options: Go to 'Device drivers -> Graphics support'. Enable"
+ ewarn "'Support for frame buffer devices'. Enable 'Trident support'"
+ ewarn "(the Trident module itself is not required)."
+ ewarn ""
+ ewarn "To get working console output, keep going to 'Console display"
+ ewarn "driver support', and enable 'Framebuffer Console support'."
+ ewarn "Enable 'Select compiled-in fonts' & once that's done, you should"
+ ewarn "have a list of fonts. Choose one. With the default OSD size,"
+ ewarn "'VGA 8x16' gives 80x30(PAL) 80x25(NTSC)."
+ ewarn ""
+ ewarn "This ebuild checks for all the correct kernel config options for"
+ ewarn "framebuffer use with the exception of choosing a font. Be sure"
+ ewarn "to pick one yourself!"
+ ewarn ""
+ fi
+
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_compile() {
+
+ cd "${S}/driver"
+ linux-mod_src_compile || die "failed to build driver"
+
+ cd "${S}/utils"
+ emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
+}
+
+src_install() {
+ cd "${S}/utils"
+ make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
+ dobin perl/*.pl
+
+ cd "${S}"
+ dodoc README* doc/* utils/README.X11 ChangeLog* utils/perl/README.ptune
+
+ cd "${S}/driver"
+ linux-mod_src_install || die "failed to install modules"
+}
+
+pkg_postinst() {
+
+ linux-mod_pkg_postinst
+
+ elog ""
+ elog "This version of the IVTV driver supports the following hardware:"
+ elog "Hauppauge WinTV PVR-250"
+ elog "Hauppauge WinTV PVR-350"
+ elog "Hauppauge WinTV PVR-150"
+ elog "Hauppauge WinTV PVR-500"
+ elog "AVerMedia M179"
+ elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
+ elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
+ elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
+ elog "Adaptec AVC-2410"
+ elog "Adaptec AVC-2010"
+ elog "Nagase Transgear 5000TV"
+ elog "AOpen VA2000MAX-STN6"
+ elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
+ elog "I/O Data GV-MVP/RX"
+ elog "I/O Data GV-MVP/RX2E"
+ elog "Gotview PCI DVD (preliminary support only)"
+ elog "Gotview PCI DVD2 Deluxe"
+ elog "Yuan MPC622"
+ elog ""
+ ewarn ""
+ ewarn "IMPORTANT: In case of problems first read this page:"
+ ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
+ ewarn ""
+ ewarn "If any of these conditions match your setup, you may want to look at the"
+ ewarn "README in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn " - Using MythTV, a PVR-350 and the ivtv-fb module"
+ ewarn " - Using the ivtv X driver and the ivtv-fb module"
+ ewarn " - You want to manually build ivtv against v4l-dvb"
+ ewarn ""
+ ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
+ ewarn "proper use and debugging utilities."
+ ewarn "They are also located in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn "For more information, see the IVTV driver homepage at:"
+ ewarn "http://www.ivtvdriver.org/"
+}