summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/pommed/Manifest8
-rw-r--r--app-laptop/pommed/files/digest-pommed-1.133
-rw-r--r--app-laptop/pommed/pommed-1.13.ebuild97
-rw-r--r--x11-drivers/synaptics-git/Manifest11
-rw-r--r--x11-drivers/synaptics-git/files/digest-synaptics-git-99990
-rw-r--r--x11-drivers/synaptics-git/synaptics-git-9999.ebuild44
6 files changed, 108 insertions, 55 deletions
diff --git a/app-laptop/pommed/Manifest b/app-laptop/pommed/Manifest
new file mode 100644
index 0000000..c0e17e7
--- /dev/null
+++ b/app-laptop/pommed/Manifest
@@ -0,0 +1,8 @@
+DIST pommed-1.13.tar.gz 997661 RMD160 bf51893b2039005912b6d8fc01dd8d2ce2cce3f5 SHA1 6ac0fd55ab4e577e3ce394bc299924612882fb01 SHA256 0b3a76467aac72cd06757a3f37c11960f406431521161ed17f6350eb7da79036
+EBUILD pommed-1.13.ebuild 2270 RMD160 535740e75b096e4ff9e8203a42ed1fb801e942a3 SHA1 9aa4d5ee08b043535b8d50a43d1d7c855a38ae2d SHA256 55b7f80a2e440fca8eba9d17ae08891762fd6596395061729736466042d234e5
+MD5 74369a07451aef415194bb2ea24b8a54 pommed-1.13.ebuild 2270
+RMD160 535740e75b096e4ff9e8203a42ed1fb801e942a3 pommed-1.13.ebuild 2270
+SHA256 55b7f80a2e440fca8eba9d17ae08891762fd6596395061729736466042d234e5 pommed-1.13.ebuild 2270
+MD5 cee5eb16fb39ed5dbe7d1eb54458814d files/digest-pommed-1.13 235
+RMD160 2f72a2a41d6a5ab156635605c0785bb385aaa912 files/digest-pommed-1.13 235
+SHA256 c86d42ef2db0c7f89bbbe5fa0c634e119b2a5b44c4ab0fd4db412506d4d70042 files/digest-pommed-1.13 235
diff --git a/app-laptop/pommed/files/digest-pommed-1.13 b/app-laptop/pommed/files/digest-pommed-1.13
new file mode 100644
index 0000000..a951f18
--- /dev/null
+++ b/app-laptop/pommed/files/digest-pommed-1.13
@@ -0,0 +1,3 @@
+MD5 f7d3b12f8b2bce4fc90fa8de2e6ccbc9 pommed-1.13.tar.gz 997661
+RMD160 bf51893b2039005912b6d8fc01dd8d2ce2cce3f5 pommed-1.13.tar.gz 997661
+SHA256 0b3a76467aac72cd06757a3f37c11960f406431521161ed17f6350eb7da79036 pommed-1.13.tar.gz 997661
diff --git a/app-laptop/pommed/pommed-1.13.ebuild b/app-laptop/pommed/pommed-1.13.ebuild
new file mode 100644
index 0000000..5281c8c
--- /dev/null
+++ b/app-laptop/pommed/pommed-1.13.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/pommed-1.12.ebuild,v 1.1 2007/11/24 11:14:07 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Daemon managing special features such as screen and keyboard \
+backlight on Apple MacBook Pro/PowerBook laptops"
+HOMEPAGE="http://technologeek.org/projects/pommed/index.html"
+ALIOTH_NUMBER="2196"
+SRC_URI="http://alioth.debian.org/frs/download.php/${ALIOTH_NUMBER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk X"
+
+DEPEND="media-libs/alsa-lib
+ x86? ( sys-apps/pciutils
+ >=sys-libs/libsmbios-0.13.6 )
+ amd64? ( sys-apps/pciutils
+ >=sys-libs/libsmbios-0.13.6 )
+ dev-libs/confuse
+ sys-apps/dbus
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ media-libs/audiofile )
+ X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}
+ virtual/eject"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.11.patch"
+}
+
+src_compile() {
+ cd "${S}"/pommed
+ emake CC="$(tc-getCC)" OFLIB=1 || die "emake pommed failed"
+
+ if use gtk; then
+ cd "${S}"/gpomme
+ local POFILES=""
+ for LANG in ${LINGUAS}; do
+ if [ -f po/${LANG}.po ]; then
+ POFILES="${POFILES} po/${LANG}.po"
+ fi
+ done
+ emake CC="$(tc-getCC)" POFILES="${POFILES}" || die "emake gpomme failed"
+ fi
+ if use X; then
+ cd "${S}"/wmpomme
+ emake CC="$(tc-getCC)" || die "emake wmpomme failed"
+ fi
+}
+
+src_install() {
+ insinto /etc
+ if use x86 || use amd64; then
+ newins pommed.conf.mactel pommed.conf
+ elif use ppc; then
+ newins pommed.conf.pmac pommed.conf
+ fi
+
+ insinto /etc/dbus-1/system.d
+ newins dbus-policy.conf pommed.conf
+
+ dobin pommed/pommed
+
+ newinitd "${FILESDIR}"/pommed.rc pommed
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ if use gtk ; then
+ dobin gpomme/gpomme
+ for LANG in ${LINGUAS}; do
+ if [ -f gpomme/po/${LANG}.mo ]; then
+ einfo "Installing lang ${LANG}"
+ insinto /usr/share/locale/${LANG}/LC_MESSAGES/
+ doins gpomme/po/${LANG}.mo
+ fi
+ done
+
+ insinto /usr/share/applications
+ doins gpomme/gpomme.desktop
+ doins gpomme/gpomme-c.desktop
+ insinto /usr/share/gpomme/
+ doins -r gpomme/themes
+ doins gpomme/gpomme.glade
+ fi
+
+ if use X ; then
+ dobin wmpomme/wmpomme
+ fi
+}
diff --git a/x11-drivers/synaptics-git/Manifest b/x11-drivers/synaptics-git/Manifest
deleted file mode 100644
index 151bdb5..0000000
--- a/x11-drivers/synaptics-git/Manifest
+++ /dev/null
@@ -1,11 +0,0 @@
-AUX pixman.patch 608 RMD160 58443642d799450d01ac247729b85ef6058b45bd SHA1 349c4ea548c3d16f7a7aaf5fcd801d8b587a1703 SHA256 acfa4a429ef199184dee65dcc941d6ff2c4f26eecce1542b3afaec5a5890db69
-MD5 a4dd93ab017feeff39b27bdcd98fbcbb files/pixman.patch 608
-RMD160 58443642d799450d01ac247729b85ef6058b45bd files/pixman.patch 608
-SHA256 acfa4a429ef199184dee65dcc941d6ff2c4f26eecce1542b3afaec5a5890db69 files/pixman.patch 608
-EBUILD synaptics-git-9999.ebuild 1011 RMD160 d3fd8a307a07339ed183fcc8259bbce81437a48c SHA1 51467544272abb70e39ec7587c380c9d1c84abc8 SHA256 648434ff1b5c13be7672efc5e2b457c888932763aaab0e301dff8443aeb46a78
-MD5 39cf65af5b032328787aa1426d0bd88b synaptics-git-9999.ebuild 1011
-RMD160 d3fd8a307a07339ed183fcc8259bbce81437a48c synaptics-git-9999.ebuild 1011
-SHA256 648434ff1b5c13be7672efc5e2b457c888932763aaab0e301dff8443aeb46a78 synaptics-git-9999.ebuild 1011
-MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-synaptics-git-9999 0
-RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-synaptics-git-9999 0
-SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-synaptics-git-9999 0
diff --git a/x11-drivers/synaptics-git/files/digest-synaptics-git-9999 b/x11-drivers/synaptics-git/files/digest-synaptics-git-9999
deleted file mode 100644
index e69de29..0000000
--- a/x11-drivers/synaptics-git/files/digest-synaptics-git-9999
+++ /dev/null
diff --git a/x11-drivers/synaptics-git/synaptics-git-9999.ebuild b/x11-drivers/synaptics-git/synaptics-git-9999.ebuild
deleted file mode 100644
index d70f190..0000000
--- a/x11-drivers/synaptics-git/synaptics-git-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EGIT_REPO_URI="http://web.telia.com/~u89404340/touchpad/synaptics/.git/"
-inherit git
-
-DESCRIPTION="The latest from the synaptics git tree."
-HOMEPAGE="http://web.telia.com/~u89404340/touchpad/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="x11-libs/libXext"
-DEPEND="${RDEPEND}
- x11-base/xorg-server
- >=sys-apps/sed-4"
-
-src_unpack() {
- git_src_unpack
-
- # Switch up the CC and CFLAGS stuff.
- sed -i \
- -e "s:CC = gcc:CC = $(tc-getCC):g" \
- -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" \
- "${S}"/Makefile
-
- epatch $FILESDIR/pixman.patch
-}
-
-src_install() {
- make \
- DESTDIR="${D}" \
- PREFIX=/usr \
- MANDIR="${D}"/usr/share/man \
- install || die
-
- dodoc script/usbmouse script/usbhid alps.patch trouble-shooting.txt
- dodoc COMPATIBILITY FILES INSTALL* LICENSE NEWS TODO README*
-
-}