summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild')
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
new file mode 100644
index 0000000..edd4b56
--- /dev/null
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+$Header: $
+
+inherit fdo-mime
+
+DESCRIPTION="A collection of data files to add support for chemical MIME types."
+HOMEPAGE="http://chemical-mime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/-data/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-util/pkgconfig
+ x11-misc/shared-mime-info
+ dev-util/intltool"
+RDEPEND=""
+
+
+src_install() {
+ make DESTDIR=${D} install
+
+# Avoid collisions.
+ rm -rf ${D}/usr/share/mime/XMLnamespaces ${D}/usr/share/mime/magic \
+ ${D}/usr/share/mime/subclasses ${D}/usr/share/mime/mime.cache \
+ ${D}/usr/share/mime/aliases ${D}/usr/share/mime/globs
+
+}
+
+pkg_postinst() {
+# fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}