aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-09-10 12:50:53 +0200
committerJohannes Huber <johu@gentoo.org>2017-09-10 12:50:53 +0200
commit3dedc64323474f1f29033ed2fc80920128afcb02 (patch)
tree21e1bc3429018d6f770144f3b7b258b878c0c91e
parentnet-irc/quassel: Sync with main tree (diff)
downloadjohu-3dedc64323474f1f29033ed2fc80920128afcb02.tar.gz
johu-3dedc64323474f1f29033ed2fc80920128afcb02.tar.bz2
johu-3dedc64323474f1f29033ed2fc80920128afcb02.zip
app-emulation/vagrant-bin: Version bump 2.0.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--app-emulation/vagrant-bin/Manifest1
-rw-r--r--app-emulation/vagrant-bin/vagrant-bin-2.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/vagrant-bin/Manifest b/app-emulation/vagrant-bin/Manifest
index 545b799..63b4aa2 100644
--- a/app-emulation/vagrant-bin/Manifest
+++ b/app-emulation/vagrant-bin/Manifest
@@ -1 +1,2 @@
DIST vagrant_1.9.8_x86_64.deb 79617692 SHA256 bdcb5637bade2e57e47a7b0118598e2b8e883b640319a4417c04f662ec073fc6 SHA512 f8194ff1386b78b445ac7af46ffa33c1bbc9bb52e53e2c00caac025464016dd62595e46ed7dcb65f3300338dbf0c3c192b9013d508b679f05d7ef0d5b927ebdb WHIRLPOOL 2ebf57db4863a2789459a5294733227e68aec6490640053e804f4d8387d1cafd0bb536e0b75830d588a467b1bfee0077ed8ea82364454cb9efdc9ce10020ea4e
+DIST vagrant_2.0.0_x86_64.deb 79650476 SHA256 bd54383e8ca2f7d00e06c9afa8bf7221b26abfe89e9ae950c69de2ee97af8aa0 SHA512 9a90a87ee2be3b2af4000ba63da48936fb1b21852f6e1380370ac8ec94ab9b0a8323d7cfe1a2265316011310f2cab6773f6e21b95279650be1c7f73b42e13952 WHIRLPOOL b09e78f69e489a15adf63faccc6313d89c0882aee105ce249590018dfb7437268ad647be826b0b0b06c70cdd7472f44cf28c26525abe7100a7e938b86f49b07d
diff --git a/app-emulation/vagrant-bin/vagrant-bin-2.0.0.ebuild b/app-emulation/vagrant-bin/vagrant-bin-2.0.0.ebuild
new file mode 100644
index 0000000..feccf0a
--- /dev/null
+++ b/app-emulation/vagrant-bin/vagrant-bin-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-bin/}
+inherit unpacker eutils
+
+DESCRIPTION="Tool for building and distributing virtual machines"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://releases.hashicorp.com/${MY_PN}/${PV}/${MY_PN}_${PV}_x86_64.deb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/opt/${MY_PN}"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ !app-emulation/vagrant
+"
+
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ local dir="/opt/${MY_PN}"
+ dodir ${dir}
+ cp -ar ./* "${ED}${dir}" || die "copy files failed"
+
+ make_wrapper "${MY_PN}" "${dir}/bin/${MY_PN}"
+}