aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-04-14 11:53:03 +0200
committerJohannes Huber <johu@gentoo.org>2017-04-14 11:53:03 +0200
commit82438583ab6b9b38a0cc32e634e6cec446469ccc (patch)
tree29b657557c61c72a4037f4453e7c44b4d7497220
parentmedia-sound/tomahawk: Sync with tree (diff)
downloadjohu-82438583ab6b9b38a0cc32e634e6cec446469ccc.tar.gz
johu-82438583ab6b9b38a0cc32e634e6cec446469ccc.tar.bz2
johu-82438583ab6b9b38a0cc32e634e6cec446469ccc.zip
app-emulation/vagrant-bin: Version bump 1.9.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--app-emulation/vagrant-bin/Manifest1
-rw-r--r--app-emulation/vagrant-bin/vagrant-bin-1.9.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/vagrant-bin/Manifest b/app-emulation/vagrant-bin/Manifest
index 93c7747..333c1a8 100644
--- a/app-emulation/vagrant-bin/Manifest
+++ b/app-emulation/vagrant-bin/Manifest
@@ -1 +1,2 @@
DIST vagrant_1.9.1_x86_64.deb 87330298 SHA256 d006d6227e049725b64d8ba3967f0c82460a403ff40230515c93134d58723150 SHA512 a4445c6410e969a7c3c3b7b647415fb9a0dff7b015bbd9ec85f15df4e22cca130db140338a3476ff9b03a5e14c35b0d5ab607ec4058129066262467a2598e678 WHIRLPOOL 507d378547b136bf0e784bf08d2ecb09de6729061df62b660cd546d5c050cad266c684e80f6ca5852a0bd416064e0bee52c282c342595a2f0c1649fe4c4892a3
+DIST vagrant_1.9.3_x86_64.deb 87666544 SHA256 faff6befacc7eed3978b4b71f0dbb9c135c01d8a4d13236bda2f9ed53482d2c4 SHA512 4ecbd4d5923e7f45552f05f443c076ad2bb8db3dd716133cc2b47fca7ccaa92a5ecfd6e0bf01c3f0d76eddc08d6933fd53917b946915a43f84b565eeca5099dc WHIRLPOOL 7588c1bd35d562e64fbbd360f5f95904a5ba8d2d4c7a979dcd5870526cb933edb0dbba72f213eb91542f386b67a516635f3f1018f32b3418b72c9fb31781d1a6
diff --git a/app-emulation/vagrant-bin/vagrant-bin-1.9.3.ebuild b/app-emulation/vagrant-bin/vagrant-bin-1.9.3.ebuild
new file mode 100644
index 0000000..feccf0a
--- /dev/null
+++ b/app-emulation/vagrant-bin/vagrant-bin-1.9.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-bin/}
+inherit unpacker eutils
+
+DESCRIPTION="Tool for building and distributing virtual machines"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://releases.hashicorp.com/${MY_PN}/${PV}/${MY_PN}_${PV}_x86_64.deb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/opt/${MY_PN}"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ !app-emulation/vagrant
+"
+
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ local dir="/opt/${MY_PN}"
+ dodir ${dir}
+ cp -ar ./* "${ED}${dir}" || die "copy files failed"
+
+ make_wrapper "${MY_PN}" "${dir}/bin/${MY_PN}"
+}