summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-31 05:34:23 +0300
committerMart Raudsepp <leio@dustbite.net>2008-03-31 05:35:08 +0300
commite8478bdcb6f275b69b90d596f2255f97a50a58e1 (patch)
treed93c042ca58ddd889632dd00525d0d6373d52982
parentClean up package.mask - wxmud and gst-plugins-ffmpeg live ebuild are not in t... (diff)
downloadleio-e8478bdcb6f275b69b90d596f2255f97a50a58e1.tar.gz
leio-e8478bdcb6f275b69b90d596f2255f97a50a58e1.tar.bz2
leio-e8478bdcb6f275b69b90d596f2255f97a50a58e1.zip
Add a live ebuild for dev-util/sysprof, as the released version does not support seeing kernel time and functions in the backtrace
-rw-r--r--dev-util/sysprof/Manifest1
-rw-r--r--dev-util/sysprof/sysprof-9999.ebuild44
-rw-r--r--profiles/package.mask3
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
new file mode 100644
index 0000000..d45c4b9
--- /dev/null
+++ b/dev-util/sysprof/Manifest
@@ -0,0 +1 @@
+EBUILD sysprof-9999.ebuild 1224 RMD160 bc4bc7cd7e2f0b0192981bb0583d4571b82097f9 SHA1 101dd4aa261e27ed6c3737922fddfc6f98d8ba9e SHA256 93479ef2a00d45bc4c26ec5ff0e04e15729c4d8baaa89d8167997012bd9c8c5c
diff --git a/dev-util/sysprof/sysprof-9999.ebuild b/dev-util/sysprof/sysprof-9999.ebuild
new file mode 100644
index 0000000..e7af6da
--- /dev/null
+++ b/dev-util/sysprof/sysprof-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/sysprof-1.0.9.ebuild,v 1.2 2008/02/29 18:00:10 carlo Exp $
+
+inherit eutils linux-mod autotools subversion
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://www.daimi.au.dk/~sandmann/sysprof/"
+#SRC_URI="http://www.daimi.au.dk/~sandmann/sysprof/${P}.tar.gz"
+ESVN_REPO_URI="http://svn.gnome.org/svn/sysprof/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.6
+ x11-libs/pango
+ >=gnome-base/libglade-2"
+
+pkg_setup() {
+ MODULE_NAMES="sysprof-module(misc:${S}/module)"
+ CONFIG_CHECK="PROFILING"
+ PROFILING_ERROR="You need to enable Profiling support in your kernel. \
+For this you need to enable 'Profiling support' under 'Instrumentation Support'. \
+It is marked CONFIG_PROFILING in the config file"
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ eautoreconf
+
+ econf --disable-kernel-module || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry sysprof Sysprof sysprof-icon
+}
diff --git a/profiles/package.mask b/profiles/package.mask
new file mode 100644
index 0000000..b535c76
--- /dev/null
+++ b/profiles/package.mask
@@ -0,0 +1,3 @@
+# Mart Raudsepp <leio@gentoo.org> (31 Mar 2008)
+# Live ebuild for testing and getting traces to include kernel symbols until sysprof-1.1 is released
+>=dev-util/sysprof-9999