summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-26 09:49:11 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-26 09:49:11 +0000
commit89529546d1eb24a5b6e2c55396cf400a64b5e0c1 (patch)
treec291edc96e30ae0af8a98c99c67ad5332a4831d7 /app-backup/mondo
parentmigrating to patched tarballs, bumping version of python 2.5 (diff)
downloadliquidx-89529546d1eb24a5b6e2c55396cf400a64b5e0c1.tar.gz
liquidx-89529546d1eb24a5b6e2c55396cf400a64b5e0c1.tar.bz2
liquidx-89529546d1eb24a5b6e2c55396cf400a64b5e0c1.zip
adding mindi and mondo for personal purposes
svn path=/; revision=64
Diffstat (limited to 'app-backup/mondo')
-rw-r--r--app-backup/mondo/Manifest8
-rw-r--r--app-backup/mondo/files/digest-mondo-2.0.93
-rw-r--r--app-backup/mondo/mondo-2.0.9.ebuild59
3 files changed, 70 insertions, 0 deletions
diff --git a/app-backup/mondo/Manifest b/app-backup/mondo/Manifest
new file mode 100644
index 0000000..ad3fe58
--- /dev/null
+++ b/app-backup/mondo/Manifest
@@ -0,0 +1,8 @@
+DIST mondo-2.0.9.tar.gz 3031778 RMD160 b99f541ebbe8b82cbf7f2b445eb1213975079a11 SHA1 c47e9a75d00cdb7211962a909544646f5d9e367f SHA256 debca33b6b97c8e09f8ec0b89b87d04c7488048578e34fca8e94961188aea5f9
+EBUILD mondo-2.0.9.ebuild 1503 RMD160 40f80a159439b9fd03637b6a02a68409a1f14b73 SHA1 c2e035a7e00f2e3d7b7820cc03c338293db625b0 SHA256 0339d6550e365412e28de2297acbf78534f9e768a5a96e4cb8a712570e5dbbae
+MD5 7294fa3568bbb0814c599d810b8f4c82 mondo-2.0.9.ebuild 1503
+RMD160 40f80a159439b9fd03637b6a02a68409a1f14b73 mondo-2.0.9.ebuild 1503
+SHA256 0339d6550e365412e28de2297acbf78534f9e768a5a96e4cb8a712570e5dbbae mondo-2.0.9.ebuild 1503
+MD5 271f48b340491731e702988f8ef60cf8 files/digest-mondo-2.0.9 238
+RMD160 4accf9a4cb9dbd0367bf4c5f1eefe43f63ee23a5 files/digest-mondo-2.0.9 238
+SHA256 50039e44ce338acd725213906cb62acf672f56c711eb2685267487d06f239263 files/digest-mondo-2.0.9 238
diff --git a/app-backup/mondo/files/digest-mondo-2.0.9 b/app-backup/mondo/files/digest-mondo-2.0.9
new file mode 100644
index 0000000..b71a427
--- /dev/null
+++ b/app-backup/mondo/files/digest-mondo-2.0.9
@@ -0,0 +1,3 @@
+MD5 55d432dc477b4d0971f5142a2c3f6534 mondo-2.0.9.tar.gz 3031778
+RMD160 b99f541ebbe8b82cbf7f2b445eb1213975079a11 mondo-2.0.9.tar.gz 3031778
+SHA256 debca33b6b97c8e09f8ec0b89b87d04c7488048578e34fca8e94961188aea5f9 mondo-2.0.9.tar.gz 3031778
diff --git a/app-backup/mondo/mondo-2.0.9.ebuild b/app-backup/mondo/mondo-2.0.9.ebuild
new file mode 100644
index 0000000..76cf408
--- /dev/null
+++ b/app-backup/mondo/mondo-2.0.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit libtool
+
+DESCRIPTION="The premier GPL disaster recovery solution."
+HOMEPAGE="http://www.mondorescue.org"
+SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-libs/slang-1.4.1
+ >=dev-libs/newt-0.50"
+
+RDEPEND="app-arch/afio
+ sys-block/buffer
+ sys-devel/binutils
+ >=app-arch/bzip2-0.9
+ app-cdr/cdrtools
+ >=app-backup/mindi-1.0.9
+ >=sys-boot/syslinux-1.52
+ ${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ elibtoolize
+ econf
+ emake VERSION=2.0.9 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ exeinto /usr/share/mondo
+ doexe mondo/autorun
+}
+
+pkg_postinst() {
+ einfo "${P} was successfully installed."
+ einfo "Please read the associated docs for help."
+ einfo "Or visit the website @ ${HOMEPAGE}"
+ echo
+ ewarn "This package is a new version after a long gap."
+ ewarn "Please report bugs to http://bugs.gentoo.org/"
+ ewarn "However, please do an advanced query to search for bugs"
+ ewarn "before reporting. This will keep down on duplicates."
+ echo
+ einfo "Prior to running mondo, ensure /boot is mounted."
+ ewarn "Grub users need to have a symlink like this:"
+ ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
+ einfo "Unless you want to have mondo backup your distfiles,"
+ einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
+ echo
+}