summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-16 14:59:26 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-16 14:59:26 +0000
commit31a66d96fbe73aa52d85fac5d6bc7dcb44723f4a (patch)
tree3e0b908f2b993a38b93a612d42bbe6490671b3a2 /dev-lang/python/files/patches/2.4.1-st_flags.patch
parentupdate manifest (diff)
downloadliquidx-31a66d96fbe73aa52d85fac5d6bc7dcb44723f4a.tar.gz
liquidx-31a66d96fbe73aa52d85fac5d6bc7dcb44723f4a.tar.bz2
liquidx-31a66d96fbe73aa52d85fac5d6bc7dcb44723f4a.zip
experimental python 2.4.3 ebuild to completely support multilib rather than a half supported version.
svn path=/; revision=59
Diffstat (limited to 'dev-lang/python/files/patches/2.4.1-st_flags.patch')
-rw-r--r--dev-lang/python/files/patches/2.4.1-st_flags.patch185
1 files changed, 185 insertions, 0 deletions
diff --git a/dev-lang/python/files/patches/2.4.1-st_flags.patch b/dev-lang/python/files/patches/2.4.1-st_flags.patch
new file mode 100644
index 0000000..a042bd2
--- /dev/null
+++ b/dev-lang/python/files/patches/2.4.1-st_flags.patch
@@ -0,0 +1,185 @@
+Only in Python-2.4.1-st_flags/: autom4te.cache
+diff -ur Python-2.4.1/configure Python-2.4.1-st_flags/configure
+--- Python-2.4.1/configure 2005-03-29 01:23:02.000000000 +0200
++++ Python-2.4.1-st_flags/configure 2005-06-19 01:26:10.485461096 +0200
+@@ -16411,6 +16411,116 @@
+
+ fi
+
++echo "$as_me:$LINENO: checking for struct stat.st_flags" >&5
++echo $ECHO_N "checking for struct stat.st_flags... $ECHO_C" >&6
++if test "${ac_cv_member_struct_stat_st_flags+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++int
++main ()
++{
++static struct stat ac_aggr;
++if (ac_aggr.st_flags)
++return 0;
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_member_struct_stat_st_flags=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++$ac_includes_default
++int
++main ()
++{
++static struct stat ac_aggr;
++if (sizeof ac_aggr.st_flags)
++return 0;
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_member_struct_stat_st_flags=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_member_struct_stat_st_flags=no
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++fi
++echo "$as_me:$LINENO: result: $ac_cv_member_struct_stat_st_flags" >&5
++echo "${ECHO_T}$ac_cv_member_struct_stat_st_flags" >&6
++if test $ac_cv_member_struct_stat_st_flags = yes; then
++
++cat >>confdefs.h <<_ACEOF
++#define HAVE_STRUCT_STAT_ST_FLAGS 1
++_ACEOF
++
++
++fi
++
+ echo "$as_me:$LINENO: checking for struct stat.st_blocks" >&5
+ echo $ECHO_N "checking for struct stat.st_blocks... $ECHO_C" >&6
+ if test "${ac_cv_member_struct_stat_st_blocks+set}" = set; then
+diff -ur Python-2.4.1/configure.in Python-2.4.1-st_flags/configure.in
+--- Python-2.4.1/configure.in 2005-03-29 01:23:34.000000000 +0200
++++ Python-2.4.1-st_flags/configure.in 2005-06-19 01:25:34.050000128 +0200
+@@ -2421,6 +2421,7 @@
+ AC_STRUCT_TIMEZONE
+ AC_CHECK_MEMBERS([struct stat.st_rdev])
+ AC_CHECK_MEMBERS([struct stat.st_blksize])
++AC_CHECK_MEMBERS([struct stat.st_flags])
+ AC_STRUCT_ST_BLOCKS
+
+ AC_MSG_CHECKING(for time.h that defines altzone)
+Only in Python-2.4.1-st_flags/: configure.in.orig
+diff -ur Python-2.4.1/Modules/posixmodule.c Python-2.4.1-st_flags/Modules/posixmodule.c
+--- Python-2.4.1/Modules/posixmodule.c 2005-03-13 23:18:26.000000000 +0100
++++ Python-2.4.1-st_flags/Modules/posixmodule.c 2005-06-19 01:25:34.048000432 +0200
+@@ -703,6 +703,9 @@
+ #ifdef HAVE_STRUCT_STAT_ST_RDEV
+ {"st_rdev", "device type (if inode device)"},
+ #endif
++#ifdef HAVE_STRUCT_STAT_ST_FLAGS
++ {"st_flags", "flags set onf ile"},
++#endif
+ {0}
+ };
+
+@@ -724,6 +727,12 @@
+ #define ST_RDEV_IDX ST_BLOCKS_IDX
+ #endif
+
++#ifdef HAVE_STRUCT_STAT_ST_FLAGS
++#define ST_FLAGS_IDX (ST_RDEV_IDX+1)
++#else
++#define ST_FLAGS_IDX ST_RDEV_IDX
++#endif
++
+ static PyStructSequence_Desc stat_result_desc = {
+ "stat_result", /* name */
+ stat_result__doc__, /* doc */
+@@ -887,6 +896,10 @@
+ PyStructSequence_SET_ITEM(v, ST_RDEV_IDX,
+ PyInt_FromLong((long)st.st_rdev));
+ #endif
++#ifdef HAVE_STRUCT_STAT_ST_FLAGS
++ PyStructSequence_SET_ITEM(v, ST_FLAGS_IDX,
++ PyInt_FromLong((long)st.st_flags));
++#endif
+
+ if (PyErr_Occurred()) {
+ Py_DECREF(v);
+Only in Python-2.4.1-st_flags/Modules: posixmodule.c.orig
+diff -ur Python-2.4.1/pyconfig.h.in Python-2.4.1-st_flags/pyconfig.h.in
+--- Python-2.4.1/pyconfig.h.in 2004-10-13 17:30:55.000000000 +0200
++++ Python-2.4.1-st_flags/pyconfig.h.in 2005-06-19 01:26:10.971387224 +0200
+@@ -480,6 +480,9 @@
+ /* Define to 1 if `st_blocks' is member of `struct stat'. */
+ #undef HAVE_STRUCT_STAT_ST_BLOCKS
+
++/* Define to 1 if `st_flags' is member of `struct stat'. */
++#undef HAVE_STRUCT_STAT_ST_FLAGS
++
+ /* Define to 1 if `st_rdev' is member of `struct stat'. */
+ #undef HAVE_STRUCT_STAT_ST_RDEV
+
+Only in Python-2.4.1-st_flags/: pyconfig.h.in~