summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/amara/Manifest2
-rw-r--r--dev-python/amara/amara-1.0_beta2.ebuild30
-rw-r--r--dev-python/amara/files/digest-amara-1.0_beta21
-rw-r--r--dev-python/flup/Manifest4
-rw-r--r--dev-python/flup/files/digest-flup-0.18271
-rw-r--r--dev-python/flup/files/digest-flup-0.18371
-rw-r--r--dev-python/flup/flup-0.1827.ebuild20
-rw-r--r--dev-python/flup/flup-0.1837.ebuild20
-rw-r--r--dev-python/json-py/Manifest2
-rw-r--r--dev-python/json-py/files/digest-json-py-3.41
-rw-r--r--dev-python/json-py/json-py-3.4.ebuild32
-rw-r--r--dev-python/openglcontext/Manifest2
-rw-r--r--dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc11
-rw-r--r--dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild26
-rw-r--r--dev-python/pyrxp/Manifest2
-rw-r--r--dev-python/pyrxp/files/digest-pyrxp-1.05_pre200504271
-rw-r--r--dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild28
-rw-r--r--dev-python/python-eclass-test/python-eclass-test-0.1.ebuild39
-rw-r--r--dev-python/python-mcrypt/Manifest2
-rw-r--r--dev-python/python-mcrypt/files/digest-python-mcrypt-1.11
-rw-r--r--dev-python/python-mcrypt/python-mcrypt-1.1.ebuild18
-rw-r--r--media-gfx/png2ico/Manifest2
-rw-r--r--media-gfx/png2ico/files/digest-png2ico-2002.12.081
-rw-r--r--media-gfx/png2ico/png2ico-2002.12.08.ebuild28
-rw-r--r--media-libs/libiptcdata/Manifest2
-rw-r--r--media-libs/libiptcdata/files/digest-libiptcdata-0.2.11
-rw-r--r--media-libs/libiptcdata/libiptcdata-0.2.1.ebuild33
-rw-r--r--media-video/pyvnc2swf/Manifest9
-rw-r--r--media-video/pyvnc2swf/files/digest-pyvnc2swf-0.8.23
-rw-r--r--media-video/pyvnc2swf/files/pyvnc2swf-0.8.2-gentoo.patch49
-rw-r--r--media-video/pyvnc2swf/pyvnc2swf-0.8.2.ebuild58
31 files changed, 420 insertions, 0 deletions
diff --git a/dev-python/amara/Manifest b/dev-python/amara/Manifest
new file mode 100644
index 0000000..2e7244c
--- /dev/null
+++ b/dev-python/amara/Manifest
@@ -0,0 +1,2 @@
+MD5 31f5e549b81047b31196fe00a1f45566 amara-1.0_beta2.ebuild 657
+MD5 4cc5af71508d4506e229ca8680f9fb2c files/digest-amara-1.0_beta2 63
diff --git a/dev-python/amara/amara-1.0_beta2.ebuild b/dev-python/amara/amara-1.0_beta2.ebuild
new file mode 100644
index 0000000..a158f05
--- /dev/null
+++ b/dev-python/amara/amara-1.0_beta2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Bug: http://bugs.gentoo.org/show_bug.cgi?id=112117
+
+inherit distutils
+
+MY_P=${P/amara/Amara}
+MY_P=${MY_P/_beta/b}
+DESCRIPTION="A collection of Pythonic tools for XML data binding built on 4Suite"
+SRC_URI="http://uche.ogbuji.net/uche.ogbuji.net/tech/4Suite/amara/${MY_P}.tar.bz2"
+HOMEPAGE="http://uche.ogbuji.net/uche.ogbuji.net/tech/4Suite/amara/"
+
+DEPEND=">=dev-lang/python-2.3
+>=dev-python/4suite-1.0_alpha4"
+
+IUSE=""
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+
+PYTHON_MODNAME=Amara
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ doins -r demo test
+}
diff --git a/dev-python/amara/files/digest-amara-1.0_beta2 b/dev-python/amara/files/digest-amara-1.0_beta2
new file mode 100644
index 0000000..44e4c66
--- /dev/null
+++ b/dev-python/amara/files/digest-amara-1.0_beta2
@@ -0,0 +1 @@
+MD5 9f2794a8b37d6c41d35815876f59cb22 Amara-1.0b2.tar.bz2 70171
diff --git a/dev-python/flup/Manifest b/dev-python/flup/Manifest
new file mode 100644
index 0000000..ee9c708
--- /dev/null
+++ b/dev-python/flup/Manifest
@@ -0,0 +1,4 @@
+MD5 01cffd4ce0f367afcd19ebe6b0989882 files/digest-flup-0.1827 61
+MD5 69756f79ac54ab2f93889f36effd1b3f files/digest-flup-0.1837 61
+MD5 a96ada0b54b08511a9872be868004b54 flup-0.1827.ebuild 558
+MD5 a96ada0b54b08511a9872be868004b54 flup-0.1837.ebuild 558
diff --git a/dev-python/flup/files/digest-flup-0.1827 b/dev-python/flup/files/digest-flup-0.1827
new file mode 100644
index 0000000..e4b8a73
--- /dev/null
+++ b/dev-python/flup/files/digest-flup-0.1827
@@ -0,0 +1 @@
+MD5 37d310a7ce3f4ce715fee1a25fb6a83e flup-r1827.tar.gz 54886
diff --git a/dev-python/flup/files/digest-flup-0.1837 b/dev-python/flup/files/digest-flup-0.1837
new file mode 100644
index 0000000..b40bf19
--- /dev/null
+++ b/dev-python/flup/files/digest-flup-0.1837
@@ -0,0 +1 @@
+MD5 860edb0068a66ba067700bd4632536dd flup-r1837.tar.gz 55358
diff --git a/dev-python/flup/flup-0.1827.ebuild b/dev-python/flup/flup-0.1827.ebuild
new file mode 100644
index 0000000..3b989bc
--- /dev/null
+++ b/dev-python/flup/flup-0.1827.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=100784
+
+inherit distutils
+
+REV=${PV/0./}
+DESCRIPTION="Python implementation of the WSGI and FastCGI interfaces"
+HOMEPAGE="http://www.saddi.com/software/flup/"
+SRC_URI="http://www.saddi.com/software/flup/dist/${PN}-r${REV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+S=${WORKDIR}/${PN}-r${REV}
diff --git a/dev-python/flup/flup-0.1837.ebuild b/dev-python/flup/flup-0.1837.ebuild
new file mode 100644
index 0000000..3b989bc
--- /dev/null
+++ b/dev-python/flup/flup-0.1837.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=100784
+
+inherit distutils
+
+REV=${PV/0./}
+DESCRIPTION="Python implementation of the WSGI and FastCGI interfaces"
+HOMEPAGE="http://www.saddi.com/software/flup/"
+SRC_URI="http://www.saddi.com/software/flup/dist/${PN}-r${REV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+S=${WORKDIR}/${PN}-r${REV}
diff --git a/dev-python/json-py/Manifest b/dev-python/json-py/Manifest
new file mode 100644
index 0000000..45d167a
--- /dev/null
+++ b/dev-python/json-py/Manifest
@@ -0,0 +1,2 @@
+MD5 8c26bb36f1d924b83efc72d872455aa9 files/digest-json-py-3.4 59
+MD5 ab13cdc8afb89057dd7d67fa3a2556c4 json-py-3.4.ebuild 506
diff --git a/dev-python/json-py/files/digest-json-py-3.4 b/dev-python/json-py/files/digest-json-py-3.4
new file mode 100644
index 0000000..fab7294
--- /dev/null
+++ b/dev-python/json-py/files/digest-json-py-3.4
@@ -0,0 +1 @@
+MD5 921ebfede886a10ff32d6d4b4e216f8f json-py-3_4.zip 20111
diff --git a/dev-python/json-py/json-py-3.4.ebuild b/dev-python/json-py/json-py-3.4.ebuild
new file mode 100644
index 0000000..1dada43
--- /dev/null
+++ b/dev-python/json-py/json-py-3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygoogle/pygoogle-0.6.ebuild,v 1.4 2005/07/02 16:48:16 fserb Exp $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=112451
+
+inherit eutils distutils
+
+MY_PV=${PV/./_}
+DESCRIPTION="JSON reader/writer for python."
+SRC_URI="mirror://sourceforge/json-py/${PN}-${MY_PV}.zip"
+HOMEPAGE="http://sourceforge.net/projects/json-py/"
+
+IUSE=""
+SLOT="0"
+LICENSE="PYTHON"
+KEYWORDS="~x86 ~ppc-macos ~amd64"
+
+DEPEND="virtual/python"
+S=${WORKDIR}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ cd ${S}
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins json.py minjson.py
+ dodoc changes.txt license.txt readme.txt
+}
diff --git a/dev-python/openglcontext/Manifest b/dev-python/openglcontext/Manifest
new file mode 100644
index 0000000..485be64
--- /dev/null
+++ b/dev-python/openglcontext/Manifest
@@ -0,0 +1,2 @@
+MD5 db21adddf1385bb935e66cbde1ae9f88 files/digest-openglcontext-2.0.0_rc1 73
+MD5 ed20880d67844abf5c7736b87b7632a3 openglcontext-2.0.0_rc1.ebuild 676
diff --git a/dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc1 b/dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc1
new file mode 100644
index 0000000..5b645ac
--- /dev/null
+++ b/dev-python/openglcontext/files/digest-openglcontext-2.0.0_rc1
@@ -0,0 +1 @@
+MD5 1ba3b69100bbdb4f754ec10169c8074c OpenGLContext-2.0.0c1.tar.gz 864024
diff --git a/dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild b/dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild
new file mode 100644
index 0000000..76d29c6
--- /dev/null
+++ b/dev-python/openglcontext/openglcontext-2.0.0_rc1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+MY_PN="OpenGLContext"
+MY_PV="2.0.0c1" # change when version has an a1 or similar extension
+
+DESCRIPTION="Testing and demonstration contexts for PyOpenGL"
+HOMEPAGE="http://pyopengl.sourceforge.net/context/"
+SRC_URI="mirror://sourceforge/pyopengl/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+RDEPEND="virtual/python
+ dev-python/ttfquery
+ dev-python/imaging
+ dev-python/numeric
+ dev-python/pydispatcher
+ >=dev-python/pyopengl-2.0.1.09"
+DEPEND="virtual/python"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
diff --git a/dev-python/pyrxp/Manifest b/dev-python/pyrxp/Manifest
new file mode 100644
index 0000000..a8bc210
--- /dev/null
+++ b/dev-python/pyrxp/Manifest
@@ -0,0 +1,2 @@
+MD5 07d154a8050718ec9d4cf03ed2451840 pyrxp-1.05_pre20050427.ebuild 625
+MD5 de43569a8a2c2abc0c2f6aad8131d555 files/digest-pyrxp-1.05_pre20050427 71
diff --git a/dev-python/pyrxp/files/digest-pyrxp-1.05_pre20050427 b/dev-python/pyrxp/files/digest-pyrxp-1.05_pre20050427
new file mode 100644
index 0000000..b025404
--- /dev/null
+++ b/dev-python/pyrxp/files/digest-pyrxp-1.05_pre20050427
@@ -0,0 +1 @@
+MD5 9280d7eb5b0bd7b8e288409619768cf6 pyrxp-1.05_pre20050427.tgz 354883
diff --git a/dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild b/dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild
new file mode 100644
index 0000000..f89b38a
--- /dev/null
+++ b/dev-python/pyrxp/pyrxp-1.05_pre20050427.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# http://bugs.gentoo.org/show_bug.cgi?id=39457
+
+inherit distutils
+
+DESCRIPTION="Python wrapper around RXP, a very fast validating XML parser"
+SRC_URI="http://dev.gentoo.org/~liquidx/snapshots/${P}.tgz"
+HOMEPAGE="http://www.reportlab.org/pyrxp.html"
+
+DEPEND="virtual/python"
+IUSE=""
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/pyRXP-${PV/_pre/-}/pyRXP
+
+src_install() {
+ distutils_src_install
+
+ dodoc docs/* README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ doins -r test
+}
diff --git a/dev-python/python-eclass-test/python-eclass-test-0.1.ebuild b/dev-python/python-eclass-test/python-eclass-test-0.1.ebuild
new file mode 100644
index 0000000..602d2af
--- /dev/null
+++ b/dev-python/python-eclass-test/python-eclass-test-0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+inherit python
+
+DESCRIPTION="Dummy Ebuild to test python"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+pkg_setup() {
+ einfo "Testing python_extract_version():"
+ __python_eclass_test
+
+ python_version
+ einfo "I think the current version of python is: ${PYVER}"
+
+ python_disable_pyc
+ if [ "x$PYTHON_DONTCOMPILE" = "x1" ]; then
+ einfo "Disabling pyc generation works!"
+ else
+ eerror "Disabling pyc generation doesn't work!"
+ fi
+
+ python_enable_pyc
+ if [ "x$PYTHON_DONTCOMPILE" = "x" ]; then
+ einfo "Enabling pyc generation works!"
+ else
+ eerror "Enabling pyc generation doesn't work!"
+ fi
+}
+
+
+
diff --git a/dev-python/python-mcrypt/Manifest b/dev-python/python-mcrypt/Manifest
new file mode 100644
index 0000000..dcf1dc3
--- /dev/null
+++ b/dev-python/python-mcrypt/Manifest
@@ -0,0 +1,2 @@
+MD5 95e5aedc6c5f824743dad08a0d8495b7 python-mcrypt-1.1.ebuild 582
+MD5 c59d000af863e84869b40f5864298e9f files/digest-python-mcrypt-1.1 68
diff --git a/dev-python/python-mcrypt/files/digest-python-mcrypt-1.1 b/dev-python/python-mcrypt/files/digest-python-mcrypt-1.1
new file mode 100644
index 0000000..b2279e3
--- /dev/null
+++ b/dev-python/python-mcrypt/files/digest-python-mcrypt-1.1
@@ -0,0 +1 @@
+MD5 0e9f7cc17545af6b51188b38984fe034 python-mcrypt-1.1.tar.gz 22708
diff --git a/dev-python/python-mcrypt/python-mcrypt-1.1.ebuild b/dev-python/python-mcrypt/python-mcrypt-1.1.ebuild
new file mode 100644
index 0000000..b1e5c91
--- /dev/null
+++ b/dev-python/python-mcrypt/python-mcrypt-1.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cjkcodecs/cjkcodecs-1.1.1.ebuild,v 1.4 2005/03/04 21:31:57 kito Exp $
+
+inherit distutils
+
+DESCRIPTION="Python interface to the mcrypt library, which provides a uniform interface to several symmetric encryption algorithms."
+HOMEPAGE="http://sourceforge.net/projects/python-mcrypt/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+dev-libs/libmcrypt"
+
diff --git a/media-gfx/png2ico/Manifest b/media-gfx/png2ico/Manifest
new file mode 100644
index 0000000..253f8a2
--- /dev/null
+++ b/media-gfx/png2ico/Manifest
@@ -0,0 +1,2 @@
+MD5 1fb8202fce7be09ca8e399122f04ea80 png2ico-2002.12.08.ebuild 658
+MD5 783a34518bd90abe9f9f20c19315e4c5 files/digest-png2ico-2002.12.08 73
diff --git a/media-gfx/png2ico/files/digest-png2ico-2002.12.08 b/media-gfx/png2ico/files/digest-png2ico-2002.12.08
new file mode 100644
index 0000000..d23c709
--- /dev/null
+++ b/media-gfx/png2ico/files/digest-png2ico-2002.12.08
@@ -0,0 +1 @@
+MD5 9b663df81c826cd564638cba2e6bc75b png2ico-src-2002-12-08.tar.gz 26527
diff --git a/media-gfx/png2ico/png2ico-2002.12.08.ebuild b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
new file mode 100644
index 0000000..b32b1ed
--- /dev/null
+++ b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtoico/pngtoico-1.0.ebuild,v 1.7 2005/04/09 17:36:34 blubb Exp $
+
+inherit eutils
+
+MY_PV=2002-12-08
+DESCRIPTION="PNG to Icon Convertor"
+HOMEPAGE="http://www.winterdrache.de/freeware/png2ico/"
+SRC_URI="http://www.winterdrache.de/freeware/png2ico/data/${PN}-src-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin png2ico
+ dodoc doc/png2ico.txt README README.unix
+ doman doc/png2ico.1
+}
diff --git a/media-libs/libiptcdata/Manifest b/media-libs/libiptcdata/Manifest
new file mode 100644
index 0000000..1425f8a
--- /dev/null
+++ b/media-libs/libiptcdata/Manifest
@@ -0,0 +1,2 @@
+MD5 e3f22aef02516ffd267050c5508bd748 files/digest-libiptcdata-0.2.1 69
+MD5 b8a6fb892a3e1e0354693885857d8cae libiptcdata-0.2.1.ebuild 793
diff --git a/media-libs/libiptcdata/files/digest-libiptcdata-0.2.1 b/media-libs/libiptcdata/files/digest-libiptcdata-0.2.1
new file mode 100644
index 0000000..4245d5d
--- /dev/null
+++ b/media-libs/libiptcdata/files/digest-libiptcdata-0.2.1
@@ -0,0 +1 @@
+MD5 2df9620f8c08aba4ccbe434032ff320d libiptcdata-0.2.1.tar.gz 471976
diff --git a/media-libs/libiptcdata/libiptcdata-0.2.1.ebuild b/media-libs/libiptcdata/libiptcdata-0.2.1.ebuild
new file mode 100644
index 0000000..c5a478a
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.12-r4.ebuild,v 1.8 2006/01/07 11:43:17 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="Library for parsing, editing, and saving IPTC data in JPEG/TIFF."
+HOMEPAGE="http://libiptcdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ # Keep around old lib
+ # preserve_old_lib /usr/$(get_libdir)/libexif.so.9
+}
+
+#pkg_postinst() {
+# preserve_old_lib_notify /usr/$(get_libdir)/libexif.so.9
+#}
diff --git a/media-video/pyvnc2swf/Manifest b/media-video/pyvnc2swf/Manifest
new file mode 100644
index 0000000..748a350
--- /dev/null
+++ b/media-video/pyvnc2swf/Manifest
@@ -0,0 +1,9 @@
+MD5 ddfe58165dcc1620736fc389d0999655 files/digest-pyvnc2swf-0.8.2 244
+RMD160 f20b83410e858d8284a28d194242effdb3002b97 files/digest-pyvnc2swf-0.8.2 244
+SHA256 54bf665f3a52ba4b7eca615db22afbd35a747a12c1d8dbd93c3e36c78b57cee5 files/digest-pyvnc2swf-0.8.2 244
+MD5 d0a66694aae204eea479d517b71976c5 files/pyvnc2swf-0.8.2-gentoo.patch 2008
+RMD160 3bb1596482c1106b9d3c9dba0fc9b646c5e4c19a files/pyvnc2swf-0.8.2-gentoo.patch 2008
+SHA256 3214d1e9a90321f5dc87da4a60428a7b9a601c14ef5bdcd291ffbb49c950b308 files/pyvnc2swf-0.8.2-gentoo.patch 2008
+MD5 6520db2a82afa982541d2d07c9b5663d pyvnc2swf-0.8.2.ebuild 1443
+RMD160 0989b570645cced7d4a90bc8e410c53b91d8fe29 pyvnc2swf-0.8.2.ebuild 1443
+SHA256 7a0e1f7d63ca18e7c407fbbac076836154569c3ac674148a7124991f005d6c7e pyvnc2swf-0.8.2.ebuild 1443
diff --git a/media-video/pyvnc2swf/files/digest-pyvnc2swf-0.8.2 b/media-video/pyvnc2swf/files/digest-pyvnc2swf-0.8.2
new file mode 100644
index 0000000..d7fb476
--- /dev/null
+++ b/media-video/pyvnc2swf/files/digest-pyvnc2swf-0.8.2
@@ -0,0 +1,3 @@
+MD5 6453d2a155a04b1ad7ce4f672c3ff837 pyvnc2swf-0.8.2.tar.gz 59078
+RMD160 ccb0c93bd0ed3d0feff401cb98da4eec36381bbc pyvnc2swf-0.8.2.tar.gz 59078
+SHA256 655f6880aee736e88b7ee12bff09f0e87fcba5fcb473a781a315c89ab0e07672 pyvnc2swf-0.8.2.tar.gz 59078
diff --git a/media-video/pyvnc2swf/files/pyvnc2swf-0.8.2-gentoo.patch b/media-video/pyvnc2swf/files/pyvnc2swf-0.8.2-gentoo.patch
new file mode 100644
index 0000000..db1e34e
--- /dev/null
+++ b/media-video/pyvnc2swf/files/pyvnc2swf-0.8.2-gentoo.patch
@@ -0,0 +1,49 @@
+diff -urN pyvnc2swf-0.8.2-orig/edit.py pyvnc2swf-0.8.2/edit.py
+--- pyvnc2swf-0.8.2-orig/edit.py 2005-11-27 01:56:23.000000000 +0100
++++ pyvnc2swf-0.8.2/edit.py 2005-12-31 17:55:20.000000000 +0100
+@@ -24,6 +24,8 @@
+ ##
+
+ import sys, re
++# We want the auxiliary Python files in /usr/lib/pyvnc2swf.
++sys.path.insert(0, "/usr/lib/pyvnc2swf")
+ from movie import SWFInfo, MovieContainer
+ from output import MPEGVideoStream, SWFVideoStream, SWFShapeStream, ImageSequenceStream, MovieBuilder
+ stderr = sys.stderr
+diff -urN pyvnc2swf-0.8.2-orig/play.py pyvnc2swf-0.8.2/play.py
+--- pyvnc2swf-0.8.2-orig/play.py 2005-11-23 07:15:45.000000000 +0100
++++ pyvnc2swf-0.8.2/play.py 2005-12-31 17:55:26.000000000 +0100
+@@ -25,6 +25,8 @@
+
+ import sys, os.path
+ import pygame
++# We want the auxiliary Python files in /usr/lib/pyvnc2swf.
++sys.path.insert(0, "/usr/lib/pyvnc2swf")
+ from movie import SWFInfo, MovieContainer
+ from output import SWFScreen, MovieOutputStream, MovieBuilder
+ lowerbound = max
+diff -urN pyvnc2swf-0.8.2-orig/recordwin.sh pyvnc2swf-0.8.2/recordwin.sh
+--- pyvnc2swf-0.8.2-orig/recordwin.sh 2005-11-11 05:58:33.000000000 +0100
++++ pyvnc2swf-0.8.2/recordwin.sh 2005-12-31 17:56:47.000000000 +0100
+@@ -9,7 +9,7 @@
+ ## recordwin.sh [-display disp] [-name winname] [-id winid] output.swf
+ ##
+
+-VNC2SWF="python vnc2swf.py"
++VNC2SWF="vnc2swf.py"
+ X11VNC=x11vnc
+ XWININFO=xwininfo
+ AWK=awk
+diff -urN pyvnc2swf-0.8.2-orig/vnc2swf.py pyvnc2swf-0.8.2/vnc2swf.py
+--- pyvnc2swf-0.8.2-orig/vnc2swf.py 2005-11-27 00:58:40.000000000 +0100
++++ pyvnc2swf-0.8.2/vnc2swf.py 2005-12-31 17:57:03.000000000 +0100
+@@ -27,7 +27,8 @@
+ import Tkinter, tkFileDialog, tkMessageBox
+ from tkSimpleDialog import Dialog
+ from struct import pack, unpack
+-
++# We want the auxiliary Python files in /usr/lib/pyvnc2swf.
++sys.path.insert(0, "/usr/lib/pyvnc2swf")
+ from movie import SWFInfo
+ from output import SWFShapeStream, SWFVideoStream
+ from rfb import RFBError, RFBNetworkClient, RFBNetworkClientForRecording, RFBStreamConverter
diff --git a/media-video/pyvnc2swf/pyvnc2swf-0.8.2.ebuild b/media-video/pyvnc2swf/pyvnc2swf-0.8.2.ebuild
new file mode 100644
index 0000000..9c7de56
--- /dev/null
+++ b/media-video/pyvnc2swf/pyvnc2swf-0.8.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# From: http://bugs.gentoo.org/show_bug.cgi?id=117291
+
+inherit eutils python
+
+DESCRIPTION="A tool for recording Flash SWF movies from VNC sessions."
+HOMEPAGE="http://www.unixuser.org/~euske/vnc2swf/pyvnc2swf.html"
+SRC_URI="http://www.unixuser.org/~euske/vnc2swf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="x11vnc"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pygame-1.6
+ x11vnc? ( x11-misc/x11vnc )"
+
+#pkg_setup() {
+# python_tkinter_exists || die "TCL/TK required. Python must be compiled with the tcltk USE flag."
+#}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Add /usr/lib/pyvnc2swf to the path so that the auxiliary Python files
+ # are found.
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ for file in $(echo crippled_des.py html_templates.py image.py movie.py\
+ mp3.py output.py rfb.py swf.py crippled_des.py html_templates.py\
+ image.py movie.py mp3.py output.py rfb.py swf.py)
+ do
+ einfo Compiling $file.
+ python_mod_compile $file
+ done
+}
+
+src_install() {
+ insinto /usr/lib/pyvnc2swf
+ doins crippled_des.py* image.py* mp3.py* rfb.py* html_templates.py*
+ doins movie.py* output.py* swf.py*
+ newbin edit.py pyvnc2swf-edit
+ newbin play.py pyvnc2swf-play
+ newbin vnc2swf.py pyvnc2swf
+ if use x11vnc;
+ then
+ # Only install the recordwin script if x11vnc is to be used.
+ newbin recordwin.sh pyvnc2swf-recordwin
+ fi
+ dodoc README.txt
+ dohtml *.html
+}