summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/bluez-utils/bluez-utils-3.7.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/net-wireless/bluez-utils/bluez-utils-3.7.ebuild b/net-wireless/bluez-utils/bluez-utils-3.7.ebuild
index 1bc2e37..bf18b1c 100644
--- a/net-wireless/bluez-utils/bluez-utils-3.7.ebuild
+++ b/net-wireless/bluez-utils/bluez-utils-3.7.ebuild
@@ -31,19 +31,28 @@ DEPEND="sys-devel/bison
pkg_setup() {
ewarn "bluez-utils-3.x uses a new DBUS Passkey API to do PIN"
- ewarn "authentication, and none of the GUI input mechanisms are"
- ewarn "available yet. To perform pin authentication, you must"
- ewarn "run a fake passkey-agent like this:"
+ ewarn "authentication. The new GNOME Applet that handles PIN"
+ ewarn "entry is now in 'net-wireless/bluez-gnome'. This will"
+ ewarn "installed to be launched on login."
+ ewarn ""
+ ewarn "If you would like to do PIN authentication without a"
+ ewarn "GUI, you can run this DBUS agent to provide a default"
+ ewarn "pin as hcid now ignores it's own configuration file."
ewarn ""
ewarn "/usr/bin/passkey-agent --default <pin number>"
ewarn ""
ewarn "bluez-utils-3.x may ignore pscan/iscan configure options in"
- ewarn "hciconfig. Instead, you must enable it using hciconfig"
+ ewarn "hciconfig. Instead, you must use DBUS to re-enable the older"
+ ewarn "insecure behaviour:"
+ ewarn ""
+ ewarn "dbus-send --system --type=method-call --print-reply \\"
+ ewarn "--dest=org.bluez \\"
+ ewarn " /org/bluez/hci0 org.bluez.Adapter.SetDiscoverableTimeout uint32:0"
ewarn ""
- ewarn "hciconfig hci0 piscan"
+ ewarn "dbus-send --system --type=method-call --print-reply \\"
+ ewarn "--dest=org.bluez \\"
+ ewarn " /org/bluez/hci0 org.bluez.Adapter.SetMode string:discoverable"
ewarn ""
- ewarn "This should be temporary until proper DBUS support is in"
- ewarn "kdebluetooth or gnome-bluetooth."
}
src_unpack() {