summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-17 00:36:54 +0200
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-17 00:36:54 +0200
commit0778d1702751427580d7a90124dffb6de09765c0 (patch)
tree0cf102d638c034ba70a9d1578ad3dce55860a0e6
parentClaws mail plugins. (diff)
downloadloki_val-0778d1702751427580d7a90124dffb6de09765c0.tar.gz
loki_val-0778d1702751427580d7a90124dffb6de09765c0.tar.bz2
loki_val-0778d1702751427580d7a90124dffb6de09765c0.zip
poppler-python added
-rw-r--r--dev-python/python-poppler/Manifest2
-rw-r--r--dev-python/python-poppler/python-poppler-0.10.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-poppler/Manifest b/dev-python/python-poppler/Manifest
new file mode 100644
index 0000000..7ac2d7c
--- /dev/null
+++ b/dev-python/python-poppler/Manifest
@@ -0,0 +1,2 @@
+DIST pypoppler-0.10.0.tar.gz 292043 RMD160 f7a2616d84dc5438559775a1c5b3338149aafd9f SHA1 a442c3f06ce5d23e78658c6ba0962cfb8b0539e3 SHA256 1c09814a457375da607aa400cd8774b98c016c760ea513e3a22357cf4fca63b1
+EBUILD python-poppler-0.10.0.ebuild 821 RMD160 8621a33abe544bfa4a264f9d783be58af249f87a SHA1 03226f8bfb3ff1b5136069c9f29dd82ad0eaf05c SHA256 2a08ed10d97c9d3086d15e00f19f94278e4c734d3e31fd722bb4e456f470e056
diff --git a/dev-python/python-poppler/python-poppler-0.10.0.ebuild b/dev-python/python-poppler/python-poppler-0.10.0.ebuild
new file mode 100644
index 0000000..879ce53
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit libtool
+
+EAPI=2
+
+DESCRIPTION="Python bindings to the Poppler PDF library."
+SRC_URI="http://www.gnome.org/~gianmt/pypoppler-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/poppler-python"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/pypoppler-${PV}"
+
+# Dependency for PyGObbject is 2.11.3 if building docs,
+# but this ebuild doesn't provide a USE flag for docs yet.
+DEPEND=">=dev-libs/poppler-glib-0.10.0
+ >=dev-python/pygobject-2.11.3
+ >=dev-python/pygtk-2.10.0
+ >=dev-python/pycairo-1.2.0"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -type f -exec rm -f '{}' ';' || die "Removing .la files failed"
+}
+