summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-12-15 20:05:07 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-12-15 20:05:07 +0000
commit0ec56ddaf770891c066e04f56ce2fc85297c404e (patch)
treed93d22b1e6a272af14f9faabc903649a142e8678 /sys-libs/libspe2/libspe2-2.0.1.ebuild
parentps3 misc utilities (diff)
downloadlu_zero-0ec56ddaf770891c066e04f56ce2fc85297c404e.tar.gz
lu_zero-0ec56ddaf770891c066e04f56ce2fc85297c404e.tar.bz2
lu_zero-0ec56ddaf770891c066e04f56ce2fc85297c404e.zip
Tentative ebuild
svn path=/; revision=65
Diffstat (limited to 'sys-libs/libspe2/libspe2-2.0.1.ebuild')
-rw-r--r--sys-libs/libspe2/libspe2-2.0.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-libs/libspe2/libspe2-2.0.1.ebuild b/sys-libs/libspe2/libspe2-2.0.1.ebuild
new file mode 100644
index 0000000..b0ce544
--- /dev/null
+++ b/sys-libs/libspe2/libspe2-2.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
+HOMEPAGE="http://ozlabs.org/pipermail/cbe-oss-dev/"
+SRC_URI="http://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ SYSROOT=""
+else
+ SYSROOT="/usr/${CTARGET}"
+fi
+
+src_unpack () {
+ unpack ${A}
+ #just in case something is missing
+}
+
+src_compile() {
+ myconf=""
+ use debug && myconf="${myconf} DEBUG=1"
+ make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" ${myconf}
+}
+
+src_install() {
+ make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" \
+ DESTDIR="$D" install
+ cp ${FILESDIR}/spe.rc6 ${T}/elfspe
+ doinitd ${T}/elfspe
+}
+
+
+pkg_postinst() {
+ einfo "You may want to register elfspe to binfmt using the"
+ einfo "provided initscript"
+ einfo "# rc-update add elfspe boot"
+}