summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libspe/libspe-1.1.0.ebuild')
-rw-r--r--sys-libs/libspe/libspe-1.1.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-libs/libspe/libspe-1.1.0.ebuild b/sys-libs/libspe/libspe-1.1.0.ebuild
new file mode 100644
index 0000000..e553346
--- /dev/null
+++ b/sys-libs/libspe/libspe-1.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
+HOMEPAGE="http://www.bsc.es/projects/deepcomputing/linuxoncell/stable/libspe.html"
+SRC_URI="http://www.bsc.es/projects/deepcomputing/linuxoncell/stable/libspe/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ SYSROOT=""
+else
+ SYSROOT="${CTARGET}"
+fi
+
+src_unpack () {
+ unpack ${A}
+ #just in case something is missing
+}
+
+src_compile() {
+ myconf=""
+ use debug && myconf="${myconf} DEBUG=1"
+ make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" ${myconf}
+}
+
+src_install() {
+ make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" \
+ DESTDIR="$D" install
+ cp ${FILESDIR}/spe.rc6 ${T}/elfspe
+ doinitd ${T}/elfspe
+}
+
+
+pkg_postinst() {
+ einfo "You may want to register elfspe to binfmt using the"
+ einfo "provided initscript"
+ einfo "# rcupdate add elfspe boot"
+}