summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-99999999.ebuild')
-rw-r--r--app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-99999999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-99999999.ebuild b/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-99999999.ebuild
new file mode 100644
index 0000000..03ffe90
--- /dev/null
+++ b/app-laptop/lenovo-sl-laptop/lenovo-sl-laptop-99999999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit linux-info linux-mod eutils git
+
+DESCRIPTION="Driver for Lenovo ThinkPad SL laptops."
+HOMEPAGE="http://github.com/tetromino/lenovo-sl-laptop/tree/master"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://github.com/tetromino/lenovo-sl-laptop"
+
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="HWMON BACKLIGHT_CLASS_DEVICE"
+
+MODULE_NAMES="${PN}(acpi)"
+BUILD_TARGETS="module"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}