summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_npy/mod_npy-0.3.3.ebuild')
-rw-r--r--www-apache/mod_npy/mod_npy-0.3.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-apache/mod_npy/mod_npy-0.3.3.ebuild b/www-apache/mod_npy/mod_npy-0.3.3.ebuild
new file mode 100644
index 0000000..7c83865
--- /dev/null
+++ b/www-apache/mod_npy/mod_npy-0.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit apache-module
+
+DESCRIPTION="Alternative way of using Python for dynamic web content."
+HOMEPAGE="http://mod-npy.sourceforge.net/"
+LICENSE="ZLIB"
+SRC_URI="mirror://sourceforge/mod-npy/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="profile"
+SLOT="0"
+
+# See apache-module.eclass for more information.
+# APACHE2_MOD_CONF=""
+# APACHE2_MOD_DEFINE=""
+
+need_apache2
+
+src_compile() {
+
+ local myconf=
+ use profile && myconf="${myconf} --enable-profile"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ apache2_src_install
+
+ insinto ${APACHE2_MODULES_CONFDIR}
+ doins "${S}/conf/99_mod_npy.conf"
+
+ dodoc "${S}/ChangeLog"
+
+}