summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-28 07:36:15 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-28 07:36:15 +0000
commitd29f7af46118d1582080d321f57f85bf55fdaa51 (patch)
treef25b21e30ae156d997e70afbeb1743b4829f0911
parentVarious ebuild cleanup. (diff)
downloadomp-d29f7af46118d1582080d321f57f85bf55fdaa51.tar.gz
omp-d29f7af46118d1582080d321f57f85bf55fdaa51.tar.bz2
omp-d29f7af46118d1582080d321f57f85bf55fdaa51.zip
Many various small changes and cleanup.
svn path=/; revision=15
-rw-r--r--x11-wm/fvwm/Manifest2
-rw-r--r--x11-wm/fvwm/fvwm-2.5.25.ebuild40
2 files changed, 18 insertions, 24 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index e21ddaf..59d6bc0 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -5,5 +5,5 @@ AUX fvwm-2.5.23-translucent-menus.diff 15765 RMD160 5629e1fcd6d41e7c9f5cfa0a6220
AUX fvwm-menu-xlock-xlockmore-compat.patch 550 RMD160 72af6f306e5869581fcd48c84edfe00adea4a5b9 SHA1 0eccf83c3046e3822737c5facb23f547a062bff8 SHA256 5db8bc279f618096b23fed04b70b626c6ff50c104283d5ece505200db1e5a8af
DIST fvwm-2.5.25.tar.bz2 2516717 RMD160 bf77786a071838304eb4bf8cc14960196c235506 SHA1 8e0f0b1eb888f7fcc27a0dbcc32a5b0f2895df2b SHA256 212dafb5fbace4a72d7a2d2dd6df7445709bad6739162a72879e4a6e942d69fc
DIST fvwm-patchset-20070901-r2.tar.bz2 37255 RMD160 787fe6f49e497a225648dbdd30b0636d3416a5b0 SHA1 9d56b1f2703feb52987e6aeb22dc151bc0e10d67 SHA256 9342142d216ca5b89c161a9796a08c4effc1b3d8dd41090e3419b051fac639fa
-EBUILD fvwm-2.5.25.ebuild 4795 RMD160 96877d07c5bf29e21ac9ddaf1fedec4f1dac2442 SHA1 2c2efc6c793f186b5708a78062dde74de280c7b6 SHA256 e50ef9a82545ef3eb122a1b3fcabb4bce6911a844fe1ddc813e7620eed1cb46e
+EBUILD fvwm-2.5.25.ebuild 4422 RMD160 d052e5cbc8e6de455d6dc7fde785d6ad0de42017 SHA1 6d93b42cc8d23dda028fc329e24bfd91778e198d SHA256 c1c0fb5601d2c5b6852e2da903eeb1eb680af59e3e10458d74303db00b393450
EBUILD fvwm-9999.ebuild 6985 RMD160 fadfaa9ca384911f2a5930991a494c7ea80754ca SHA1 60c6c84d287b3c6c4fa2249bc8b7e1c816f8d0f2 SHA256 b7a725d6bd63582a89cfde414263acdf9b2c1709180039fce96d2273176e63a2
diff --git a/x11-wm/fvwm/fvwm-2.5.25.ebuild b/x11-wm/fvwm/fvwm-2.5.25.ebuild
index a41216e..9b68653 100644
--- a/x11-wm/fvwm/fvwm-2.5.25.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.25.ebuild
@@ -71,20 +71,7 @@ src_unpack() {
}
src_compile() {
- local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs"
-
- use readline && myconf="${myconf} --without-termcap-library"
-
- # FvwmGtk can be built as a gnome application, or a Gtk+ application.
- if ! use gtk; then
- myconf="${myconf} --disable-gtk --without-gnome"
- else
- if ! use imlib; then
- einfo "ATTN: You can safely ignore any imlib related configure errors."
- myconf="${myconf} --with-imlib-prefix=${T}"
- fi
- myconf="${myconf} --without-gnome"
- fi
+ local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs --without-gnome"
# Non-upstream email where bugs should be sent; used in fvwm-bug.
export FVWM_BUGADDR="desktop-wm@gentoo.org"
@@ -95,6 +82,17 @@ src_compile() {
# Signed chars are required.
use ppc && append-flags -fsigned-char
+ if use gtk; then
+ if ! use imlib; then
+ einfo "ATTN: You can safely ignore any imlib related configure errors."
+ myconf="${myconf} --with-imlib-prefix=${T}"
+ fi
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+
+ use readline && myconf="${myconf} --without-termcap-library"
+
econf ${myconf} \
$(use_enable bidi) \
$(use_enable debug debug-msgs) \
@@ -119,29 +117,25 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
if use perl; then
-
local toolkits="gtk tcltk"
if ! use tk; then
- # Remove the Tk bindings (requires perl-tk)
rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Tk.pm"
toolkits=${toolkits/tcltk/}
fi
+
if ! use gtk; then
- # Remove gtk bindings (requires gtk-perl/gtk2-perl)
rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/"Gtk{,2}.pm
toolkits=${toolkits/gtk/}
fi
- toolkits=${toolkits// /}
- if ! test "${toolkits}"; then
- # No perl toolkit bindings wanted, remove the unneeded files
- # and empty directories.
+
+ if ! test "${toolkits// /}"; then
rm -f "${D}/usr/share/fvwm/perllib/FVWM/Module/Toolkit.pm"
find "${D}/usr/share/fvwm/perllib" -depth -type d -exec rmdir {} \; 2>/dev/null
fi
else
- # Remove useless script if perllib isnt required.
- rm -rf "${D}/usr/bin/fvwm-perllib" "${D}/usr/share/man/man1/fvwm-perllib.1"
+ rm -rf "${D}/usr/bin/fvwm-perllib" \
+ "${D}/usr/share/man/man1/fvwm-perllib.1"
fi
# Utility for testing FVWM behaviour by creating a simple window with