summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-27 23:51:21 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-27 23:51:21 +0000
commitdb6b3ecc86d2b3dce7e178949fcb7c9ef15bd2f9 (patch)
treeb9b3db27d68429ace6ccf19b265f8594f2362cd1
parentOrganise and clean up dependencies. (diff)
downloadomp-db6b3ecc86d2b3dce7e178949fcb7c9ef15bd2f9.tar.gz
omp-db6b3ecc86d2b3dce7e178949fcb7c9ef15bd2f9.tar.bz2
omp-db6b3ecc86d2b3dce7e178949fcb7c9ef15bd2f9.zip
Change FVWM_BUGADDR and shorten USE flag conditional statements.
svn path=/; revision=12
-rw-r--r--x11-wm/fvwm/Manifest2
-rw-r--r--x11-wm/fvwm/fvwm-2.5.25.ebuild15
2 files changed, 6 insertions, 11 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index fd98048..9770801 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -5,5 +5,5 @@ AUX fvwm-2.5.23-translucent-menus.diff 15765 RMD160 5629e1fcd6d41e7c9f5cfa0a6220
AUX fvwm-menu-xlock-xlockmore-compat.patch 550 RMD160 72af6f306e5869581fcd48c84edfe00adea4a5b9 SHA1 0eccf83c3046e3822737c5facb23f547a062bff8 SHA256 5db8bc279f618096b23fed04b70b626c6ff50c104283d5ece505200db1e5a8af
DIST fvwm-2.5.25.tar.bz2 2516717 RMD160 bf77786a071838304eb4bf8cc14960196c235506 SHA1 8e0f0b1eb888f7fcc27a0dbcc32a5b0f2895df2b SHA256 212dafb5fbace4a72d7a2d2dd6df7445709bad6739162a72879e4a6e942d69fc
DIST fvwm-patchset-20070901-r2.tar.bz2 37255 RMD160 787fe6f49e497a225648dbdd30b0636d3416a5b0 SHA1 9d56b1f2703feb52987e6aeb22dc151bc0e10d67 SHA256 9342142d216ca5b89c161a9796a08c4effc1b3d8dd41090e3419b051fac639fa
-EBUILD fvwm-2.5.25.ebuild 5104 RMD160 8f88d6ac4adec486e14e85c56e4c97af562623ef SHA1 efb17efd6d5209aedd2ff6dafb98bd4a4ad8f321 SHA256 52de483c6f45bf933a64c9e8fa9704f1b2b70c5929e44648bfee9e2bb8096986
+EBUILD fvwm-2.5.25.ebuild 5077 RMD160 5bdcdbdf7db480ee05b5c70bff3a69c8ad519b73 SHA1 6b1f68ef1c1bfcb8b167ac28d3aded95ef0d0af7 SHA256 e940da5ec6ce755c3ad61889d032551369ec2a6d8db40a37ed4f209a126150ad
EBUILD fvwm-9999.ebuild 6985 RMD160 fadfaa9ca384911f2a5930991a494c7ea80754ca SHA1 60c6c84d287b3c6c4fa2249bc8b7e1c816f8d0f2 SHA256 b7a725d6bd63582a89cfde414263acdf9b2c1709180039fce96d2273176e63a2
diff --git a/x11-wm/fvwm/fvwm-2.5.25.ebuild b/x11-wm/fvwm/fvwm-2.5.25.ebuild
index 8a72a3c..7ea553e 100644
--- a/x11-wm/fvwm/fvwm-2.5.25.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -73,10 +73,7 @@ src_unpack() {
src_compile() {
local myconf="--libexecdir=/usr/lib --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm --enable-package-subdirs"
- # use readline in FvwmConsole.
- if use readline; then
- myconf="${myconf} --without-termcap-library"
- fi
+ use readline && myconf="${myconf} --without-termcap-library"
# FvwmGtk can be built as a gnome application, or a Gtk+ application.
if ! use gtk; then
@@ -89,16 +86,14 @@ src_compile() {
myconf="${myconf} --without-gnome"
fi
- # set the local maintainer for fvwm-bug.
- export FVWM_BUGADDR="i92guboj@terra.es"
+ # Non-upstream email where bugs should be sent; used in fvwm-bug.
+ export FVWM_BUGADDR="desktop-wm@gentoo.org"
# reccommended by upstream
append-flags -fno-strict-aliasing
# signed chars are required
- if use ppc; then
- append-flags -fsigned-char
- fi
+ use ppc && append-flags -fsigned-char
econf ${myconf} \
$(use_enable bidi) \