summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-04-10 17:39:27 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-04-10 17:39:27 +0000
commit684fbf6c0202df4f9a750c7223693337d6562062 (patch)
tree48d9bb10421bc48de9c517acf1a252238975c9b8 /app-crypt/forcefield/forcefield-0.16.ebuild
downloadphilantrop-684fbf6c0202df4f9a750c7223693337d6562062.tar.gz
philantrop-684fbf6c0202df4f9a750c7223693337d6562062.tar.bz2
philantrop-684fbf6c0202df4f9a750c7223693337d6562062.zip
Initial import.
svn path=/trunk/; revision=2
Diffstat (limited to 'app-crypt/forcefield/forcefield-0.16.ebuild')
-rw-r--r--app-crypt/forcefield/forcefield-0.16.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/forcefield/forcefield-0.16.ebuild b/app-crypt/forcefield/forcefield-0.16.ebuild
new file mode 100644
index 0000000..b87fd15
--- /dev/null
+++ b/app-crypt/forcefield/forcefield-0.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils gnome2
+
+MY_P="${PN}_${PV}-1"
+
+DESCRIPTION="A pygtk gui for truecrypt."
+HOMEPAGE="http://bockcay.de/forcefield/"
+SRC_URI="http://bockcay.de/stuff/programs/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RESTRICT="mirror"
+
+DEPEND=">=dev-python/setuptools-0.6_rc3
+ >=dev-python/gnome-python-2.12.4"
+
+RDEPEND="${DEPEND}
+ >=dev-python/python-crack-0.5.1
+ >=dev-python/pycrypto-2.0.1-r5
+ >=dev-python/gnome-python-extras-2.14.0-r1
+ >=dev-python/pexpect-0.999
+ >=dev-python/dbus-python-0.71
+ >=dev-python/notify-python-0.1.1
+ >=app-crypt/truecrypt-4.2a-r1"
+
+pkg_setup() {
+ if ! built_with_use ">=sys-libs/cracklib-2.8.9-r1" python ; then
+ die "You MUST build sys-libs/cracklib with the python USE flag."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gettext.patch
+ epatch ${FILESDIR}/${P}-translation.patch
+}