summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-07-22 13:53:15 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-07-22 13:53:15 +0000
commitc2c5dc4a85f4eecfd7f5e8086837bd7997cbe721 (patch)
treed2611a523d79871d24f0d4b3990fee9895674e78 /www-apps/open-xchange/files/Makefile.am
parentUgly ebuilds for kvm but they suit my needs for now. :-) (diff)
downloadphilantrop-c2c5dc4a85f4eecfd7f5e8086837bd7997cbe721.tar.gz
philantrop-c2c5dc4a85f4eecfd7f5e8086837bd7997cbe721.tar.bz2
philantrop-c2c5dc4a85f4eecfd7f5e8086837bd7997cbe721.zip
Some random ebuild stuff.
svn path=/trunk/; revision=16
Diffstat (limited to 'www-apps/open-xchange/files/Makefile.am')
-rw-r--r--www-apps/open-xchange/files/Makefile.am122
1 files changed, 122 insertions, 0 deletions
diff --git a/www-apps/open-xchange/files/Makefile.am b/www-apps/open-xchange/files/Makefile.am
new file mode 100644
index 0000000..c6cab9a
--- /dev/null
+++ b/www-apps/open-xchange/files/Makefile.am
@@ -0,0 +1,122 @@
+SUBDIRS = javabuild src
+clean: @sslsubdir@
+ @ANT@ clean
+
+misc:
+ rm src/misc/ssl/com_openchange_ssl_SSLServerSocket.h
+ rm src/misc/ssl/com_openexchange_ssl_SSLCtx.h
+ rm src/misc/ssl/com_openexchange_ssl_SSLInputStream.h
+ rm src/misc/ssl/com_openexchange_ssl_SSLOutputStream.h
+ rm src/misc/ssl/com_openexchange_ssl_SSLSession.h
+ rm src/misc/ssl/com_openexchange_ssl_SSLSocket.h
+
+install:
+ $(mkinstalldirs) ${D}/@bindir@
+ $(mkinstalldirs) ${D}/@sbindir@
+ $(mkinstalldirs) ${D}/@datadir@
+ $(mkinstalldirs) ${D}/@datadir@/images
+ $(mkinstalldirs) ${D}/@datadir@/sound
+ $(mkinstalldirs) ${D}/@datadir@/misc
+ $(mkinstalldirs) ${D}/@datadir@/servlets
+ $(mkinstalldirs) ${D}/@datadir@/perl
+ $(mkinstalldirs) ${D}/@oxgroupwarehtmldir@
+ $(mkinstalldirs) ${D}/@oxwebmailhtmldir@
+ $(mkinstalldirs) ${D}/@sysconfdir@
+ $(mkinstalldirs) ${D}/@sysconfdir@/groupware
+ $(mkinstalldirs) ${D}/@sysconfdir@/webmail
+ $(mkinstalldirs) ${D}/@sysconfdir@/init.d
+ $(mkinstalldirs) ${D}/@sysconfdir@/groupware/CERT
+ $(mkinstalldirs) ${D}/@localstatedir@
+ $(mkinstalldirs) ${D}/@localstatedir@/log
+ $(mkinstalldirs) ${D}/@localstatedir@/settings/intranet
+ $(mkinstalldirs) ${D}/@localstatedir@/settings/webmail
+ $(mkinstalldirs) ${D}/@localstatedir@/filespool
+ $(mkinstalldirs) ${D}/@localstatedir@/drafts
+ $(mkinstalldirs) ${D}/@localstatedir@/webmailupload
+ $(mkinstalldirs) ${D}/@localstatedir@/dictionary
+ $(mkinstalldirs) ${D}/@libdir@
+ $(mkinstalldirs) ${D}/@includedir@
+ $(mkinstalldirs) ${D}/@infodir@
+ $(mkinstalldirs) ${D}/@mandir@
+ chmod 755 bin/groupware/openexchange-groupware
+ chmod 755 bin/groupware/openexchange-sessiond
+ chmod 755 bin/webmail/openexchange-webmail
+ chmod 755 sbin/addgroup_ox
+ chmod 755 sbin/addresource_ox
+ chmod 755 sbin/addresourcegroup_ox
+ chmod 755 sbin/addresourcetogroup_ox
+ chmod 755 sbin/adduser_ox
+ chmod 755 sbin/addusersql_ox
+ chmod 755 sbin/addusertogroup_ox
+ chmod 755 sbin/changecyruspass_ox
+ chmod 755 sbin/changeuserattr_ox
+ chmod 755 sbin/delgroup_ox
+ chmod 755 sbin/delresource_ox
+ chmod 755 sbin/delresourcefromgroup_ox
+ chmod 755 sbin/delresourcegroup_ox
+ chmod 755 sbin/deluser_ox
+ chmod 755 sbin/deluserfromgroup_ox
+ chmod 755 sbin/correctfilespool
+ chmod 755 system/etc/init.d/groupware
+ chmod 755 system/etc/init.d/webmail
+ chmod 755 system/etc/init.d/sessiond
+ chmod 755 system/etc/init.d/openexchange
+ cp bin/groupware/openexchange-groupware ${D}/@bindir@/.
+ cp bin/groupware/openexchange-sessiond ${D}/@bindir@/.
+ cp bin/webmail/openexchange-webmail ${D}/@bindir@/.
+ cp sbin/addgroup_ox ${D}/@sbindir@/.
+ cp sbin/addresource_ox ${D}/@sbindir@/.
+ cp sbin/addresourcegroup_ox ${D}/@sbindir@/.
+ cp sbin/addresourcetogroup_ox ${D}/@sbindir@/.
+ cp sbin/adduser_ox ${D}/@sbindir@/.
+ cp sbin/addusersql_ox ${D}/@sbindir@/.
+ cp sbin/addusertogroup_ox ${D}/@sbindir@/.
+ cp sbin/changeuserattr_ox ${D}/@sbindir@/.
+ cp sbin/delgroup_ox ${D}/@sbindir@/.
+ cp sbin/delresource_ox ${D}/@sbindir@/.
+ cp sbin/delresourcefromgroup_ox ${D}/@sbindir@/.
+ cp sbin/delresourcegroup_ox ${D}/@sbindir@/.
+ cp sbin/deluser_ox ${D}/@sbindir@/.
+ cp sbin/deluserfromgroup_ox ${D}/@sbindir@/.
+ cp sbin/correctfilespool ${D}/@sbindir@/.
+ cp -r system/setup/* ${D}/@datadir@/.
+ cp -r system/etc/cron.d/ ${D}/@sysconfdir@/.
+ cp system/etc/init.d/groupware ${D}/@sysconfdir@/init.d/.
+ cp system/etc/init.d/sessiond ${D}/@sysconfdir@/init.d/.
+ cp system/etc/init.d/webmail ${D}/@sysconfdir@/init.d/.
+ cp system/etc/init.d/openexchange ${D}/@sysconfdir@/init.d/.
+ cp conf/admintools.conf ${D}/@sysconfdir@/.
+ cp conf/initscript.conf ${D}/@sysconfdir@/.
+ cp conf/groupware/nasi.conf ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/calendar ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/currencyformat ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/dateformat ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/external.conf ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/forum ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/intranet.conf ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/ldap.properties ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/server.conf ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/system.properties ${D}/@sysconfdir@/groupware/.
+ cp conf/groupware/tasks ${D}/@sysconfdir@/groupware/.
+ cp -r conf/groupware/locales ${D}/@sysconfdir@/groupware/.
+ cp -r conf/groupware/METADB ${D}/@sysconfdir@/groupware/.
+ cp conf/webmail/flags.cfg ${D}/@oxwebmailsysconfdir@/.
+ cp conf/webmail/system.properties ${D}/@oxwebmailsysconfdir@/.
+ cp conf/webmail/nasi.conf ${D}/@oxwebmailsysconfdir@/.
+ cp conf/webmail/server.conf ${D}/@oxwebmailsysconfdir@/.
+ cp conf/webmail/spellcheck.cfg ${D}/@oxwebmailsysconfdir@/.
+ cp conf/webmail/system.cfg ${D}/@oxwebmailsysconfdir@/.
+ cp conf/webmail/system.properties ${D}/@oxwebmailsysconfdir@/.
+ cp -r conf/webmail/locales ${D}/@oxwebmailsysconfdir@/.
+ cp -r groupware/* ${D}/@oxgroupwarehtmldir@/.
+ cp -r webmail/* ${D}/@oxwebmailhtmldir@/.
+ cp -r system/www/groupware/* ${D}/@datadir@/groupware/data/.
+ cp -r system/www/webmail/* ${D}/@datadir@/webmail/data/.
+ cp lib/* ${D}/@libdir@/
+ if test -f src/misc/ssl/.libs/liboxssl.so ; then cp src/misc/ssl/.libs/liboxssl.so ${D}/@libdir@/. ; fi
+ chmod 755 src/misc/login/login.pl
+ cp src/misc/login/login.pl ${D}/@datadir@/perl/.
+ cp src/misc/login/login.pm ${D}/@datadir@/perl/.
+ cp build/intranet.class ${D}/@datadir@/servlets/.
+ cp build/webmail.class ${D}/@datadir@/servlets/.
+