summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/crossover-office-bin/Manifest18
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild50
-rw-r--r--app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.2.03
3 files changed, 71 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-bin/Manifest b/app-emulation/crossover-office-bin/Manifest
index 8d9d7f2..dba3a24 100644
--- a/app-emulation/crossover-office-bin/Manifest
+++ b/app-emulation/crossover-office-bin/Manifest
@@ -1,8 +1,26 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST install-crossover-standard-6.1.0.sh 24481498 RMD160 3f65fc3f19e1c222c10c85c943af1cea0f246890 SHA1 ea7589851bf27b9e70e092a18dcd7d35859f2460 SHA256 d36938d7a53767e6169eb05565f8a3ae8313f3ceee6a5912c6497f39ca08afbf
+DIST install-crossover-standard-6.2.0.sh 23632049 RMD160 dc0156afe069579f70dec55052655f7328ca1035 SHA1 4ceb3d05b4eb0f7c66df9cf833847799c156c0e3 SHA256 5ddd35d5271b49ec43ed128e9efd122c1792e1718e6e4024aa263ae0212c4320
EBUILD crossover-office-bin-6.1.0.ebuild 1230 RMD160 e133b17ab56d17b49800764eece6ff674c3192f3 SHA1 d1923aeafb5821f3914b98fdacef9093d50affc0 SHA256 152cf853a885ac8ccc36c6a7e1f4eddfda231084ae9dd351c009c166845b98ba
MD5 e83fefecbab208c8962d33adb4556b1b crossover-office-bin-6.1.0.ebuild 1230
RMD160 e133b17ab56d17b49800764eece6ff674c3192f3 crossover-office-bin-6.1.0.ebuild 1230
SHA256 152cf853a885ac8ccc36c6a7e1f4eddfda231084ae9dd351c009c166845b98ba crossover-office-bin-6.1.0.ebuild 1230
+EBUILD crossover-office-bin-6.2.0.ebuild 1243 RMD160 be98033a7888771da1ba3fe17fffba127f8cdfbf SHA1 360f1005a729ffe48dd017c4566441c4e3feedaa SHA256 bcea9ddb4e16bc48e1a005fe644e9def9d75d7ca22a673f9a901f2b2fafc51a2
+MD5 f14c2d1f635d607c744f1ebd45d0a593 crossover-office-bin-6.2.0.ebuild 1243
+RMD160 be98033a7888771da1ba3fe17fffba127f8cdfbf crossover-office-bin-6.2.0.ebuild 1243
+SHA256 bcea9ddb4e16bc48e1a005fe644e9def9d75d7ca22a673f9a901f2b2fafc51a2 crossover-office-bin-6.2.0.ebuild 1243
MD5 4d5eab0c4d32bace33c7c1039accf98c files/digest-crossover-office-bin-6.1.0 292
RMD160 c77658ed1d5bb4961d285a4338e69e6fe49279e1 files/digest-crossover-office-bin-6.1.0 292
SHA256 bac6bb3d42382be92ebfaaa66e62c0f18007b88252a861f8379288bee9df4eda files/digest-crossover-office-bin-6.1.0 292
+MD5 25570c32388270d69f4b7d3dd9ff7d69 files/digest-crossover-office-bin-6.2.0 292
+RMD160 9e97d1ba8192611c34c2b3a20e9dadcb9b064dcb files/digest-crossover-office-bin-6.2.0 292
+SHA256 738c58324940d39555ab0fb482365dc4b85d6a0138c7c6e411236f1b9ccd2573 files/digest-crossover-office-bin-6.2.0 292
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.7 (GNU/Linux)
+
+iD8DBQFHArurCkvF58q80IkRAjdeAJ9vVyKpIvdv3nXXu+U8WZL5kbYZawCfevRw
+1ARbuPPQ5KzcLzC7a9jVvBI=
+=DdcF
+-----END PGP SIGNATURE-----
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild
new file mode 100644
index 0000000..f331c3e
--- /dev/null
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-6.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-6.0.1.ebuild,v 1.2 2007/07/02 13:48:55 peper Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-standard-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ dev-util/desktop-file-utils
+ nas? ( media-libs/nas )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}
+
+pkg_postinst() {
+ einfo "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ einfo "bottles and install Windows applications."
+}
diff --git a/app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.2.0 b/app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.2.0
new file mode 100644
index 0000000..37e97a5
--- /dev/null
+++ b/app-emulation/crossover-office-bin/files/digest-crossover-office-bin-6.2.0
@@ -0,0 +1,3 @@
+MD5 629803c8ef274821e26e1c5d3ceb6b9f install-crossover-standard-6.2.0.sh 23632049
+RMD160 dc0156afe069579f70dec55052655f7328ca1035 install-crossover-standard-6.2.0.sh 23632049
+SHA256 5ddd35d5271b49ec43ed128e9efd122c1792e1718e6e4024aa263ae0212c4320 install-crossover-standard-6.2.0.sh 23632049