summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/openca')
-rwxr-xr-xwww-apps/openca/Manifest4
-rwxr-xr-xwww-apps/openca/files/mysql-setup.sql.in5
-rwxr-xr-xwww-apps/openca/files/openca-0.9.2_noldap.patch24
-rwxr-xr-xwww-apps/openca/openca-0.9.2_p1-r1.ebuild174
4 files changed, 0 insertions, 207 deletions
diff --git a/www-apps/openca/Manifest b/www-apps/openca/Manifest
deleted file mode 100755
index 4faf0ae..0000000
--- a/www-apps/openca/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX mysql-setup.sql.in 188 RMD160 f6872544d80052f04e1275ccbe7423e706f037fe SHA1 f319af41006321718d33c7e89b0be701cdb9e0b4 SHA256 c14a54b39910154a8a200c151df8890484337f76077366160e551821289910a3
-AUX openca-0.9.2_noldap.patch 819 RMD160 1619ff471a25cd18cf9b75bd48731e5e89bb63d1 SHA1 4905899b03c0675dc4f3b046ecc6b96938dc6e35 SHA256 d222363638862a59db58ab4b2cb4bcad4c5649da39bc777839baa0a87480720a
-DIST openca-0.9.2-1.tar.gz 7185831 RMD160 06fc44aa0fb83557b2cc4766a55c5ff558b63284 SHA1 0f36dbef1c2837d8b3822ef96d8948b92e3b2947 SHA256 c839825133defbc25c2cbcd9009615e3f140cb7488e7acaabfc8b52d4c5dab5f
-EBUILD openca-0.9.2_p1-r1.ebuild 4577 RMD160 b08564c2db0938e577587dc9810dae9bbcb4e03d SHA1 76052d490c13f10542ee9bd421002c0a843e4650 SHA256 1456cdd849c63f068b95e5aea085e09b600239b15efb390d221af5c481cf7a85
diff --git a/www-apps/openca/files/mysql-setup.sql.in b/www-apps/openca/files/mysql-setup.sql.in
deleted file mode 100755
index 07b1705..0000000
--- a/www-apps/openca/files/mysql-setup.sql.in
+++ /dev/null
@@ -1,5 +0,0 @@
-GRANT USAGE ON openca.* TO 'openca'@'localhost' IDENTIFIED BY '@dbpass@';
-
-GRANT SELECT, INSERT, UPDATE, DELETE ON openca.* TO 'openca'@'localhost';
-
-CREATE DATABASE IF NOT EXISTS openca;
diff --git a/www-apps/openca/files/openca-0.9.2_noldap.patch b/www-apps/openca/files/openca-0.9.2_noldap.patch
deleted file mode 100755
index 0065730..0000000
--- a/www-apps/openca/files/openca-0.9.2_noldap.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/common/lib/functions/initServer 2005-01-19 14:33:20.780398440 +0100
-+++ src/common/lib/functions/initServer 2005-01-19 14:33:51.348751344 +0100
-@@ -80,8 +80,8 @@
- setPerformancePoint ("rbac-utils loaded");
- require "$common_libs/mail-utils.lib";
- setPerformancePoint ("mail-utils loaded");
--require "$common_libs/ldap-utils.lib";
--setPerformancePoint ("ldap-utils loaded");
-+#require "$common_libs/ldap-utils.lib";
-+#setPerformancePoint ("ldap-utils loaded");
- require "$common_libs/export-import.lib";
- setPerformancePoint ("export-import loaded");
-
-@@ -119,8 +119,8 @@
- initAccessControl();
- $ui_html = $debug_ui_html;
-
--require "$common_libs/initLDAP";
--setPerformancePoint ("ldap ready");
-+#require "$common_libs/initLDAP";
-+#setPerformancePoint ("ldap ready");
-
- ## 5. load version and init debugging
-
diff --git a/www-apps/openca/openca-0.9.2_p1-r1.ebuild b/www-apps/openca/openca-0.9.2_p1-r1.ebuild
deleted file mode 100755
index f98f5fe..0000000
--- a/www-apps/openca/openca-0.9.2_p1-r1.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils flag-o-matic toolchain
-MY_P=${P/_p/-}
-MY_P2=${P/_p/.}
-
-DESCRIPTION="The OpenCA Project is a collaborative effort to develop a robust, full-featured and Open Source out-of-the-box Certification Authority implementing the most used protocols with full-strength cryptography world-wide."
-HOMEPAGE="http://www.openca.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="uclibc doc dbm mysql postgres ldap vhosts"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- !dev-perl/OpenCA-X509
- !dev-perl/OpenCA-REQ
- !dev-perl/OpenCA-OpenSSL
- !dev-perl/OpenCA-CRL
- >=dev-libs/openssl-0.9.7
- net-www/apache
- >=perl-core/MIME-Base64-2.20
- >=dev-perl/Digest-HMAC-1.01
- >=dev-perl/Digest-SHA1-2.02
- >=perl-core/Digest-MD5-2.24
- >=dev-perl/libintl-perl-1.10
- >=dev-perl/IO-stringy-2.108
- >=dev-perl/MIME-Lite-3.01
- >=dev-perl/MIME-tools-5.411
- >=dev-perl/MailTools-1.58
- >=dev-perl/Parse-RecDescent-1.94
- >=dev-perl/X500-DN-0.28
- >=dev-perl/XML-Twig-3.09
- >=dev-perl/CGI-Session-3.95
- >=dev-perl/net-server-0.86
- >=dev-perl/Convert-ASN1-0.18
- dbm? ( perl-core/DB_File )
- mysql? ( dev-perl/DBD-mysql )
- postgres? ( dev-perl/DBD-Pg )
- !mysql? ( !postgres? ( perl-core/DB_File ) )
- ldap? ( net-nds/openldap
- >=dev-perl/perl-ldap-0.28
- >=dev-perl/IO-Socket-SSL-0.92
- >=dev-perl/URI-1.23
- )
- sasl? ( >=dev-perl/Authen-SASL-2.04 )
- !uclibc? ( sys-devel/bc )"
-
-S=${WORKDIR}/${MY_P2}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- if ! use ldap ; then
- epatch ${FILESDIR}/openca-0.9.2_noldap.patch
- fi
-
- case $( gcc-version ) in
- 3.4 | 3.3 | 3.2 )
- filter-flags -fprefetch-loop-arrays -freduce-all-givs -funroll-loops
- ;;
- esac
- econf
-}
-
-src_compile() {
- cd ${S}
- einfo "Compiling ${P}"
- myconf="--with-openca-user=openca \
- --with-openca-group=openca \
- --with-htdocs-fs-prefix=/var/www/localhost/htdocs/openca \
- --with-cgi-fs-prefix=/var/www/localhost/cgi-bin \
- --with-etc-prefix=/etc/openca \
- --with-var-prefix=/var/openca \
- --with-lib-prefix=/usr/lib/openca \
- --with-httpd-user=apache \
- --with-httpd-group=apache \
- --disable-external-modules"
- if ! use vhosts ; then
- myconf="${myconf} --with-htdocs-url-prefix=/openca"
- fi
- if use ldap; then
- myconf="${myconf} --with-ldap-port=389 \
- --with-ldap-root='cn=Manager,o=OpenCA,c=IT' \
- --with-ldap-root-pwd='openca'"
- else
- myconf="${myconf} --disable-ldap"
- fi
- if ! use mysql && ! use postgres || use dbm; then
- myconf="${myconf} --enable-db"
- else
- myconf="${myconf} --disable-db"
- fi
- if use mysql; then
- einfo "Setting random user/password details for the mysql database"
- local dbpass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
- sed -e "s/@dbpass@/${dbpass}/g" \
- ${FILESDIR}/mysql-setup.sql.in > ${T}/mysql-setup.sql
-
- myconf="${myconf} --enable-dbi \
- --with-db-type=mysql \
- --with-db-name=openca \
- --with-db-host=localhost \
- --with-db-port=3306 \
- --with-db-user=openca \
- --with-db-passwd='${dbpass}'"
- fi
- if use postgres; then
- einfo "Setting random user/password details for the postgres database"
- local dbpass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
-# sed -e "s/@dbpass@/${dbpass}/g" \
-# ${FILESDIR}/postgres-setup.sql.in > ${T}/posgres-setup.sql
-
- myconf="${myconf} --enable-dbi \
- --with-db-type=Pg \
- --with-db-name=openca \
- --with-db-host=localhost \
- --with-db-port=5432 \
- --with-db-user=openca \
- --with-db-passwd='${dbpass}'"
- fi
-
- econf ${myconf}
- emake || die
-}
-
-src_install() {
- cd ${S}
- make install-online install-ca DESTDIR=${D} || die
-
- dodir /var/openca/tmp
- keepdir /var/openca/tmp
- dosym /var/openca/log /var/log/openca
- keepdir /var/openca/log
- dodir /var/openca/log/xml
- keepdir /var/openca/log/xml
-
- dodoc CHANGES* LICENSE README
- dodoc docs/*.txt
- doman docs/man3/*.3
- if use doc; then
- dohtml -r docs/guide
- dohtml -r docs/howto
- docinto shared
- dodocs docs/shared/*.txt
- fi
- if use ldap; then
- docinto openldap
- dodocs contrib/openldap/openca.schema
- fi
- if ! use mysql && ! use postgres || use dbm ; then
- dodir /var/openca/db
- keepdir /var/openca/db
- fi
- if use vhosts; then
- insinto /etc/apache2/conf/vhosts
- #***more to come***
- fi
- dosym /etc/openca/openca_rc /etc/init.d/openca
-}
-
-pkg_setup() {
- enewgroup openca
- enewuser openca -1 -1 /dev/null openca
-}
-
-pkg_postinst() {
- einfo "Please check file '/etc/openca/config.xml'"
- einfo "Then run '/etc/openca/configure_etc.sh' script"
-}