summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-08-20 16:47:55 +0000
committerChristian Heim <phreak@gentoo.org>2007-08-20 16:47:55 +0000
commitee56ced9f4fb57800c5ec4fe02bc02df9955361d (patch)
tree40fbfbaddd34cf2d25f3d394c4559db4238180b6 /bugfixes
parentDocument stuff still todo. (diff)
downloadphreak-ee56ced9f4fb57800c5ec4fe02bc02df9955361d.tar.gz
phreak-ee56ced9f4fb57800c5ec4fe02bc02df9955361d.tar.bz2
phreak-ee56ced9f4fb57800c5ec4fe02bc02df9955361d.zip
Fixing build, by hacking the output of tc-arch-kernel for sparc and ppc*.
svn path=/; revision=359
Diffstat (limited to 'bugfixes')
-rw-r--r--bugfixes/dev-libs/klibc/klibc-1.5.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/bugfixes/dev-libs/klibc/klibc-1.5.ebuild b/bugfixes/dev-libs/klibc/klibc-1.5.ebuild
index 1663c35..c8af474 100644
--- a/bugfixes/dev-libs/klibc/klibc-1.5.ebuild
+++ b/bugfixes/dev-libs/klibc/klibc-1.5.ebuild
@@ -42,15 +42,18 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-sigaction.patch
}
+tc-detect-arch() {
+ tc-arch-kernel | sed -e "s,powerpc,ppc" -e "s,sparc(.*),sparc"
+}
+
src_compile() {
local myconf=""
# sparc kernel bitness (32 vs. 64) doesn't matter, as userland is always
# compiled w/ 32 -- as pointed out by gustavoz
- # neither tc-arch-kernel nor tc-arch-portage get the UL foo right for
- # ppc32/64, guess we either have to improvise or we need to figure out
- # something else.
+ # tc-arch-kernel gets the UL issue on ppc64 right, but klibc is still back
+ # before 2.6.15, when ppc/ppc64 got renamed to powerpc.
[[ ${KV_DIR} != "${KV_OUT_DIR}" ]] && \
myconf="KLIBCKERNELOBJ='${KV_OUT_DIR}/' KBUILD_SRC='1'"
@@ -61,7 +64,7 @@ src_compile() {
myconf="CROSS_COMPILE=${CTARGET}-"
fi
- emake KLIBCARCH=$(tc-arch-kernel) \
+ emake KLIBCARCH=$(tc-detect-arch | sed "s,powerpc,ppc") \
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
EXTRA_KLIBCLDFLAGS="-z,noexecstack" \
libdir="/usr/$(get_libdir)" \
@@ -86,7 +89,7 @@ src_install() {
klibc_prefix=$("${S}/klcc/klcc" -print-klibc-prefix)
fi
- emake KLIBCARCH=$(tc-arch-kernel) \
+ emake KLIBCARCH=$(tc-detect-arch) \
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
EXTRA_KLIBCLDFLAGS="-z,noexecstack" \
INSTALLROOT="${D}" \