summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx/fcitx-9999.ebuild')
-rw-r--r--app-i18n/fcitx/fcitx-9999.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-i18n/fcitx/fcitx-9999.ebuild b/app-i18n/fcitx/fcitx-9999.ebuild
new file mode 100644
index 0000000..146c029
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit mercurial
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://fcitx.googlecode.com"
+SRC_URI="${HOMEPAGE}/files/pinyin.tar.gz
+ ${HOMEPAGE}/files/pinyin.tar.gz.md5
+ ${HOMEPAGE}/files/table.tar.gz
+ ${HOMEPAGE}/files/table.tar.gz.md5"
+EHG_REPO_URI="https://fcitx.googlecode.com/hg/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus debug +pango"
+RESTRICT="mirror"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ media-libs/fontconfig
+ x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ x11-proto/xproto"
+
+src_unpack() {
+ mercurial_src_unpack
+ cp "${DISTDIR}"/pinyin.tar.gz "${S}"/data
+ cp "${DISTDIR}"/pinyin.tar.gz.md5 "${S}"/data
+ cp "${DISTDIR}"/table.tar.gz "${S}"/data/table
+ cp "${DISTDIR}"/table.tar.gz.md5 "${S}"/data/table
+}
+
+src_compile() {
+ ./autogen.sh
+ econf --enable-tray --enable-recording \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable debug log)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO || die "dodoc failed"
+ rm -rf "${D}"/usr/share/fcitx/doc || die
+ dodoc doc/cjkvinput.txt doc/fcitx4.pdf doc/pinyin.txt
+ dohtml doc/wb_fh.htm || die "dothml failed"
+}
+
+pkg_postinst() {
+ einfo "This is not an official release. Please report you bugs to:"
+ einfo "http://code.google.com/p/fcitx/issues/list"
+ echo
+ elog "You should export the following variables to use fcitx"
+ elog " export XMODIFIERS=\"@im=fcitx\""
+ elog " export XIM=\"fcitx\""
+ elog " export GTK_IM_MODULE=\"fcitx\""
+ elog " export QT_IM_MODULE=\"fcitx\""
+}