summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-04-18 17:23:57 +0000
committerRichard Brown <rbrown@gentoo.org>2007-04-18 17:23:57 +0000
commit44873905c83421f57118dc8cd52ddb097631c216 (patch)
tree4414f4c22029e1c89974210aac69221eeb0e901a
downloadrbrown-44873905c83421f57118dc8cd52ddb097631c216.tar.gz
rbrown-44873905c83421f57118dc8cd52ddb097631c216.tar.bz2
rbrown-44873905c83421f57118dc8cd52ddb097631c216.zip
Finish profiles. Add sqlite3-ruby-1.2.1 EAPI="paludis-1"
svn path=/; revision=2
-rw-r--r--dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1.ebuild54
-rw-r--r--profiles/categories1
-rw-r--r--profiles/repo_name1
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1.ebuild b/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1.ebuild
new file mode 100644
index 0000000..305cfcd
--- /dev/null
+++ b/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3-ruby/sqlite3-ruby-1.2.1.ebuild,v 1.3 2007/03/04 00:15:40 genone Exp $
+
+inherit ruby
+
+DESCRIPTION="An extension library to access a SQLite database from Ruby"
+HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
+LICENSE="BSD"
+EAPI="paludis-1"
+
+SRC_URI="http://rubyforge.org/frs/download.php/17096/${P}.tar.bz2"
+
+KEYWORDS="~sparc ~x86"
+SLOT="0"
+IUSE="doc swig"
+
+USE_RUBY="ruby18 ruby19"
+DEPEND="dev-db/sqlite:3
+ swig? ( dev-lang/swig[ruby] )"
+
+pkg_setup() {
+ if ! use swig ; then
+ elog "${PN} will work a lot better with swig; it is suggested"
+ elog "that you install swig with the 'ruby' USE flag, and then"
+ elog "install ${PN} with the swig USE flag"
+ ebeep
+ epause 5
+ fi
+}
+
+src_compile() {
+ myconf=""
+ if ! use swig ; then
+ myconf="--without-ext"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr ${myconf} \
+ || die "setup.rb config failed"
+ ${RUBY} setup.rb setup \
+ || die "setup.rb setup failed"
+}
+
+src_install() {
+ ${RUBY} setup.rb install --prefix=${D} \
+ || die "setup.rb install failed"
+
+ dodoc README ChangeLog
+ dohtml doc/faq/faq.html
+
+ if use doc ; then
+ dohtml -r -V api
+ fi
+}
diff --git a/profiles/categories b/profiles/categories
new file mode 100644
index 0000000..1d2269d
--- /dev/null
+++ b/profiles/categories
@@ -0,0 +1 @@
+dev-ruby
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..2dbf412
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+rbrown