summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-05-01 14:52:48 +0000
committerRichard Brown <rbrown@gentoo.org>2007-05-01 14:52:48 +0000
commitcc63985e8d4616e286096f2d591e76e1835e7eac (patch)
treeb82d5716c91709db36b5f467566302357f705a07
parentFix ruby exit status (diff)
downloadrbrown-cc63985e8d4616e286096f2d591e76e1835e7eac.tar.gz
rbrown-cc63985e8d4616e286096f2d591e76e1835e7eac.tar.bz2
rbrown-cc63985e8d4616e286096f2d591e76e1835e7eac.zip
Force -j1 to emake in src_test
svn path=/; revision=15
-rw-r--r--dev-lang/ruby/ruby-1.8.6-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/ruby/ruby-1.8.6-r2.ebuild b/dev-lang/ruby/ruby-1.8.6-r2.ebuild
index 29135ea..6ab1e15 100644
--- a/dev-lang/ruby/ruby-1.8.6-r2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6-r2.ebuild
@@ -102,7 +102,7 @@ src_compile() {
}
src_test() {
- emake test || die "make test failed"
+ emake -j1 test || die "make test failed"
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -147,7 +147,7 @@ src_install() {
dodoc ChangeLog NEWS README* ToDo
if use rubytests; then
- dodir /usr/share/${PN}
+ dodir /usr/share/${PN}-${SLOT}
cp -pPR test ${D}/usr/share/${PN}
fi
}