summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-04-23 18:53:14 +0000
committerRichard Brown <rbrown@gentoo.org>2007-04-23 18:53:14 +0000
commitf4301aeced8a5a445aff2fa0423bbe7d272ae232 (patch)
tree9f02045c0d79a020ad89d605bfa3c852cd3cadd2
parentAdd eclasses and sqlite-ruby (diff)
downloadrbrown-f4301aeced8a5a445aff2fa0423bbe7d272ae232.tar.gz
rbrown-f4301aeced8a5a445aff2fa0423bbe7d272ae232.tar.bz2
rbrown-f4301aeced8a5a445aff2fa0423bbe7d272ae232.zip
add ruby and gorg
svn path=/; revision=4
-rw-r--r--dev-lang/ruby/ruby-1.8.6.ebuild142
-rw-r--r--profiles/categories2
-rw-r--r--www-servers/gorg/gorg-0.6.3-r1.ebuild52
3 files changed, 196 insertions, 0 deletions
diff --git a/dev-lang/ruby/ruby-1.8.6.ebuild b/dev-lang/ruby/ruby-1.8.6.ebuild
new file mode 100644
index 0000000..8591bcc
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.6.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6.ebuild,v 1.2 2007/04/07 16:23:57 pclouds Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+# A new version is needed for 1.8.6, currently disabled.
+ONIGURUMA="onigd2_5_8"
+
+inherit flag-o-matic alternatives eutils multilib autotools versionator
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/$(get_version_component_range 1-2)/${P}.tar.gz"
+# cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug socks5 tk doc threads examples ipv6" # cjk
+RESTRICT="confcache"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3.1
+ !=dev-lang/ruby-cvs-1.8*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+src_unpack() {
+ unpack ${A}
+
+# if use cjk ; then
+# einfo "Applying ${ONIGURUMA}"
+# pushd ${WORKDIR}/oniguruma
+## epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+# econf --with-rubydir=${S} || die "econf failed"
+# MY_PV=$(get_version_component_range 1-2)
+# make ${MY_PV/./}
+# popd
+# fi
+
+ cd "${S}"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ econf --program-suffix=${SLOT/./} --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6 ipv6) \
+ $(use_enable debug debug) \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find ${S}/ext -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir ${ROOT}usr/share/doc/${PF}
+ cp -pPR sample ${D}/${ROOT}usr/share/doc/${PF}
+ fi
+
+ dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
+ dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
+
+ dodoc ChangeLog NEWS README* ToDo
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Warning: Vim won't work if you've just updated ruby from"
+ ewarn "1.6.x to 1.8.x due to the library version change."
+ ewarn "In that case, you will need to remerge vim."
+ ewarn
+
+ ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
+ ewarn "you should re-emerge ruby again."
+ ewarn "See bug #159922 for details"
+ ewarn
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ elog
+ elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ elog
+}
+
+pkg_postrm() {
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+}
diff --git a/profiles/categories b/profiles/categories
index 1d2269d..96525aa 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1 +1,3 @@
dev-ruby
+www-servers
+dev-lang
diff --git a/www-servers/gorg/gorg-0.6.3-r1.ebuild b/www-servers/gorg/gorg-0.6.3-r1.ebuild
new file mode 100644
index 0000000..0b6124b
--- /dev/null
+++ b/www-servers/gorg/gorg-0.6.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gorg/gorg-0.6.3-r1.ebuild,v 1.1 2007/04/23 17:15:36 rbrown Exp $
+
+inherit ruby eutils
+
+DESCRIPTION="Back-end XSLT processor for an XML-based web site"
+HOMEPAGE="http://gentoo.neysx.org/mystuff/gorg/gorg.xml"
+SRC_URI="http://gentoo.neysx.org/mystuff/gorg/${P}.tgz"
+IUSE="apache fastcgi mysql"
+
+EAPI="paludis-1"
+SLOT="0"
+USE_RUBY="ruby18"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/ruby
+ >=dev-libs/libxml2-2.6.16
+ >=dev-libs/libxslt-1.1.12"
+RDEPEND="${DEPEND}
+ apache? ( net-www/apache )
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.5-r1
+ apache? ( >=www-apache/mod_fcgid-1.05 )
+ )
+ mysql? ( >=dev-ruby/ruby-dbi-0.0.21[mysql] >=dev-ruby/mysql-ruby-2.5 )"
+
+pkg_setup() {
+ enewgroup gorg
+ enewuser gorg -1 -1 -1 gorg
+}
+
+src_compile() {
+ # Fix listen issue w/ webrick
+ sed -i -e 's/WEBrick::HTTPServer.new(/WEBrick::HTTPServer.new( :BindAddress=>"127.0.0.1",/' lib/gorg/www.rb
+
+ ruby_src_compile
+}
+
+src_install() {
+ ruby_einstall
+
+ # install doesn't seem to chmod these correctly, forcing it here
+ SITE_LIB_DIR=`$RUBY -r rbconfig -e 'puts Config::CONFIG["sitelibdir"]'`
+ chmod +x ${D}/${SITE_LIB_DIR}/gorg/cgi-bin/*.cgi
+ chmod +x ${D}/${SITE_LIB_DIR}/gorg/fcgi-bin/*.fcgi
+
+ keepdir /etc/gorg; insinto /etc/gorg ; doins etc/gorg/*
+ diropts -m0770 -o gorg -g gorg; keepdir /var/cache/gorg
+
+ dodoc Changelog README
+}