summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libffado')
-rw-r--r--media-libs/libffado/Manifest3
-rw-r--r--media-libs/libffado/files/libffado-2.0.0-fix-scons-options.patch58
-rw-r--r--media-libs/libffado/libffado-2.0.0.ebuild65
3 files changed, 126 insertions, 0 deletions
diff --git a/media-libs/libffado/Manifest b/media-libs/libffado/Manifest
new file mode 100644
index 0000000..4f91684
--- /dev/null
+++ b/media-libs/libffado/Manifest
@@ -0,0 +1,3 @@
+AUX libffado-2.0.0-fix-scons-options.patch 4126 RMD160 70fb63fae2278e86ee2b57565093080047e1e3ef SHA1 52dbf469d81c1ba33b1b32667dbbc95ff95855da SHA256 ce3b2b70f2a739a310cf90f557ee71e2b8bad55731479fb6833899c40e1254d6
+DIST libffado-2.0.0.tar.gz 778733 RMD160 dca255a68f67ae904b8a597669ff412d84d0b629 SHA1 474d41ad4e3e4bad952636fea47488fad3db0d93 SHA256 5d375246f7c269f21b6471cb23cc30a8886431b2b09e7cfbbcc085dba2a6d65b
+EBUILD libffado-2.0.0.ebuild 1422 RMD160 7421fe8c835b0a4c367fe6e0a560a5eebb10da96 SHA1 00cb312b120f2919ecc43e8f04d89fdb2ed95bc6 SHA256 fb287c9f21a1c477cfbd23d8ec6a0cf14f4eca7b5ed0fa08b122ae08e13b6651
diff --git a/media-libs/libffado/files/libffado-2.0.0-fix-scons-options.patch b/media-libs/libffado/files/libffado-2.0.0-fix-scons-options.patch
new file mode 100644
index 0000000..4d71fa3
--- /dev/null
+++ b/media-libs/libffado/files/libffado-2.0.0-fix-scons-options.patch
@@ -0,0 +1,58 @@
+--- SConstruct 2009-12-08 19:08:47.000000000 +0100
++++ SConstruct 2009-12-23 15:04:40.000000000 +0100
+@@ -35,35 +35,35 @@
+ if not os.path.isdir( "cache" ):
+ os.makedirs( "cache" )
+
+-opts = Options( "cache/options.cache" )
++opts = Variables( "cache/options.cache" )
+
+-opts.AddOptions(
+- BoolOption( "DEBUG", """\
++opts.AddVariables(
++ BoolVariable( "DEBUG", """\
+ Toggle debug-build. DEBUG means \"-g -Wall\" and more, otherwise we will use
+ \"-O2\" to optimize.""", False ),
+- BoolOption( "PROFILE", "Build with symbols and other profiling info", False ),
+- PathOption( "PREFIX", "The prefix where ffado will be installed to.", "/usr/local", PathOption.PathAccept ),
+- PathOption( "BINDIR", "Overwrite the directory where apps are installed to.", "$PREFIX/bin", PathOption.PathAccept ),
+- PathOption( "LIBDIR", "Overwrite the directory where libs are installed to.", "$PREFIX/lib", PathOption.PathAccept ),
+- PathOption( "INCLUDEDIR", "Overwrite the directory where headers are installed to.", "$PREFIX/include", PathOption.PathAccept ),
+- PathOption( "SHAREDIR", "Overwrite the directory where misc shared files are installed to.", "$PREFIX/share/libffado", PathOption.PathAccept ),
+- BoolOption( "ENABLE_BEBOB", "Enable/Disable the bebob part.", True ),
+- BoolOption( "ENABLE_FIREWORKS", "Enable/Disable the ECHO Audio FireWorks AV/C part.", True ),
+- BoolOption( "ENABLE_MOTU", "Enable/Disable the MOTU part.", True ),
+- BoolOption( "ENABLE_GENERICAVC", """\
++ BoolVariable( "PROFILE", "Build with symbols and other profiling info", False ),
++ PathVariable( "PREFIX", "The prefix where ffado will be installed to.", "/usr/local", PathVariable.PathAccept ),
++ PathVariable( "BINDIR", "Overwrite the directory where apps are installed to.", "$PREFIX/bin", PathVariable.PathAccept ),
++ PathVariable( "LIBDIR", "Overwrite the directory where libs are installed to.", "$PREFIX/lib", PathVariable.PathAccept ),
++ PathVariable( "INCLUDEDIR", "Overwrite the directory where headers are installed to.", "$PREFIX/include", PathVariable.PathAccept ),
++ PathVariable( "SHAREDIR", "Overwrite the directory where misc shared files are installed to.", "$PREFIX/share/libffado", PathVariable.PathAccept ),
++ BoolVariable( "ENABLE_BEBOB", "Enable/Disable the bebob part.", True ),
++ BoolVariable( "ENABLE_FIREWORKS", "Enable/Disable the ECHO Audio FireWorks AV/C part.", True ),
++ BoolVariable( "ENABLE_MOTU", "Enable/Disable the MOTU part.", True ),
++ BoolVariable( "ENABLE_GENERICAVC", """\
+ Enable/Disable the the generic avc part (mainly used by apple).
+ Note that disabling this option might be overwritten by other devices needing
+ this code.""", False ),
+- BoolOption( "ENABLE_ALL", "Enable/Disable support for all devices.", False ),
+- BoolOption( "SERIALIZE_USE_EXPAT", "Use libexpat for XML serialization.", False ),
+- BoolOption( "BUILD_TESTS", """\
++ BoolVariable( "ENABLE_ALL", "Enable/Disable support for all devices.", False ),
++ BoolVariable( "SERIALIZE_USE_EXPAT", "Use libexpat for XML serialization.", False ),
++ BoolVariable( "BUILD_TESTS", """\
+ Build the tests in their directory. As some contain quite some functionality,
+ this is on by default.
+ If you just want to use ffado with jack without the tools, you can disable this.\
+ """, True ),
+- BoolOption( "BUILD_STATIC_TOOLS", "Build a statically linked version of the FFADO tools.", False ),
+- EnumOption('DIST_TARGET', 'Build target for cross compiling packagers', 'auto', allowed_values=('auto', 'i386', 'i686', 'x86_64', 'powerpc', 'powerpc64', 'none' ), ignorecase=2),
+- BoolOption( "ENABLE_OPTIMIZATIONS", "Enable optimizations and the use of processor specific extentions (MMX/SSE/...).", False ),
++ BoolVariable( "BUILD_STATIC_TOOLS", "Build a statically linked version of the FFADO tools.", False ),
++ EnumVariable('DIST_TARGET', 'Build target for cross compiling packagers', 'auto', allowed_values=('auto', 'i386', 'i686', 'x86_64', 'powerpc', 'powerpc64', 'none' ), ignorecase=2),
++ BoolVariable( "ENABLE_OPTIMIZATIONS", "Enable optimizations and the use of processor specific extentions (MMX/SSE/...).", False ),
+
+ )
+
+
diff --git a/media-libs/libffado/libffado-2.0.0.ebuild b/media-libs/libffado/libffado-2.0.0.ebuild
new file mode 100644
index 0000000..b7c3910
--- /dev/null
+++ b/media-libs/libffado/libffado-2.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+inherit eutils multilib
+RESTRICT="mirror"
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Successor for freebob: Library for accessing BeBoB IEEE1394 devices"
+HOMEPAGE="http://www.ffado.org"
+SRC_URI="http://www.ffado.org/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug qt4"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.0
+ >=dev-cpp/libxmlpp-2.13.0
+ >=sys-libs/libraw1394-1.3.0
+ >=media-libs/libiec61883-1.1.0
+ >=sys-libs/libavc1394-0.5.3
+ >=sys-apps/dbus-1.0
+ qt4? (
+ || ( ( x11-libs/qt-core x11-libs/qt-gui )
+ >=x11-libs/qt-4.0:4 )
+ dev-python/PyQt4
+ >=dev-python/dbus-python-0.83.0 )"
+
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fix-scons-options.patch"
+}
+
+src_compile () {
+ local myconf=""
+
+ use debug \
+ && myconf="${myconf} DEBUG=True ENABLE_OPTIMIZATIONS=False" \
+ || myconf="${myconf} DEBUG=False ENABLE_OPTIMIZATIONS=True"
+
+ scons \
+ PREFIX=/usr \
+ LIBDIR=/usr/$(get_libdir) \
+ ${myconf} || die
+}
+
+src_install () {
+ scons DESTDIR="${D}" WILL_DEAL_WITH_XDG_MYSELF="True" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use qt4; then
+ newicon "support/xdg/hi64-apps-ffado.png" "ffado.png"
+ newmenu "support/xdg/ffado.org-ffadomixer.desktop" "ffado-mixer.desktop"
+ fi
+}