summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:17:59 +0200
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-11 13:17:59 +0200
commit809b6f1e3e4be9ee8f28530b29111e6d6ff835f4 (patch)
tree835a89931173bbf9bece5e39c43a8337e700a112
parent[sys-boot/grub] fully support side-by-side install with old grub. (diff)
downloadscarabeus-809b6f1e3e4be9ee8f28530b29111e6d6ff835f4.tar.gz
scarabeus-809b6f1e3e4be9ee8f28530b29111e6d6ff835f4.tar.bz2
scarabeus-809b6f1e3e4be9ee8f28530b29111e6d6ff835f4.zip
[sys-boot/grub] Rename efi cutting so it does not break qemu targets. Add loongson target for live version as yeelong was renamed.
-rw-r--r--sys-boot/grub/Manifest4
-rw-r--r--sys-boot/grub/grub-1.99.ebuild14
-rw-r--r--sys-boot/grub/grub-9999.ebuild16
3 files changed, 17 insertions, 17 deletions
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index 9f6ccf6..75508d4 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -1,5 +1,5 @@
AUX grub.default 1127 RMD160 a884e842cb203687cac4cac6551b0feed58d3b7a SHA1 5878147845b5d4b4aac34ce046ead60b93c3170c SHA256 32664f2e0bdd05cf9579f8e098aa0add76ef7bf7b37eb103c6d0f625204f44d3
DIST grub-1.99.tar.xz 2639224 RMD160 d59a47fa40b2be0d5ea5b2b00ff5538cfa147747 SHA1 a5ae9558f30ce7757a76aa130088b053a87e2fb6 SHA256 f308148d4c83c6f16a73b58a0cd39381656edb740929028cae7ad5f0d651021b
-EBUILD grub-1.99.ebuild 7683 RMD160 586653c6286ea53086b11dfe663a5052dd2a78c1 SHA1 77ac581dc7e23d937ff37308faa2d226f8a6fe8c SHA256 022b97492e4b2b1cace0f853e87b8282a2e6cdfe19e0d469836b400c0fd9cea7
-EBUILD grub-9999.ebuild 7683 RMD160 586653c6286ea53086b11dfe663a5052dd2a78c1 SHA1 77ac581dc7e23d937ff37308faa2d226f8a6fe8c SHA256 022b97492e4b2b1cace0f853e87b8282a2e6cdfe19e0d469836b400c0fd9cea7
+EBUILD grub-1.99.ebuild 7683 RMD160 12631ba0d4d494bc0de901cbc11fb76f34938f29 SHA1 c2a90722db4cf03ed6334cc597f3504884814b4c SHA256 3bde7f19ec359b7ce33e50b1d7b4fd07f27e6bdcf576bb54cbb06fe3b6d9319b
+EBUILD grub-9999.ebuild 7684 RMD160 ad7613fb1cccf77d2a81a75840db737cf641a936 SHA1 c46926839bc99ede02aaa21709fcd702c7fefa08 SHA256 bf2c6a9db29e0e3a39ae345bafe0cb43dde0330348e4c8922dc9e10924d46139
MISC metadata.xml 264 RMD160 3cb995676f964b9637fbfc0027a81b9409802608 SHA1 c4d35e3a71c545cdf1aae525de803126bf54f596 SHA256 9bd1ce830cf1b821978ab90c81b2e369177a8d7c1bfe2dd2868419872c097f64
diff --git a/sys-boot/grub/grub-1.99.ebuild b/sys-boot/grub/grub-1.99.ebuild
index c229a4c..1f19fd3 100644
--- a/sys-boot/grub/grub-1.99.ebuild
+++ b/sys-boot/grub/grub-1.99.ebuild
@@ -26,7 +26,7 @@ SLOT="2"
[[ ${PV} != "9999" ]] && KEYWORDS="~amd64 ~x86 ~mips ~ppc ~ppc64"
IUSE="custom-cflags debug device-mapper nls static sdl truetype"
-GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips yeeloong"
+GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips yeeloong"
# everywhere:
# emu
# mips only:
@@ -34,9 +34,9 @@ GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips
# amd64, x86, ppc, ppc64
# ieee1275
# amd64, x86
-# coreboot, multiboot, efi-32, pc, qemu
+# coreboot, multiboot, efi_32, pc, qemu
# amd64
-# efi-64
+# efi_64
for i in ${GRUB_PLATFORMS}; do
IUSE+=" grub_platforms_${i}"
done
@@ -132,16 +132,16 @@ grub_src_configure() {
# check if we have to specify the target (EFI)
# or just append correct --with-platform
if [[ -n ${platform} ]]; then
- if [[ ${platform/-*} == ${platform} ]]; then
+ if [[ ${platform/_*} == ${platform} ]]; then
platform=" --with-platform=${platform}"
else
# EFI platform hack
- [[ ${platform/*-} == 32 ]] && target=i386
- [[ ${platform/*-} == 64 ]] && target=x86_64
+ [[ ${platform/*_} == 32 ]] && target=i386
+ [[ ${platform/*_} == 64 ]] && target=x86_64
# program-prefix is required empty because otherwise it is equal to
# target variable, which we do not want at all
platform="
- --with-platform=${platform/-*}
+ --with-platform=${platform/_*}
--target=${target}
--program-prefix=
"
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index c229a4c..7ae0b4e 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -26,17 +26,17 @@ SLOT="2"
[[ ${PV} != "9999" ]] && KEYWORDS="~amd64 ~x86 ~mips ~ppc ~ppc64"
IUSE="custom-cflags debug device-mapper nls static sdl truetype"
-GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips yeeloong"
+GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips loongson"
# everywhere:
# emu
# mips only:
-# qemu-mips, yeelong
+# qemu-mips, loongson
# amd64, x86, ppc, ppc64
# ieee1275
# amd64, x86
-# coreboot, multiboot, efi-32, pc, qemu
+# coreboot, multiboot, efi_32, pc, qemu
# amd64
-# efi-64
+# efi_64
for i in ${GRUB_PLATFORMS}; do
IUSE+=" grub_platforms_${i}"
done
@@ -132,16 +132,16 @@ grub_src_configure() {
# check if we have to specify the target (EFI)
# or just append correct --with-platform
if [[ -n ${platform} ]]; then
- if [[ ${platform/-*} == ${platform} ]]; then
+ if [[ ${platform/_*} == ${platform} ]]; then
platform=" --with-platform=${platform}"
else
# EFI platform hack
- [[ ${platform/*-} == 32 ]] && target=i386
- [[ ${platform/*-} == 64 ]] && target=x86_64
+ [[ ${platform/*_} == 32 ]] && target=i386
+ [[ ${platform/*_} == 64 ]] && target=x86_64
# program-prefix is required empty because otherwise it is equal to
# target variable, which we do not want at all
platform="
- --with-platform=${platform/-*}
+ --with-platform=${platform/_*}
--target=${target}
--program-prefix=
"