summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-19 09:12:56 +0200
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-19 09:12:56 +0200
commit0ebd8ed2794dbc81b319c247934e68bf01420223 (patch)
treeb96a56c61251fee5796b5d582e166c516401eb7d /sys-boot/grub/grub-9999.ebuild
parent[sys-boot/grub] Inform user to install the grub. (diff)
downloadscarabeus-0ebd8ed2794dbc81b319c247934e68bf01420223.tar.gz
scarabeus-0ebd8ed2794dbc81b319c247934e68bf01420223.tar.bz2
scarabeus-0ebd8ed2794dbc81b319c247934e68bf01420223.zip
[sys-boot/grub] Fix eautoreconf failing the phase.
Diffstat (limited to 'sys-boot/grub/grub-9999.ebuild')
-rw-r--r--sys-boot/grub/grub-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index b2d01f5..38ae008 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -61,8 +61,9 @@ src_prepare() {
# autogen.sh does more than just run autotools
if [[ ${PV} == "9999" ]] ; then
- sed -i -e '/^autoreconf/s:^:e:' autogen.sh || die
+ sed -i -e '/^autoreconf/ d' autogen.sh || die
(. ./autogen.sh) || die
+ eautoreconf
fi
}