summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-9999.ebuild')
-rw-r--r--sys-boot/grub/grub-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 7ae0b4e..f0bc2bf 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -26,7 +26,7 @@ SLOT="2"
[[ ${PV} != "9999" ]] && KEYWORDS="~amd64 ~x86 ~mips ~ppc ~ppc64"
IUSE="custom-cflags debug device-mapper nls static sdl truetype"
-GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips loongson"
+GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips loongson"
# everywhere:
# emu
# mips only:
@@ -34,9 +34,9 @@ GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips
# amd64, x86, ppc, ppc64
# ieee1275
# amd64, x86
-# coreboot, multiboot, efi_32, pc, qemu
+# coreboot, multiboot, efi-32, pc, qemu
# amd64
-# efi_64
+# efi-64
for i in ${GRUB_PLATFORMS}; do
IUSE+=" grub_platforms_${i}"
done
@@ -132,19 +132,19 @@ grub_src_configure() {
# check if we have to specify the target (EFI)
# or just append correct --with-platform
if [[ -n ${platform} ]]; then
- if [[ ${platform/_*} == ${platform} ]]; then
- platform=" --with-platform=${platform}"
- else
+ if [[ ${platform} == efi* ]]; then
# EFI platform hack
- [[ ${platform/*_} == 32 ]] && target=i386
- [[ ${platform/*_} == 64 ]] && target=x86_64
+ [[ ${platform/*-} == 32 ]] && target=i386
+ [[ ${platform/*-} == 64 ]] && target=x86_64
# program-prefix is required empty because otherwise it is equal to
# target variable, which we do not want at all
platform="
- --with-platform=${platform/_*}
+ --with-platform=${platform/-*}
--target=${target}
--program-prefix=
"
+ else
+ platform=" --with-platform=${platform}"
fi
fi