summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2014-02-22 12:07:08 +0100
committerRalph Sennhauser <sera@gentoo.org>2014-02-22 12:07:08 +0100
commitda9824bc03b8440ad9910c78b90a9850d18d7c7f (patch)
treee50e7be94f49ee3ca7cd3745a42220bcd3e02b0f /x11-misc
parentevas_generic_loaders-1.8.1: Fix slot dep on poppler (diff)
downloadsera-da9824bc03b8440ad9910c78b90a9850d18d7c7f.tar.gz
sera-da9824bc03b8440ad9910c78b90a9850d18d7c7f.tar.bz2
sera-da9824bc03b8440ad9910c78b90a9850d18d7c7f.zip
entrance-9999: Use upstream unit file
Package-Manager: portage-2.2.8-r1 Manifest-Sign-Key: 3C5CF75A
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/entrance/entrance-9999.ebuild9
-rw-r--r--x11-misc/entrance/files/0001-disable-check-for-systemd.patch36
2 files changed, 42 insertions, 3 deletions
diff --git a/x11-misc/entrance/entrance-9999.ebuild b/x11-misc/entrance/entrance-9999.ebuild
index dab3b81..269eb9c 100644
--- a/x11-misc/entrance/entrance-9999.ebuild
+++ b/x11-misc/entrance/entrance-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit autotools git-2 pam systemd
+inherit autotools eutils git-2 pam
DESCRIPTION="Display-manager based on efl"
HOMEPAGE="http://www.enlightenment.org/"
@@ -24,9 +24,11 @@ RDEPEND="
consolekit? ( sys-auth/consolekit )
pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}
+ !<sys-apps/systemd-192
virtual/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/0001-disable-check-for-systemd.patch
eautoreconf
}
@@ -36,6 +38,8 @@ src_configure() {
$(use_enable ekbd)
$(use_enable grub2)
$(use_enable pam)
+ # only installs unit file for now
+ --enable-systemd
)
econf "${config[@]}"
@@ -45,5 +49,4 @@ src_install() {
default
newpamd "${FILESDIR}"/entrance.pamd entrance
- systemd_dounit "${FILESDIR}"/entrance.service
}
diff --git a/x11-misc/entrance/files/0001-disable-check-for-systemd.patch b/x11-misc/entrance/files/0001-disable-check-for-systemd.patch
new file mode 100644
index 0000000..5adee2f
--- /dev/null
+++ b/x11-misc/entrance/files/0001-disable-check-for-systemd.patch
@@ -0,0 +1,36 @@
+From bd0486e720178009cc839cb813d669f4b4fc0051 Mon Sep 17 00:00:00 2001
+From: Ralph Sennhauser <sera@gentoo.org>
+Date: Sun, 16 Feb 2014 11:15:52 +0100
+Subject: [PATCH] disable check for systemd
+
+Gentoo installs unit files unconditionally so long this is all that is
+needed for systemd support. A blocker could be used should the version
+of systemd be a concern.
+---
+ configure.ac | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4b9d39c..aaf80a8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -155,11 +155,11 @@ if test "x${enable_pam}" = "xyes" ; then
+ fi
+
+ # Systemd
+-if test "x${enable_systemd}" = "xyes" ; then
+- PKG_CHECK_EXISTS([systemd >= 192],
+- [enable_systemd="yes"],
+- [enable_systemd="no"])
+-fi
++#if test "x${enable_systemd}" = "xyes" ; then
++# PKG_CHECK_EXISTS([systemd >= 192],
++# [enable_systemd="yes"],
++# [enable_systemd="no"])
++#fi
+ AM_CONDITIONAL(HAVE_SYSTEMD, [test "x${enable_systemd}" = "xyes"])
+
+ ### Checks for header files
+--
+1.8.3.2
+