summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-11 17:17:41 +0200
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-11 17:17:41 +0200
commit223eeba44c0bbfe2c87da47a7efb701fa137df75 (patch)
tree505802b4cef6b7eb8b0645ba9cc207271a9b14b9
parentInitial repo commit (diff)
downloadsochotnicky-223eeba44c0bbfe2c87da47a7efb701fa137df75.tar.gz
sochotnicky-223eeba44c0bbfe2c87da47a7efb701fa137df75.tar.bz2
sochotnicky-223eeba44c0bbfe2c87da47a7efb701fa137df75.zip
Adding net-p2p/Circle-0.41c
-rw-r--r--net-p2p/Circle/Circle-0.41c.ebuild51
-rw-r--r--net-p2p/Circle/Manifest4
-rw-r--r--net-p2p/Circle/metadata.xml5
3 files changed, 60 insertions, 0 deletions
diff --git a/net-p2p/Circle/Circle-0.41c.ebuild b/net-p2p/Circle/Circle-0.41c.ebuild
new file mode 100644
index 0000000..3eb70c2
--- /dev/null
+++ b/net-p2p/Circle/Circle-0.41c.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/Circle/Circle-0.41c.ebuild,v 1.4 2005/09/06 21:49:32 sekretarz Exp $
+
+inherit python
+
+DESCRIPTION="The Circle messaging and file sharing system"
+HOMEPAGE="http://thecircle.org.au/"
+SRC_URI="http://thecircle.org.au/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="vorbis gnome"
+
+DEPEND="virtual/python
+ >=dev-python/pygtk-1.99.14
+ >=x11-libs/gtk+-2
+ vorbis? ( dev-python/pyogg
+ dev-python/pyvorbis )
+ gnome? ( dev-python/gnome-python )"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ python_version
+ exeinto /usr/bin/
+ doexe circle
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/
+ doins circlelib/*.py
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/pixmaps/
+ doins circlelib/pixmaps/*
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/crypto/
+ doins circlelib/crypto/*
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/ui_gtk/
+ doins circlelib/ui_gtk/*
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/ui_http/
+ doins circlelib/ui_http/*
+ insinto /usr/lib/python${PYVER}/site-packages/circlelib/ui_text/
+ doins circlelib/ui_text/*
+ insinto /usr/share/pixmaps/
+ doins circle-icon.png
+ if use gnome ; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins circle.desktop
+ fi
+ dohtml circlelib/*.html
+ dodoc NEWS PKG-INFO README
+}
diff --git a/net-p2p/Circle/Manifest b/net-p2p/Circle/Manifest
new file mode 100644
index 0000000..d4f4bc4
--- /dev/null
+++ b/net-p2p/Circle/Manifest
@@ -0,0 +1,4 @@
+DIST Circle-0.41c.tar.gz 670536 RMD160 0c6f0631d081a6d7d86361a420f3eb05ce18d236 SHA1 a498d8285b6395cc08f302dd89e22307adf5606b SHA256 2b9745dafbfb66488c638cd065773446a131a87e95c2d6069165133b0a1a7fbc
+EBUILD Circle-0.41c.ebuild 1455 RMD160 165eb301798e7889fdfda55174387e615a19956e SHA1 ff57609c6e7bd644f591620799580165c6445ebc SHA256 448a5fa4b3c4fb1b5007dedcdaac9c448d71e0b76ec579faa5dd8341970427b3
+MISC ChangeLog 1562 RMD160 5ca6b863f27d53f60fcf717f281cd0e6262bea7f SHA1 a88632a837329cb25f0c3c94c1048e20a7875d85 SHA256 c804b29c8e9c52094c86f1a3905546975674ebdd68229499f0a0fff0fd9eadaf
+MISC metadata.xml 160 RMD160 828887200387b28c37fc97111fc6bc3a0a2fcccd SHA1 813ef5bc57f6a8d95e7cab7a745a2a824858f49c SHA256 fe06593409e7f28665c032001005e94cb650299711a0af7f1a558bdb56c4004f
diff --git a/net-p2p/Circle/metadata.xml b/net-p2p/Circle/metadata.xml
new file mode 100644
index 0000000..aa0f366
--- /dev/null
+++ b/net-p2p/Circle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>