summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-05-20 08:56:42 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-05-20 08:56:42 +0000
commit478251c09ccb8e2bc0e5562348502ecd87f0f512 (patch)
tree8b26d7ffe50f7fb5f2d122dbce4ba3c5cf14d0b7
parentAdd newer shotwell with dark theme patch (diff)
downloadsuka-478251c09ccb8e2bc0e5562348502ecd87f0f512.tar.gz
suka-478251c09ccb8e2bc0e5562348502ecd87f0f512.tar.bz2
suka-478251c09ccb8e2bc0e5562348502ecd87f0f512.zip
Updated gnome-online-accounts with exchange support (not used yet by any application though)
svn path=/; revision=330
-rw-r--r--net-libs/gnome-online-accounts/Manifest3
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.5.1.ebuild62
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild62
3 files changed, 127 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
new file mode 100644
index 0000000..5a40103
--- /dev/null
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-online-accounts-3.5.1.tar.xz 517148 RMD160 35132075da63672e634236edd0c61b07d8bcbaa6 SHA1 ac8f886f97c65d898c76a428f004d1beaf0702dc SHA256 0944d1dc2ebf6fdadede6a469e453cd2829180029e72d367c444bcc17d145785
+EBUILD gnome-online-accounts-3.5.1.ebuild 1567 RMD160 ca5bc1b08e15081a7e1099a97b58c0305b7dd6a9 SHA1 957866d0327105f48a92705106ed863e93449532 SHA256 e82c7732e3a160accaf000960a0179e7c3ef0a722ddc4dd214a8accee066e9cd
+EBUILD gnome-online-accounts-9999.ebuild 1567 RMD160 ca5bc1b08e15081a7e1099a97b58c0305b7dd6a9 SHA1 957866d0327105f48a92705106ed863e93449532 SHA256 e82c7732e3a160accaf000960a0179e7c3ef0a722ddc4dd214a8accee066e9cd
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.5.1.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.5.1.ebuild
new file mode 100644
index 0000000..477bef7
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.5.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild,v 1.1 2012/05/06 09:15:10 tetromino Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc gnome +introspection"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2
+ dev-libs/json-glib
+ gnome-base/libgnome-keyring
+ net-libs/libsoup:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.0.0:3
+ >=x11-libs/libnotify-0.7
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+pkg_setup() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-documentation
+ --enable-exchange
+ --enable-facebook
+ --enable-windows-live"
+ DOCS="NEWS" # README is empty
+}
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
new file mode 100644
index 0000000..477bef7
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild,v 1.1 2012/05/06 09:15:10 tetromino Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc gnome +introspection"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2
+ dev-libs/json-glib
+ gnome-base/libgnome-keyring
+ net-libs/libsoup:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.0.0:3
+ >=x11-libs/libnotify-0.7
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+pkg_setup() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-documentation
+ --enable-exchange
+ --enable-facebook
+ --enable-windows-live"
+ DOCS="NEWS" # README is empty
+}