summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-11-30 08:29:39 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-11-30 08:29:39 +0000
commit7a9c9b08b84a338bee27c4c9c64020c50e171df6 (patch)
treee6e705f7c3f07b3d2ebc910fbfd3f5ea86734cbe /gnome-base/libgnomekbd
parentuse gvfs from dev cycle (diff)
downloadsuka-7a9c9b08b84a338bee27c4c9c64020c50e171df6.tar.gz
suka-7a9c9b08b84a338bee27c4c9c64020c50e171df6.tar.bz2
suka-7a9c9b08b84a338bee27c4c9c64020c50e171df6.zip
some masked bumps, as new libnotify breaks lots of stuff
svn path=/; revision=322
Diffstat (limited to 'gnome-base/libgnomekbd')
-rw-r--r--gnome-base/libgnomekbd/Manifest2
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/Manifest b/gnome-base/libgnomekbd/Manifest
new file mode 100644
index 0000000..c6a5274
--- /dev/null
+++ b/gnome-base/libgnomekbd/Manifest
@@ -0,0 +1,2 @@
+DIST libgnomekbd-2.91.2.tar.bz2 419884 RMD160 30e75e213acac55dde10b863ca37ea2647edb14a SHA1 1d39fc951a02c5ebe8502f4ed9a20fce3162b6ba SHA256 fb24ba2b429911987851d46b281f13831704cc1bc9a2f6d32ae6cb78bc0ab872
+EBUILD libgnomekbd-2.91.2.ebuild 1061 RMD160 197a78bd21edc41689f0834c98397bedac4bd0db SHA1 1ae54a6624ea7d466f02ae9c350b7084374a76bd SHA256 557f8bc064904e1c005fb04e3494a6493a062769bd98ce817e2b188d0b5eec33
diff --git a/gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild b/gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild
new file mode 100644
index 0000000..8dd54bb
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild,v 1.1 2010/06/13 16:47:46 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=sys-apps/dbus-0.92
+ >=dev-libs/dbus-glib-0.34
+ >=x11-libs/gtk+-2.90:3
+ >=x11-libs/libxklavier-5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # Only user interaction required graphical tests at the time of 2.22.0 - not useful for us
+ G2CONF="${G2CONF} --disable-tests --disable-static"
+}
+
+src_compile() {
+ # FreeBSD doesn't like -j, upstream? bug #????
+ use x86-fbsd && MAKEOPTS="${MAKEOPTS} -j1"
+ gnome2_src_compile
+}